My Wyze Robot Vacuum is Officially a Lemon

At this point, there’s no other word for my robot vacuum than “lemon.” It simply does not work as it should. People post valid complaints daily about the terrible mapping, yet it only seems to get worse. My house hasn’t been thoroughly (or even barely adequately) cleaned by the vacuum in months, primarily because the mapping does more harm than good. It is constantly getting “lost” in a space that never changes (and I never move the charging base). Even when the map looks correct, trying to spot clean a room - 10 feet in a straight line from the base - causes it to go off half-cocked at an angle, spin around a few times bumping repeatedly into the same chair, then triumphantly declaring “Cleaning complete!” when it never got anywhere near the room I selected. When I check the cleaning records, the map looks nothing like the main map in the app.

Wyze should disable the mapping and let the device run randomly. My first robot vacuum was strictly random movements with no mapping of any kind and it absolutely 100% did a better job at cleaning the entire house and finding its way home than this Wyze model. All I want the damned thing to do make a pass through my kitchen, but because the mapping is so screwed up - and the vacuum is so dependent on it - I cannot get it go to that room, and I can’t place the vacuum there without it throwing a fit when it isn’t where it expected to be. I finally pulled my old vacuum old and cleaned the kitchen manually. To say this defeats the purpose of the vacuum is an understatement.

I realize it works better for some than others, but the whole point of this is that it’s supposed to quietly, efficiently, and effectively do it’s job without your intervention (other than to clean out the dustbin). Instead I’m constantly babysitting this [mod edit] vacuum with my fingers crossed that it won’t get hopelessly lost - or hunting for it under furniture when it gets stuck, runs down its battery doing who-knows-what, and disconnects from the network. Or cajoling it - trying to TRICK it into doing a half-assed job.

It’s a defective product, and Wyze either needs to release a software update that fixes it, or issue a recall for anyone who’s tired of fussing with it.

MOD NOTE: Post edited to conform to the Community Guidelines.


I certainly feel your pain. I ran the mapping first time it worked great, Ran manual clean on each room it worked great. Set up a schedule next day, it started of great until It got stuck on a chair leg, out of all things a damn chair leg. I have it a little nudge and it just went down hill from there, it started going in circles, back and forth just confused all around.

I decided to send it back home, well it had different plans it went in to the closed and it couldn’t get out. I had to carry it to the base, well guess what it remapped the house and moved the gateway outside of the house map. Base originally was in the dining room corner.


I’m beginning to think it missed its calling. All these room maps you guys post are great. This should be sold for furniture and cabinet planning and interior design. Meanwhile my dumb old robot vacuum continues to do its job. I had to nudge it around a chair leg with my foot just this week and it went merrily and dopily along. Heck, I just remembered it has an “edge” cleaning mode where it hugs a perimeter all around the house. It worked great!

I’m not an expert on the vacuum, so I don’t have any solutions for you. But have you tried contacting Customer Support (206) 339-9646 Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT to see if they do?


Yes. And I did a factory reset, as advised. This “fixed” the vacuum for about a week (not quite). But then today…like clockwork…it went off the rails. I watching the magical moment while cleaning my living room where it lost all sense of its location, and proceeded to attempt to clean while thinking it was in an entirely different location than where it actually was. I got tired of watching it stupidly, hopelessly stumble about so I sent it back to the charger. Of course, because it was actually in the kitchen when it thought it was in the living room, it took 10 minutes of stupidly, hopelessly stumbling about to find its way home.

The new beta firmware being tested has a fix (and posted explanation) of what was leading the to the drunken driving/mapping. If you feel brave sign up and test by updating and remapping!

How do you sign up for beta software? link?

I feel your pain as my WKYZE Headphones keep crashing every 20 minutes and after all this time, still NO fix for it!!!

On the other hand, my Wyze Vacuum works great. I had a ROOMBA in the past, and it did its the whole bumping into everything and having to block off areas I didn’t want it to go into.

I have to say for the most part this Wyze Vacuum has been working great for me. It has my house all mapped out great. I divided the rooms myself better. I have up VIrtual walls in a few places like bathrooms, or areas it could get trapped into. It really works well going around the room walls and then filling inside of them. Rarely hits anything. I can pick a room and it’ll go there and clean it. I pick a few rooms and it’ll do those, or have it clean my whole house.

My complaints are battery life which seems a little weak. My house is not that big, but it can’t seem to finish my whole house on a single charge. So it’ll do what it can, go back and charge up and then finish. It also doesn’t look like it’s replaceable. At least I haven’t seen any easy way to replace the battery as I could on my Roomba. Also, the garbage bin is SMALL!!! It really doesn’t take much to fill it up. My old ROOMBA was at least twice as big if not 3 times. It’s pretty small.

Overall it’s good. It can work in the dark as it’s using LIDAR. Some other vacuums use Cameras that don’t work well or at all in the dark. So I can have it clean when in bed, or better yet, clean while I’m not home and empty out the bin when I get home. It also has only a single roller under it, where my old Roomba and most others have a duel roller setup.

Pro’s and Con’s!!! For the most part, it does a good job and works well. I can watch it do its thing on my iPhone or iPad. But of course, there is room for improvement. But since I’m on this topic, I just started it up to clean a couple of rooms while I’m away and can watch it and see where exactly it’s at and what sections it had already gone over.

I’m not happy either with my vacuum. Constantly having mapping issues. It’s getting stuck under furniture that is mapped off and it keeps disconnecting from the internet. We’re not having any issues at all with our home internet. I’m about tired of it!

I have same issues with lost robot vacuum… it’s stupid silly . I have mine in a RECTANGULAR room with very little furniture, and none low enough to cause the robot to get stuck. But it constantly loses all sense of where it is…searches until it’s out of power and then I search for it and start over…

Frustrating. Would not buy again… seems like an on board computer could figure out the basic navigation… it can “see” the base station almost 100pct of the time.

Those of you with these issues should sign up for the beta firmware if you’d like it fixed now. Otherwise they will likely make this beta firmware official soon. It does help the majority of the drunken mapping / driving

Good Idea. I’m using the Beta software myself. It works just fine for me. Not saying others aren’t having issues. I’m having issues with my Wyze Headphones. They don’t seem in any hurry to fix those, making them almost worthless. So I get it with the Vacuum. If it’s just not cutting it for you, return it. If y ou can, give the Beta firmware a try if you havn’t.

Is the beta software on the app?

You have to be using the Beta software of the Wyze app to get beta firmware. But it looks like the Beta version was just released to the public anyway. So there is no newer beta version now.

Mine does the exact same thing. I send it to the far reaches of the house… it gets halfway there and decides it’s done and heads back home. Also I cannot get it to clean 2 rooms. That is too confusing so I have to send it one room at a time. I loved its base a few weeks ago and it continues to say the old base is where it use to be in the map but returns back to the new base… totally frustrating. How do I beta test? I’ve signed up and downloaded TestFlight but received no instructions past that.

Well, you need to get the Wyze Beta app in Testflight. When you sign up, it should tell you how to do that. After you install Testflight, the next step is clicking on that link they give you with your iOS device. Did you do that? It’s a simple 1, 2, 3 steps, Pretty simple!!!

As I said above, the Beta version has been released and so Beta and release versions should be the same version number, Wyze Beta is at 2.19.16 and the Vacuum firmware is at 1.6.113.

All I know is it seems to work just fine at my house with the one I have. I can have it clean my whole house or pic what rooms to clean and it does it. I had to manually split some rooms and then name them. You can see my Map below.

Now there are some issues I’m not a fan of. I don’t think it has a very big battery. I can’t finish my 1100 sq foot house on a single charge at high suction. So it has to go back to base, charge up and then finish the job. I also think the dust bin is pretty small. How much having a single brush under to the normal duel brush setup I’m used to in cleaning abilities?!?! It works pretty well. It is picking things up, It does overall work. The VIrtual walls have been working great for me. It can work in the dark because it’s using Lidar and not cameras. It doesn’t go crashing into everything like my older Roomba would do. For the price of $199 that I paid for it, pretty good deal.

But if you are still having issues, you’re having issues. I’ve been having issues for months on end with the Wyze Headphones which they seem in no hurry to fix. They’re slow on updates for the Vacuum also. Who knows, maybe it’s just a Lemon.

You can see on my map, I’m not blocking out these huge sections. It’s a small wall so it won’t go through a doorway. Or go into a section where it could get trapped. Keep it simple. I can be at work and start it up, and watch it as it’s laying down it’s paths as it goes along. That’s pretty cool. So when it works, great, when it doesn’t,… That’s not fun.

My vac is terrible too. I’ve stopped considering any Wyze product because they talk big but where is the follow thru. So many features promised they haven’t delivered plus the stupid thing has been circling a table now for 40 minutes. It can’t clean a one level simple layout house correctly. Hopefully it runs out of power soon. Certainly not ready for prime time!

1 Like

You can manually power it down and then power it back up. That may fix the issue? Or you could have a Lemon.

My Wyze Headphones I’ve had for 9+ months now and they still can’t fix the approx 20-minute crashing issue!!! I even got a second pair and it has done the same thing, Wyze just doesn’t seem to care and so I’ve stopped buying anything from Wyze and I have most of their products and would be buying the newest things, but I’ve refused. They are throwing everything out there and moving on without fixing the issues the current products have.

Again, my Wyze Vacumme works pretty well. I had a Wifi connection issue once. I turned it off and turned it back on and it connected and has been fine sense then for me. So has their other products. Other than lack of Homekit support, OK, I knew that going in, not a deal-breaker for me in most of the products. The Wyze Headphones crashing over and over and over again and doing nothing about it. I’m not happy about that.

40 minutes of circling the table, strange, that sucks!!! I think you hold the power button down and it’ll power off. Then hold it down again to power and boot back up. I think that was what I did. Give that a try so you don’t have to wait for the battery to go dead.

The last 2 posts are FIVE MONTHS after the rest?

Yes, so what. Different person with a similar complaint. What is unusual about that?