Robot vacuum mapping issues

I have two wyze vacuum cleaners. One works great the other doesn’t follow the map, it’s never worked well. I’ve tried resetting, remapping, and reinstalled the unit. The map turns diagonally… the vac gets lost…, and goes in circles… and can’t find the charger. I’m obviously using the same OIS software for both, and the software in both units is the same 1.6.113. Has anybody figured this out? It’s strange that one of the vacuums works great and the other is a lemon.

Check if there’s any dust on the LIDAR sensor. It’s the circular thing on top of the robot, and around the sides is the sensor. Try blowing it out with spray air


Try selecting a different room than it usually starts in and see if it works. I’ve been able to “fix” mine by splitting the room a bit differently causing the robot to clean using a different path/order. My map does the rotation thing when the issue happens. I have 1.6.173 beta.

It’s always been downstairs, which has dark carpet, so maybe an issue with false cliff detection.

Ok thanks I’ll move it and remap. How do I get the latest beta version that you have? Mine says up to date?

Just tried moving it and remapped. It maps perfectly. However it still does not follow the map. It gets completely confused and lost

Was supposed to clean these two rooms. Here’s the result

Is there anything reflective like a mirror at floor level? That can confuse the robot.

I assume you cleaned the sensor like mentioned by IEatBeans?

I’ve been stuck on this buggy beta version since I updated to it, soon after getting the vacuum.

I have it working reliably now. Two things helped. Cleaning the LiDAR sensor and anchoring the base station / charger to the wall. The base station is on carpet and gets moved slightly every time the unit parks. I bought a dock bracket on Etsy the resolves the movement issue

1 Like