Robot vacuum unusable

Had my wyze vacuum awhile but just set it up about a week ago. WOW what a disappointment. First I couldn’t get it to map while it was cleaning. After numerous tried I finally just did a quick mapping and at least got a few rooms to map. Then I ran it on a 3 rooms successfully. So I set up a schedule and it never ran on the schedule. I then tried to run it manually and it skews the map and gets lost and can’t even get home. I have bragged on wyze for a long time and own several of the products. I even pay a monthly fee (when I could have got it for free) because I really believe in their company and was so happy with their products. But I’m just as disappointed in this robot vacuum. Is mine bad or are others having this much trouble?

I’m not having the problems you’re describing.

No such issues for me. Be sure to update firmware and remove shipping foam blocks underneath. My first mapping was skewed a bit but that didn’t cause problems other than less-than-optimal cleaning paths. I ran another map-only run and it straightened out.

I just received a replacement for a vac that wouldn’t set up and am having problems similar but not identical to yours with the new one.

I’m on Wyze app beta 2.17.31.

  1. It successfully mapped although it needed a recharge to complete it.

  2. I edited the map to rename the rooms and delineate the borders

  3. This morning it would not respond to the app when I told it to clean

  4. I pushed the button on the vac to begin a manual clean. It efficiently cleaned the first room (I was following it on the map).

  5. It got lost in the second room and didn’t finish. It then began creating phantom rooms on the map and returned to the first room. It was doing a new pattern in that room and knocked over the charging base.

  6. I pushed pause and told it to return to the charger. It couldn’t find the charger.

  7. I manually turned the vac off and carried it to the charger

  8. I reset the map - took three tries.

  9. Vac would not respond to the “quick mapping” request (app says it was mapping but then bails)

  10. I hard reset the vac. No response to quick mapping.

  11. I deleted the device from the app and re-added it. No response from the app (but it retained some of my settings (quiet suction). The device shows no IP address.

  12. I deleted the device again. I hard reset the vac. I re-added a device with a different name. It still retained the quiet suction mode). The device would not respond to the app and it again shows no IP address. The former IP address from the first setup shows as still connected to my network with an excellent signal.

I submitted a ticket and got an auto response that included this article:

It contained this nugget:

  • Wyze Robot Vacuum was unable to complete the first clean on its first battery charge, which can cause issues during the next session.

And this:

Troubleshooting Tips:

  • Do not interrupt or move the vacuum during a clean. It will not save the map.
  • If the vacuum stops to charge mid-clean, it will not save the map.
  • Reset the map, then start a “Clean” with the vacuum starting at the charging station and returning to the charging station with no interruptions during the clean.

I rebooted my router and the vac successfully connected and got a new IP address.

It still wouldn’t respond to a request for “quick mapping” from the app, but I started a manual clean and it is going and creating a new map.

This did it; vac now responds to commands from app and properly vacuums the house.

Why so salty?

The OP asked: