Welp...My vacuum has gone stupid again

It was a bit of a struggle at first, but it seemed that the fine folks at Wyze had squashed enough bugs that the vacuum was able to do a serviceable job at cleaning my floors.
Welp, I don’t know if it was the last update or what, but it’s gone stupid again. It can’t get to rooms that are clearly mapped, it gets lost going home, it gets stuck on invisible obstacles in the middle of the room, it stupidly runs into the same actual object over and over and over and over and over and over seemingly hoping it will magically vanish, it skips rooms and then says it cleaned them. I just reset the map so I had a nice, clear one that matched my actual home, and darn it the thing cannot for the life of it find its way to my bedroom.
And of course because it always has to start at the charging station, I can’t just pick it up and put it down in my bedroom. So it is effectively impossible to get this “smart” dumb vacuum to, ya know, vacuum rooms in my house.
C’mon guys…you’re not exactly at the bleeding edge here. Robot vacuums have been around for 20 years.

1 Like

You had me at welp. :grin:

Agree, they need to do better. Best of luck. :slight_smile:

Sorry about these issues. Have you moved stuff around recently, or do you have any large boxes that were placed after mapping? When it runs, does the map look right in the app, it’s not creating a new one or rotating the map? Do you have any reflective surfaces down at the vacuumed level?

I tidied up the entire house to get things off the floor that may not be permanent (for example, an ottoman that sometimes gets moved around), then I reset the map and the vacuum created a new, very accurate model of the entire house. The next time I tried to clean with it, it got stuck in the middle of a rug and just ran over and around that spot repeatedly until it had to stop to return to the charger because the battery was low. Once it returned to the charger, I stopped that cleaning cycle because I didn’t want it to go back to that spot again and continue endlessly spinning around it. Instead, there was only 1 room left it hadn’t cleaned - the bedroom - so I picked that room and tried to spot clean it. The vacuum made a bee line in that direction where it ran into the legs of a grand piano (which had been there before) and instead of going around them (which there was plenty of room to do), it just kept trying to transmogrify itself or the piano to allow the matter to pass through. After a few minutes of that, it announced that cleaning was complete, turned around and went back to its station.

No - there are no reflective surfaces at the vacuumed level, but it was a colorful rug that it got “stuck” on (not literally…it’s a very short rug - like office carpet), but just kept spinning around this one area. I thought perhaps the pattern was confusing it, but it seems like it shouldn’t do that.

What color/pattern is the rug? If darker/patterned it could be confusing the Cliff sensors. Possibly lighter on the outside, darker in the center?

Cannot speak to the attempt to pass through the piano legs. Other than the standard Ensure up to date firmware and Wyze App. Which I would infer based on the above that you have done.

When you re-mapped did you do a full or quick map?

While I suspect not, has the base been moved since remapping? This could cause some unwanted behavior in the WRV knowing where it is.

A support ticket with a Log could be warranted but my guess is up front they would ask you to Remove and Re-add of the device ensuring the device is on the latest Firmware and App, doing a full map and seeing if the same behavior continues.

1 Like

I appreciate all your suggestions, but they don’t really apply to my situation (and anything that does apply I’ve already tried). The truth is that the burden is on Wyze to address these issues, not to require all manner of rituals by the user to try and cajole their product to perform as it should. As noted in my original post, robot vacuums have been around for 20 years and the basic requirements haven’t really changed much since.

As far as I’m aware your the only one seeing this issue, so we must find the cause before Wyze can fix it. Make sure the LiDAR sensor is clean, if you can spray some canned air into the hole on the sensor that may help. Can you get a sceeenshot of the map when the vacuums mid run, like maybe 20 mins in?