Vacuum stopped working after about a week

So we got our vacuum, set it up, and for a week, it worked so good! We ran it like twice a day for both kicks for the kids, and because it was picking up so much trash!
Then we moved it upstairs, mapped the rooms, and let it clean upstairs for a couple of days. It did great. We’re planning on buying one for each floor now.

However, since moving the vacuum back downstairs, It hasn’t been able to complete a single cleaning. It maps everything with a slight curve to it. The previous maps aligned to the grid in the app. The maps now are all skewed and slightly curved between rooms as if one end of the walls are thicker than the other end. I send the little guy to clean and he makes his way around the parameter for about 3 minutes, then decides he’s all done cleaning and returns to base. Occasionally, I can get it to clean a room, but then it gets confused and remaps itself into a different part of the map, redrawing the floorplans over the old one, making our house look much more confusing than it is. It sometimes won’t go back to the charging station and dies along the way, even if I started it at 100% battery. It just spends that long trying to figure out how to get back.

Anyone else having this issues? I’ve factory reset the robot, removed and readded it to the app, cleared the map, checked the app version and firmware version, checked the wheels and everything for obstructions, and it seems to just be getting worse.


I had a similar issue, except I never moved mine between floors.

Vacuum ran and worked flawlessly for 5-6 days back in late December/early January right after I received it. Then, for no apparent reason, I could no longer run the vacuum using a saved map because it would start drawing over the top of the existing map and thinking it was somewhere other than it actually was/should’ve been. I have to delete the map after every cleaning and then re-add all the virtual walls in the middle of each cleaning-every single time I want it to run.

Call support tomorrow, it’ll get resolved much quicker than trying to get a response for email ticket.

So after reaching out to support you’re still having to delete the map each cleaning?
How did they resolve your issue?

After troubleshooting and confirming it wasn’t an app or firmware generated error, they’re replacing it.

my vacuum quit working after a firmware update. I have put in a half a dozen support requests. Someone from Wyze told me to reset it which I did. No help. A total lack of help from Wyze support.