Weird Vaccum Mapping

I’ve been enjoying my vaccum for the most part, but I have those one really bad bug. Essentially, what happens is my house is getting mapped twice. It will go good for the first 20 minutes or so then once it hits a certain point it basically mirrors the floor horizontally on the map. It then tries to vaccum that fake map, which makes it vaccum some areas twice and it takes twice as long to finish. Has any one else had this issue? If you have did you find a fix?


I have set up three vacuums and I have not had that problem.
Are you using the quick mapping?

My actual map is okay, when it starts vaccuming it gets screwed up during that time.

can you post your map? Let’s see what it looks like.

Have you guys had any trouble deleting schedules? I’ve been shutting unwanted schedules off. Can not find a delete schedule solution.

I wish I could delete them also. It will be on the next software update probably.

Look forward to an update. Thanks for the reply!

Mine does th same thing. I had the delete the map and rescan the room. I added a no go zone where it seemed to create the second clone map and it seems to have fixed it, for now.

I reset my map as well and it seems to have worked since the last run. I think when I added my own rooms it messed up the map somehow. So I just let it generate itself and I left it alone.

I have this same problem. I have had to remap a few times due to this bug. During a cleaning job it copies all or a portion of the map and overlays it on top of the real map, and then gets lost because the map is all screwed up. There needs to be some protection for the map so the vacuum does not edit it like that.

Hi Lee4, we had issues with the mapping initially, but painstakingly went back through the house and re-set all rooms. That was about Feb. 2021, we have had no trouble since. We do not use the schedule save, just use it when we want to. We’ve put a new brush in it etc. because we use it so much. Good luck and a little patience we finally got it.