Vaccum map messed up

Once again, my robot is completely lost and the map has turned by about 30 degrees. This is the 5th time it’s happened in as many weeks. Each time I have to clear the map and start over again, only to have it do the same thing again.

It hasn’t completed a full cleaning cycle in almost 2 months because of this.

Getting really tired of this and am thinking of going back to the “dumb” Neato Botvac I used for years with little to no issues.

What firmware are you using? they had found the issue and a solution for this not long ago and released it…maybe using an older FW version?

1 Like

I’m a beta tester, so I’m usually at the front edge of updates. Yet it happened again.

I have not had a complete cleaning cycle without issues in over 3 months.

1 Like

I second this I had the same issue as well after the update, I’m also a beta tester.

1 Like

Not entirely sure if I’m having the same issue or not but even as a beta tester, I’ve used both the official firmware and the beta updates yet I continue to have similar mapping issues. For the most part it maps accurately, though the vacuum does occasionally decide to go in circles rather than follow the most logical path.

The issue I’ve been having that relates to yours is the map turning issue. None of my rooms ever get vacuumed in a straightforward left to right or up down pattern, it’s always on an odd diagonal path.

One clue I noticed was the fact that the vacuum seems to follow a north-south or east-west pattern, and I think it may relate to the fact that my house position on the road does not perfectly line up to those patterns… That is to say my house and the road are on a diagonal Northeast to Southwest lineup. I’m wondering if this is specifically the vacuum using North Southeast West coordinates or if it’s a problem in the firmware. It would be nice to have the straight lines that so many people show in their maps but I’ve never had it, and I’ve remapped and updated and remapped dozens of times, as well as changing the location of the base station and remapping in other locations in the house, with the same result.

1 Like

Interesting. I’m not sure if that’s my issue because the actual map gets rotated, but I do know my house isn’t on a North South alignment.

Once again, today my map got all messed up on a several room area clean and it said it was finished after cleaning a room and a half because the map got flipped and cut off its path.

Just to add to this discussion, since I’ve noticed similar behavior and also have been testing iRobot / Roborock vacuums. I think there’s two issues at play …

From what I can tell, the map is aligned to the “base station”. This creates the diagonal, the bot uses this starting point to align the mapping grid. If you happen to be lucky to have walls which run relatively straight to eachother, you’ll get a straight map. If your house is even slightly crooked, like mine is, you’ll get really odd jagged walls and misaligned.

The bot uses the base station alignment to map out the vacuuming path. Slightly diagonal/crooked base station, and you get diagonal/odd vacuuming paths (I tested this one myself, the vacuum did 45deg paths by offsetting the base 45deg, lol).

This leads to another issue, the base station is flimsy and prone to rotating when the bot docks. I’ve noticed on numerous occasions that the bot has parked slightly off rotation to the 180deg it should be. If it does this little by little, I speculate that positioning gets thrown off (if there’s not enough to identify the position) and that causes the map to wig out / flip because it’s identifying a starting position elsewhere on the map. I’ve seen some users post this issue with their maps and you can clearly tell it’s been flipped, the bot didn’t vacuum part of the house because it was no longer orientating itself to the map correctly, so what it thought was an access point was now a wall.

These methods are contrary to what iRobot and Robovac both do for their mapping. Both:

  • Align the longest point (straightest estimated wall) of the mapped area to a fixed grid. This creates straight walls.
  • Determine a vacuuming pattern on a room by room basis, based on the longest portion.
  • Have weighted docks, so they don’t rotate. Although dock rotation doesn’t matter, since they align the map to the grid.
  • I believe they both apply some form of smoothing algorithm to the display map, with iRobot’s being really aggressive (but it does make for a pretty map) in that regard.

Hopefully they fix this up.

Some screenshots for comparison.

RoboRock (note, this is aligned 180deg to the others):



My base station hasn’t moved since I taped it to the floor. And the robot had worked before several times with no issues while it had the exact same setup.

I get nothing from Wyze other than “factory reset”…

It happens again today… It started out fine then about midway through the map gets rotated and it thinks it’s off in space somewhere.

A potential solution have you tried cleaning the lidar sensor ? Maybe theres dust or something, I know might not be the best advice, but you have an interesting issue.

I have noticed improvements in mapping with .113. Supposedly the pending beta release (within weeks, last I read) might even improve this further as they introduce multi-floor (in my opinion - by nature of that, they have to decouple the charging station stuff from the map because it needs to be able to run on floors w/o a station).

It’s an odd issue to have. Have you tried submitting the logs via the app right after the mapping issue occurs?

I’ve submitted logs every week for 4 months.

Yup. Cleaned the LIDAR. Reset the map. Etc… All the usual checklist of things.

No luck.

Now my map is gone like it’s a brand new device. WTH?

I’ve had the map disappear issue before. I’ve also noticed it’s very easy to accidentally delete the map as I’ve done that a few times myself. Asking for a mapping run should add to an existing map (e.g. you open a door to map a connected room), but instead it deletes and starts new … little things like that.

I’d wait for the pending beta (should be soon, the last dev post said weeks and that was over a week ago) which will hopefully address some of these issues.

I’ve finally had them tell me they are sending a replacement vacuum. I don’t know how much that would fix this issue, but I’m at my wit’s end right now with this.

Does your robot have trouble docking? Used to be, and probably still is, that if the robot attempts to dock 3 times it will erase the map, making an assumption that it doesn’t know where it is. Way to fix that was to put it on a solid floor (not carpet).

Also, crooked mapping in the past was fixed by setting the charging station up against a right-angle wall, perpendicular to it (not at an angle to it, or the rest of the house).

1 Like

Nope. It has no issues docking.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.