Robot vacuum map duplication issue

After mapping my house out, I make my initial run to clean and my mapping shows up a second time skewed. I have deleted the map three times and started over, always with the same results. Mapping works, first cleaning creates a skewed second copy of the map and the vacuum cannot clean properly.

I have also tried removing and re-adding the vacuum. Thoughts on this?

For Clarification - the labelled rooms are the only actual parts of my house. Everything else shows up during the first cleaning after initial mapping.


I have the same issue but mine happens when the vacuum goes from tile to carpet and then it gets lost midway and tries to remap the same room from a different perspective causing overlaps and phantom walls.

This very well could be the same for mine. 2 of my rooms are carpeted and the other 4 are tiled.

So after some follow the robot exercise, I found that the spring type door stops caused the robot to skew itself and think it was pointing a certain direction. When the robot hit the door stop head first then the mapping got all messed up. But when it hit the door stop from the side it was fine because the door stop is a spring type that would bend sideways but bounce back when hit head on.

And this happened only on the carpet because the door stop was too low and near the floor carpet compared to on tile. This caused it to escape the eyes of the lidar.

Interesting. I dont believe this is my case as mapping starting going off course in my dining room, before it makes it to any room with a door stop.

Ive set up a few large no go zones around my table and buffet and have not had an issue for the past 2 days. Still, Im interested in why these pose a problem. There is plenty of space to navigate around the legs.

Ill just continue to tinker for a few days and see what comes of it all.

Same for me. Can’t edit rooms or setup a schedule (can’t select room) either. I assume those problems are caused by the duplication of the map.

Having this issue completely. I can’t even finish a first cleaning the map gets distorted before even finishing.

So I cleared my map and started to let it rebuild. I could not get a good run, it kept skipping a room when going down the hallway. I finally rolled up the carpet runner as it would be 1/2 off and be angled. I think being angled confused the Lidar and sensors as it started to get confused and drawing ghost rooms. it also could not figure out distance. It overlayed as if it was 1/2 over another room.

I took the carpet runner out of the hallway and it seems to be working fine now. My take away for now is that it has issues if it is on an angle while mapping a room or cleaning.

It is still mapping and cleaning, I will send report tomorrow when done. :slight_smile:

I have completely factory reset the device. Cleaned all of the sensors, brushes and shaken out any dust caught inbetween the collision sensor spring-bound bumper. I did a quick mapping on it and then I managed to block off areas that may have been contentious with the room mapping.
Now the vacuum is cleaning and will report in a week if that fixed it.

How did you do a Factory Reset? In the event I need to do it.

Go into the mobile app and go into the vacuum’s settings and remove it. Dock the vacuum. Then press and hold the [house button] for 5 seconds … it will speak out loud something like “factory reset started” … then release the button … then again, hold the [house button] for another 5 seconds … it will speak out loud something like “factory reset complete”.
Now add the vacuum normally as you did when you first got it.

1 Like

Thanks – appreciate that.