Vacuum thinks it is stuck

Hey everyone,

I manually ran the robot vacuum for the first time today since I’m still waiting on a replacement due to the setup issue that many have experienced. It was running fine when it ended up getting stuck on some rug fringe. I flattened the rug back out, checked the brush/wheels, placed the vacuum back on the floor and pushed the power button to resume cleaning. Everything started as it should with the side and main brushes spinning and the vacuum sucking but the vacuum didn’t move. It jerked back a couple times but didn’t even move an inch in any direction. Then it stopped, the red lights started blinking, and it said the vacuum was stuck and to move objects (whatever that message says). I picked it up, triple-checked the brushes, spun the wheels manually, and put the vacuum down in a different spot (in case there was a shadow or something on the floor that it didn’t like). I pushed the button to resume cleaning and the same thing happened - jerked a couple times and told me it was stuck. I reset the robot to factory setting and tried again. Same result.

I guess it doesn’t matter in the long run since I’ll be receiving a new vacuum but has anyone experienced a similar issue? If so, what did you do to fix it? And was it before the firmware update or is this something I’m going to need to watch out for with the new vacuum, too?


I just got the same thing a few days ago. Says wheels are stuck, but it’s not at all…just thinks it is and won’t move. Now I’m stuck in limbo wondering if I’ll get a replacement or wait until an update may come out to address it! Kinda sucks to have this happen after only about a month of use.

Same. Just happened today. It was working fine yesterday.

So I just reset the map for my house and it’s working again. The event that caused it to think it was stuck, was my wife picking up the vacuum and moving it to the other end of the house. So at some point it probably did get stuck, and she messed with it, and that made the problem worse to the point it thought it couldn’t go anywhere. I power cycled the vacuum and then started the quick mapping function and it’s working again.

1 Like

My vacuum got a cord wrapped round the brush and got the same message. I removed the brush and unwrapped the cord and after a restart alternated between being stuck and its wheels not touching the ground (after each restart)
. I took a screenshot of my map so I could reset each fence and was about to reset the map but discovered that a full power cycle cleared everything up and it has worked fine since the power cycle.

1 Like

Same here. Reset the map and fixed it!! Thank you!!

Resetting the map and re-adding it to the app didn’t work for me. The wheels have seized up and will not move. After a few minutes they’ll release and I can move it around, but it still won’t drive. It jerks a little bit, primarily backwards but it will not move anywhere. This all happened after it sucked up a couple of socks. In the past, I’ve been able to clear anything and it will move right along. Not this time.

Have you tried the aluminum foil over the sensors on the bottom of the unit? That is what it took for mine to recalibrate. I think I must have a damaged sensor or something but it works now.

This fixed my issue. I had the same thing happen it just became permanently stuck and wouldn’t move. Thank you so much! I was freaking out that it was broken.

How do you do this?? My vacuum won’t go out at all anymore it just spins in one spot

How do we do that?

I swear these products suck