Vacuum getting stuck

I just got my vacuum and tried to start it mapping today. It kept getting stuck on things I would put a virtual wall around at a later time. I tried, but it said I couldn’t put a wall around an area the robot had been (or something like that). As a result, after 3 times getting stuck, I turned it off and gave up. Any help would be appreciated.
Thanks in advance!

Agree it is a pain that you have to babysit the mapping.

Workaround : If it gets stuck on a object or goes where you don’t want it to go, pause it and physically move the vacuum away from the obstacle.
Resume clean and pause it again after the new position of the robot is recorded in the map. You can then draw a virtual wall around the original obstacle even if the vacuum has traversed it.


My Vacuum continually gets stuck on stairs. I can’t draw a wall around it (forbidden area) because that option is not available when mapping.

I had the same issue. When I called they said to put a piece of cardboard where I didn’t want it to go when mapping. The vacuum would see it as a wall and go around. It worked! Unfortunately, now it keeps losing the map and I have to redo.:worried:

Thanks, that makes sense.