Wyze robot vacuum is building new map each time we clean

After every use wyze robot vacuum is acting it’s own way not cleaning the selecting room and rebuilding new map each time

Struggling a lot to return to changing station


Same here. Run out of battery before finishing first cleaning.
That happened twice already.

1 Like

If you let it run, it will create an outline and try to clean the area.
If it runs out of battery, it will go back and charge and it will resume automatically when it is ready.
And after it finishes the area within the white outline, it will go outside the white boundary and create another area within the green map. And repeat.

Actually I don’t have issues running very 1st time …I mean it build a map and return to the charging station as expected…The issue was selecting the room and hit clean now the robot is building up the map again instead of cleaning inside the white boundary and finding hard to identify the charging station

1 Like

Thanks for your answer, the problem is it got stuck with the Christmas tree skirt and a cord the 2nd time and when I cleared it said battery was too low to return and asked me to manually put it in the base. Now I don’t have an option to resume. Only to Clean.

(until the entire floor has been mapped out) When it cannot find the charging station I just move the charging station so that it is in direct line of sight. And it will dock. After the map has been completed it didn’t have trouble navigating to the charger in another room hidden in the corner where it started from.

I’m having a similar issue. It can’t map my house fully in one charge, and when I carried it back to the base to charge, it started the next session all over. Even forgot about the walls I created in the first session.

1 Like

Until they fix the docking issue, here are some tips:

  1. Try putting the docking station on a hard floor. That environment seems more tolerant.

  2. Watch the robot when it goes back to the charger. If it fails TWICE, then the next time it tries just push back on the front of the robot to help it dock. The issue here is they also have an issue where if it fails to dock 3 times it will erase the map.

Hopefully these issues will be resolved soon.

Same issues here. Robot forgets it’s map. @Wyze we know this is practically still in beta, but you need to address this. Roomba doesn’t have such problems and so far we are really struggling with this product. Since the map isn’t remembered, I have to put 2x4s or boxes out to block areas. This isn’t sustainable and my wife is already irritated at that’s seeming like a superfluous purchase.

  1. Whether it can complete the whole floor or not, and whether it manages to make it back to the charger or not, it MUST retain the map and walls, unless the user specifies otherwise. This is the logic that I believe is missing.

Hi, I wanted to report some success.
What worked for me was putting virtual barriers and let the robot learn the map by smaller chunks. When it is able to finish an area it will return to the base and it will prompt you in the app if you want to save the new learned area. In that way I’m almost done mapping the house, it even identified 2 rooms automatically.
I wish I could define the rooms myself, so I can have more flexibility when scheduling cleanings.
I know this is a really new product and that’s probably coming.
In the beginning when it kept resetting the map it never completed an area and prompt me to save. Although the map was showing in the app. I guess that’s the big difference.
And I agree with JeffPit it should be able to complete this learning process with less intervention.

that’s brilliant Juliodgregorio - I will try that! So far today it seems to be doing well actually, inexplicably better than last time under identical conditions.

Didn’t work for me. Set it to clean a room that hadn’t been finished. When it was done it went back to charge (or tried). I carried it back and it then figured out to charge, but the map on the main page and editor do not have the parts of the room that that cleaning discovered. This is so frustrating.

I put of a bunch of barriers and sent it on it’s way to try and build out my map. Here is a shot of the barriers and it actually building out the areas that were missing in this room. However, when the cleaning was done, it never made it back to home (stopped under the sofa). When I got home, I told it to go charge. When I did, the new areas it found didn’t get updated in my map.

It cleaning and filling out the areas that were missing in room 7/8.

When it was done and back charging. I got no prompts about “would you like to update your map”.

I’m on beta firmware 1.6.87 and iOS beta app version 2.16.35 (3).

yes, I wish it would remember the map even if it does not finish cleaning if it had completed the outline.

I’m on the beta and now the map editing is back, I was finally able to split my only 2 huge rooms in a more realistic number.

Another trick to have it learn new rooms is take the robot to the maped room next to the one you need to discover, put a barrier so it does not go towards the already known part and hit clean. After it maps the perimeter pause remove the barrier and let it finish cleaning.
It will return and ask you to save.
Repeat for other rooms.

Hope it helps.

1 Like

I did exactly that.
Unfortunately, between the new room and the charger was staircase with see thru banister.
WRV kept trying to go thru the banister when it was finished cleaning the new room.
So I stopped it and made it return and it did not add the new room to the map. It did not ask save it and ask me if I wanted to add it. I will try again next week when I need to vacuum that room.
I wish I could draw an rectangle where the room should be added and name that room. Then when WRV cleans it, the more accurate shape of the room can be added after it has been cleaned.