Wyze robot vacuum in a large area

Have tried to setup a robot vacuum at our church. It just won’t work. We have mapped the area, everything shows up fine, but when we try to vacuum, it acts like it’s a brand new area, and does squares to try a new area. Eventually it just stops and you have to take it back to the charger.
I brought it home and verified that it works as expected, as I already have a vacuum at home, so I’m familiar with the process.
Am I missing something? Please help!



Interesting, so after going around for a while it just gives up and creates a new map?

Nothing changes in the building after you map right? No furniture is moved or boxes are near the dock?

Also make sure there aren’t any mirrors or reflective objects at its level

1 Like

My suggestion is, after you do the map, you notice there are some areas that seem to not have solid lines. In some cases this may be glass doors or other things. That’s fine. But consider adding a virtual wall to make a solid line so it ignores trying to go out or map further.

When the WRV stops, how full is the dustbin?

It’s not getting stuck underneath anything? It just stops where it is when the battery gets low without going back on its own to charge?

How many times have you attempted this? And it’s always done the same thing?

I have not heard of any mapping size limitations, but I don’t know of anyone who has tried to use it to map a single floor the size of a church yet either. If I had a large enough building at my disposal I would attempt to replicate it for you. I wonder if anyone else can do so.

I’ll tag in @WyzeJasonJ here to see if he can ask the WRV team if they know of any size limitations or if the algorithm or map or anything could be getting affected or if he has any other ideas. It would be good to look into this. Thanks for sharing.

2 Likes

No mirrors or glass doors in the church at all. Even if I try to separate rooms or add virtual walls it says you need to map out a room and it starts all over again.
I’m just wondering if there is a memory limitation?

This is slightly nuclear, but if your vacuum at home is the same, try swapping them. All you would have to do extra is create another map on the home vac when all is said and done.

1 Like

So you’re thinking I should take my home back home to the church? I could certainly try that. Will have to set it up on the Wi-Fi there? It wouldn’t forget anything from my home mapping?

Unless you have the multi-floor mapping option already (some beta testers have it) you would lose your home mapping.

Multi-floor mapping should be coming as an update in the near future though.

That’s why I used the term ‘nuclear’ you will lose everything on your home vac. I am talking out the side of my mouth because I honestly dont know if you can save a map and reload it.

Hmm…well I guess I can always remap my house if required.

@WyzeJasonJ do you have any suggestions? I tried it again today at our church, basically I can map the whole thing out, but as soon as it returns back to the charger it goes back to wanting to quick map it again.


1 Like

@brockpsu
When it does this I would submit a log after it happens.

You can send in a log through Account > Wyze Support > Submit a Log.

I would then contact support and see if they are able to help you, if that also does not work give me the ticket number you receive from support and I will see what I can find out.

2 Likes

Here’s the response I received-

Thanks for contacting the Wyze Wizards team. My name is Leo and I’ll be happy to explain.

Thank you very much for sending us a log. I’d like to be respectful of your time and point you to the best resource to have the issue resolved.

This has been determined as a bug in our service and is not a hardware issue. Your log has been sent to our Engineers.

Rest assured they are looking into the root cause to integrate what was lacking in our system. We don’t have an estimated time frame on when this will be resolved, currently, the fix is being tested before being released to make sure there are no additional issues.

Thank you for your precious time. Please reach back out if there are any additional issues.

Thanks for being a part of Wyze!

3 Likes

Well, at least we know it’s not a faulty unit and that they’ve discovered the issue and are currently testing the fix.

I don’t think they can send out the fix for it until they are ready to do the next major update for all vacuums.

3 Likes

Just out of curiosity, how long do you think a fix would take? Are we talking days, weeks, months?

No idea, since this isn’t a super common issue, it may take longer. Depending on its complexity it could be from a few weeks to a few months.

Thanks for all the help!

1 Like