Wyze sense V1 - Design flaws


I’ve been a early backer and adopter of many Wyze products including the Wyze sense v1. Recently, I realised that all my v1 contact and motion sensors are completely dead, thanks to terrible engineering design from Wyze. What surprised me the most, is Wyze’s response to this issue. I think it’s ethically wrong to sell a product once you’ve identified that there’s a design flaw which affects the EOL of the product, Not only didn’t Wyze fix the issue, they chose not to broadly communicate the issue to customers who had bought the product and/ or update their app to proactively notify that the product would be dead if the battery wasn’t replaced in a timely fashion. Rather, Wyze decided to use the 1 year warranty period as an excuse to get away Scot free from this issue that affects thousands of customers.

The industry best practice in cases like this would be to recall the product, offer refunds, repairs and extended warranties along with an apology for intentionally misleading their customer base. But none of these seemed to have happened in this case.

I guess Wyze is a different company now. Gone are the days when the CEO would write a sincere apology when their camera was delayed and communicate updates proactively.


And this is a big reason why Wyze invested in an alternative and got rid of these sensors.
They identified a design flaw, so they took steps to help people prevent the issue as much as possible (check the LEDs and get battery low notifications), and then they looked for alternatives, and after they secured an alternative, they deprecated the product with the problem, and only offered the newer more reliable one that resolved the issue.

I agree that Wyze could’ve done some things differently here with better communication.

The issue is actually with Texas Instruments design of the chip used:

Wyze also didn’t design the sensor, they just made new firmware alterations for it. When they learned about the brown-out issue from low voltage they did communicate how we could learn when the battery starts to get low (the led lights), and then they created a firmware and software update so that the app and notifications could alert us and tell us when the battery starts to get low so we could replace the batteries before the brownout occurred. This is certainly taking action. Again, it’s fair to believe they could’ve done more communication, but it would be disingenuous to say they did nothing and were just trying to “get away with it” or something.

I’m impressed the improved replacement sensors are relatively close to the same overall price after shipping, etc is all included (especially if inflation, tariffs, and CPI changes are taken into account).

In the smart home or IOT industry, I am unaware of any company doing massive recalls, refunds, etc for anything remotely similar, though I won’t rule it out. In my experience, that sort of thing is usually only done when it puts someone at bodily risk or endangers someone else. Especially with profit margins as low as Wyze’s. It’s a little easier for companies with high profit margins to eat such a recall, but almost impossible for someone with low profit margins to recall hundreds of thousands of devices, and many wouldn’t do it anyway. I wouldn’t have returned my V1’s. I personally love them. Even after I learned of the brownout issue, I started buying tons more V1 sensors, as did many other people I know, and there are still tons of people complaining to Wyze that they stopped selling them.

Given their limitations and options to handle this without destroying the company and going broke, I thought their response was fair. I wouldn’t rate it excellent or anything though. I learned how to make sure I don’t let my sensors brownout, and with dozens of sensors, the only ones that have locked up are ones I lost (they fell somewhere and I couldn’t find them until months later, and by then it was too late…definitely not Wyze’s fault). I learned how to prevent the issue, and with dozens of sensors I’ve prevented any brownouts. Also, the brownout doesn’t occur every time, Before I knew about this, I had several sensors batteries die without them going into a brownout, so it’s not every sensor either, apparently, most don’t brownout, but some do…though it is incredibly frustrating when they do. You can actually restore them as the document describes, and then reassing the MAC address posted on the sensor, or just use them on Home Assistant instead.

Still, I agree that Wyze could’ve done much better with communication than they did, but I won’t say their response was terrible or abnormal or poor, though it wasn’t excellent either. It was fair though (TO ME at least).

1 Like

I picked up some extra sensors to replace my current ones when they get bricked and I’ve been good about changing the batteries in them.

The bulletin from TI indicates that it is the slow discharge across the brownout threshold that is the issue.

What I’m wondering is if I take the battery out of the good spare sensors then there is no slow discharge across the brownout threshold so perhaps the spare working sensors could be stored indefinitely without the batteries in them?

1 Like

That is correct, you have summarized it well!

Taking the battery out will allow you to store them basically indefinitely. The problem occurs intermittently on some sensors when the low voltage (from an almost dead but not quite dead battery) causes it. One can jump the sensor back to life, but most people don’t have the technical expertise or tools to be able to do this.

I would recommend doing this anytime you will be absent for an extended period of time (ie: a vacation home) or when they are not connected to the Wyze app or seen regularly to view the LED indicators.

As you suggested, Wyze should have sold the V1 sensors without the batteries inside them (instead kept them separate and had the user install the battery when ready for setup). This would’ve resolved the issue of some people having dead sensors before they even installed the sensor. This is one of the things I think they should’ve done much differently.

In theory Wyze could develop something to help restore sensors, but I can’t blame for just deciding to move on to the V2 sensors with most of their resources and focus. I would not be surprised if the new Matter initiate is incompatible with the current V2 sensors though, so it is possible that we will get a version 3 of the sensors to be able to make them matter compliant, though I am hoping that instead they can simply use the same sensors and just upgrade a new hub to be matter compliant.

Have you tried the workaround suggested in the Advisory of resetting the device when powering it up?

Looks like it would just take holding the reset line on the CC1310 chip high while applying power to the device.

1 Like

Others have done this and had success doing it in different ways. I was following a thread on here for some time detailing out how to do this. It is easier with a special tool, but there are guys who have just manually winged it without special tools too.

Eventually I plan to defibrillate the life back into a couple of the sensors that died while I lost them (then found them months later)…so I have them sitting in a box waiting for me to stop being lazy. I am most likely going to switch them to be Local-only sensors through Home Assistant so they aren’t reliant on the internet and will work a lot faster too. I might eventually convert ALL my V1 sensors to be local only sensors through Home Assistant, honestly. Then it doesn’t matter if Comcast is having issues, all my stuff will still work great. I think that’s the long term plan. There are lots of people who LOVE these V1 sensors so they can connect them to Home Assistant and use them totally locally. They can do their own low battery notifications, but the brownout doesn’t really worry them because they can just flash it back to life and it still goes right back to working on Home Assistant.

The biggest problem with brownout is that it resets the sensor’s mac address, and so if you want to continue to use it with Wyze after resuscitating it, you need to somehow imprint the MAC address Wyze originally assigned it back onto the device. It’s easier to just blow that off and keep it on home assistant. Honestly, if someone is really upset that a bunch of their sensors died in a brownout and they don’t know how or don’t want to restore them back to life themselves, I would just go onto a home assistant forum or group and ask if anyone wants to buy them to restore them themselves. The sensors aren’t destroyed or anything like that. They will still work.

I just haven’t switched mine over to local only yet out of laziness :rofl: but my wife is getting sick of them being internet reliant…if Xfinity is having issues (way too often) then suddenly some of our lights won’t go on or off easily because everything is internet dependent. If I convert these and some bulbs, then internet won’t matter since they’ll all run locally off the router.

On topic point is: The sensors aren’t really destroyed…they’re annoying to fix or convert when/if they do hit that intermittent brownout risk, but don’t ever throw them away, there are people who will buy them and use them in better ways. If you want a Wyze dependent sensor, the V2’s are pretty awesome sensors…but they are twice the size of the V1’s, so I LOVE to use the V1’s as smart light switches.

1 Like

I’ve got a few of the v1 contact sensors that suffered the brownout condition.

Very recently I got into Home Assistant and found that two of my brownout sensors worked with HA.

So I took one and added a tilt sensor soldered on to the magnetic reed switch. Now the contact sensor can open and close by tilting it and no magnet needed.

I did this so I could mount it on the outside of my mailbox door as putting it inside a metal mailbox with magnet blocked the signal.

Specifically I put it under the mailbox on the part of the door that extended down below the mailbox.

It has obly been a few days but seems to work great so far. Only concern I’ve got is that I used that 2 sided tape that came with V2 cams and it may not hold.

There is a discussion going on about it in another thread on this forum and one member is making me a 3d printed holder to attach to the mailbox.

1 Like

Oops, meant to ask… how do you convert a wyze bulb to work with Home Assistant?

Has anyone setup the v2 sensors using the V1 bridge? I’ve beeen repeated told by the customer service that it’s possible, but I can’t seem to get mine to connect to the v1 bridge.

You don’t convert the bulbs. There is a wyzeapi addon to HomeAssistant that gives you access to bulbs, plugs, sensors, HomeMonitoring, etc. It uses the Wyze servers to get the information.

1 Like

I’ve heard rumours that you can do it with HomeAssistant and one of the Wyze addons, the one that makes the sense bridge work directly. Beyond that, I haven’t seen anything indicating you can do it via the Wyze app.

I was not able to use a V2 contact sensor with a v1 hub in a V2 cam but was able to use a v1 sensor with the home monitoring hub.

I’ve not yet tried a v2 sensor with a hub in my Pi running Home Assistant.

I tried the Wyze add on for Home Assistant and it works for a bit but then crashes my system. I suspect lack of resources on my old Pi due to too many wyze products. I may give it another go but using another account that I shared some items with. That way there are leas items to crash my system.

@davsav I read in some forum thread (maybe in Home Assistant forums?) several months ago that someone figured out how to convert the V1 bulbs to be local only. This made them no longer work with Wyze’s ecosystem of course, but apparently, there is some kind of complicated way to convert them to local-only so they weren’t internet dependent. I bookmarked it somewhere…but it might take a while to figure out where that bookmark is! :rofl:

I don’t recall the details on it off the top of my head, but I am guessing they had to get access to the microchip and manually overwrite the firmware somehow. I don’t know if there is a way to do it OTA since it just goes to Wyze’s servers…though maybe they figured out how to highjack that authorization to OTA a different firmware onto it. I just remember reading it was possible (though complicated) to convert them to local only, and I saved that thread somewhere for long-term intentions of switching a bunch of things to be able to work locally and not be dependent on so many open points of failure (Xfinity, Wyze, Amazon Servers, and so many other possible points of failure). Though I do like Joshua’s Wyze API for Home Assistant, and Love having that in the meantime, even if it is internet dependent too. If I find that thread I saved somewhere, I will try to remember to post a link. I wouldn’t be surprised to learn it’s beyond my capabilities since I don’t currently know how to manually update firmware in some microchip, and I am sure I’d have to buy some special tool, but it could be worth it…hoping someone found a way to insert firmware OTA through highjacking the API though. That I probably could do.

Here’s the thing. Officially, as of right now, Both sensor versions will connect to the new V2 Hub.

Home Assistant users have been able to connect V2 sensors to the V1 bridge, so we know this is possible.

When Wyze started selling the V2 sensors separately several weeks (or months now?) ago, the Wyze website and FAQ’s announced that V2 sensors COULD now connect to the V1 bridge, so I tried it out, and it was not the case. Wyze then edited the Website and FAQ’s to instead basically say “not at the time” instead now…but for a short time it said it was possible.

From this we can guess that Wyze apparently intends too allow V2 sensors to connect to the V1 bridge, but they would not be allowed to act as security sensors for the HMS. It seems that Wyze must be testing an Alpha firmware update on the V1 Bridge to allow this, but it hasn’t [yet] been released publicly or even to beta.

It is possible they will ultimately decide not to allow this at all for different reasons, but I suspect they are mostly waiting for the silicone chip shortage issues to abate. Since they are limited on how many chips they can secure for their products, they are probably restricting that firmware update for now to ensure those who want them for security and home monitoring get them first. Once they have no shortage of supply, they will likely allow the bridge firmware update so anyone can add V2’s to their bridges.

I don’t work for, speak for, or represent Wyze in any way though. I am just stating what I observed as well as my interpretation and personal hypothesis on the matter based on those observations.

So Customer service may have seen an announcement that V2’s could work with the bridge, or they may know people who are alpha testing this capability or simply misunderstand the difference between the V1 bridge and the V2 hub…customer service agents aren’t necessarily tech experts or Wyze experts, and they can have a lot of misunderstandings too. But the basic answer is that

V2’s cannot currently connect to the V1 Bridge through the Wyze Ecosystem, but this capability is possible and MAY (or may not) be enabled by Wyze in the future.

You will be interested in reading through the following thread on the topic of people actually doing this:

1 Like

I had a neighbor digging a poop accidentally cut the cable line, taking out my internet. Then I couldn’t turn on my lights so I can see why people would want to keep control local.

I am curios how they do the conversion so please let me know if you find the link.

Interesting you mention bricked motion sensors as I only recently got my first one bricked so I didn’t know that was a thing… but glad to know they can be unbricked.

Oops… digging a pool.

And thanks for the link on unbricking.

1 Like

A few months ago on the same day every single one of my v1 motion and contact sensors stopped working. Totally bizarre. They were spread across three different usb bridge/camera combos.

Wyze support told me to delete and re add them all. None of them will re-add. They all have good batteries in them. They all flash three times when I try to add then but they all time out no matter what bridge/camera combo I try to add.

Wyze support won’t help me, they just say there is nothing they can do because they don’t have replacements for those sensors and they are more than 30 days old.

I tried holding down the reset while inserting a battery - get a single flash. Try to add them again, three flashes, timeout.

Anyone have any suggestions? I am furious to suddenly have twelve sensors stop working for no reason and Wyze’s only suggestion is to buy new sensors, hub, and their subscription monitoring service that I don’t need.

Yikes, I know return policy is 1 month, but warranty should still be longer than that, and if they don’t have replacements, then at least store credit would be the honorable thing to do to cover the warranty issues. If you’re within one year I would try to call another rep. I was pretty sure some other people got store credit within the warranty time frame, though I am guessing you’ve had them more than a year too.

What I would try:

  • Try to reset one of the bridges.
  • Switch the Bridge to another camera (I had a problem like this once, and when I switched the bridge to a different camera, my problems were resolved).
  • Try another CSRepresentative anyway. Sometimes you get different results with different people. It shouldn’t be that way, but it’s just reality. Maybe ask to be escalated to a higher technical support.
  • Remove and set back up the camera again. Maybe the initial problem was caused by a firmware update that had a bug. Delete and set up the camera, then make sure it has the latest firmware, and try again.
    • if that doesn’t work, then if you are on production firmware, try switching to Beta and installing the latest beta firmware. Otherwise maybe try flashing the camera back to a previous firmware and seeing if that makes a difference.

I can’t imagine what caused the initial issue, and it isn’t happening to ALL V1’s unless it was a firmware update bug or a temporary system outage or some weird surge fried the bridges or something. I have V1’s that are still working on bridges and the new hub. I am able to set up new ones too (I just moved to a new house and have been re-adding V1’s to my system over time).

Sorry, I wish I could resolve it, but the above are things I would try in your shoes.

1 Like

Make sure to power cycle the camera while removing the bridge and power the cameras off at least once before installing the bridges. I’ve seen this make a difference as well.

1 Like