Unbricking Wyze Contact Sensor - pcb reset pin

Hello, the forum contains many posts about sensors which fail to continue working after a low battery.
through observing the logs this poster determined the sensors mac address was somehow being corrupted in its RAM , and this one detailed 5 blinks = fail to pair, 3 blinks ok.

The wyze sense is based on the TI CC13x0 system on a chip, TI manual link there are a number of references in the manual to resetting it , and the chip itself has a reset pin.

i had 8 (7 contact & 1 motion) bricked sensors, and have been experimenting on how to unbrick them. I have unbricked a motion sensor by applying an overvoltage of 4.5v in lieu of the 3v cell ( maybe a peer on the forum or at Wyze labs can repeat this to verify?) , but have yet to find a way to unbrick contact sensors - still 5 blinks. if there are other ppl in the forum who have any suggestions, i would be more than happy to experiment on my bricked sensors, maybe together we might find a workaround. thanks


the root of the problem seems to be documented here: TI warning on low battery

TI mentioned a reset , any suggestions how to go about this? thanks


I’m very rusty on circuits, but it looks like that’s a POR Power on Reset pin. If I remember correctly, a POR needs to get a pulse during power up of the IC to reset it from a locked up or stuck state.

1 Like

thanks, would you reckon the reset pin in the diagram is 4th from top left of the chip in the photo ?

I have a bunch of door sensors that fall into this category.
Once I replaced the battery they never would re-connect again.
If anyone finds a solution to “attempt”, I am willing to try it.
Thanks for locating this information!

I don’t see the mark for pin 1 on your photo, but checked one of mine and pin one top left side. So that would make the reset pin 4 down on the right side in the picture. The mark on one I checked is a small indentation designating pin 1

Reset pin is on right hand side of the photo. the pin layoit is 90 degree twisted left.

try apply pos connect to reset pin for half a second and see.



I will need to remove one of these out of the case so I can get to the bottom where the reset pin is.
Hopefully someone will have done one by that time and give us some “pointers”!

the pcb is held in place by a rivet of (melted) plastic near the spring aerial. it looks like a white dot.

you can cut the rivet’s head with a sharp blade.

be patient as it is fragile. btw I don’t work for wyze . we are experimenting here.

I realize this is a non-sanctioned experiment! :slight_smile:
I have several contact sensors that bit the dust after going out of warranty and battery replacements.
I also have two I bought in October 2020 that arrived with almost dead batteries that I had to replace.
One never worked at all, the other one never worked again after the battery swap.
I am not really sure how to “properly” apply the voltage during power-on though.

the advisory in the documentation i linked to describes the device as being in a hung state. if we could find a way to thoroughly discharge it (it is a low power consuming device - without transmitting , it could run for 10 years on a battery) then it reasons they could be saved. the advantage is we have a number of them to test with.

could someone help point out how to identify capacitors on the board? thanks

I am curious how you know your sensors are bricked? I had a problem with mine not connecting, and it turns out it was the Sense Bridge that was the issue. I got mine to start working again by get a replacement bridge from Wyze and NOT upgrading the firmware to After that, I use the button on the Bridge to enable sync mode and the reset pin on the sensors to get everything connected again.


U can try shorting reset pin and pin 5 next to it as it is vss.

not sure if you short it while plug in battery or after plug in battery to reset.

I have tried connecting my problem sensors to several bridges, and to ones that have working contact sensors on them. What is the trick to associating a contact sensor to a bridge without using the Wyze app?
Do you hold the button down on the back of the bridge till it starts blinking, then use the reset pin on the contact sensor to “marry” them?
Update, you are right, when the bridge firmware is at holding down that button on the back of the bridge does nothing, the Blue light stays solid.

I still had to use the app but the difference seems to be able to use the back button. The app doesn’t seem to properly put the Bridge into sync mode.

You have to hold the button for like 30 seconds before the led light starts blinking yellow/blue. Then you follow the setup in the app. The problem you will have is firmware disables the button. It seems to be the only change it makes over This is why you need a new one without the firmware update. I had three replacement Bridges before I realized it was a firmware issue. It work on the first try after that, It is always possible I was just lucky too.

This is an exciting thread; I half expect someone to pull a rabbit out of a hat and save a few thousand sensors from the dumpster.

1 Like

I agree with raym64. It would be the 4th pin down on the right-hand edge of the chip. You can see the orientation of the chip by the angled corner of the white stencil on the board. That corner would be Pin 1.

it would help if maybe Wyze could share further light on this (perhaps release some documentation for the pcb for these Version 1 contact sensors, seeing they are not being sold anymore).


I have a contact sensor that did this as well after initial battery death.

It is a shame that you have to monitor the battery condition so closely. If you miss your “window” of opportunity to replace the battery, you are out of luck. I think I have only successfully replaced two batteries so far on contact sensors, the motion sensors seem to work.