2 of 4 Contact Sensors Unresponsive After Battery Change

2 of 4 Contact Sensors I recently purchased failed after two weeks. During the two weeks, they acted differently than my other 3 contact sensors, as they flashed every five seconds, no matter if opened or if closed. Eventually, they went offline. Opened them, batteries were at 2.52V, fuctionally dead. Followed the procedure described for a battery change, i.e. remove old battery, wait 20 seconds, install new battery with + term facing out, wait for single flash… never happens. Tried waiting 10 minutes, no flash. Tried shorting battery terminals with the battery out to drain any caps, no flash. Tried holding side button in with no battery, then installing battery, no flash. Tried holding side button in for over 2 minutes, no flashes. I assume these are totally dead? Any way to revive? They’re so cheap I’m probably not going to waste time on a return, and will order 4 more, maybe I’ll be luckier this time.

Just give Wyze Support a call and explain your situation. It’s pretty much a known issue with older sensor units and Support has been responding well to the calls with replacements. My sensors’ batteries are about at their end of life. Not looking forward to the same. :neutral_face:

Wyze Customer Support
1 (844) 999-3226 or (206) 339-9646
Available Monday - Friday 5 am - 6 pm PT
Saturday 8 am - 4 pm PT


Thanks, that’s what I did and they’re sending me replacements. The sensor is driven by a TI CC3310 ARM Wireless MCU w/128K of Flash. These things are awfully hard to kill, so I’ve got to believe this is some kind of firmware issue. I might eventually figure out how to get the MCU to reset, if I do, I’ll post it.


Great to hear they took care of you! :+1: And yes, please share if you figure out a reset. I may dissect one of mine if it bricks on low power… l have spares.


The Brown Out Detector is disabled between recharge periods in STANDBY. Lowering the supply voltage below the BOD threshold between two recharge periods while in STANDBY may cause the BOD to lock the device upon wakeup until a Reset/POR releases it.

To avoid this, it is recommended that STANDBY mode is avoided if there is a risk that the supply voltage (VDDS) may drop below the specified operating voltage range. For the same reason, it is also good practice to ensure that a power cycling operation, such as a battery replacement, triggers a Power-on-reset by ensuring that the VDDS decoupling network is fully depleted before applying supply voltage again (for example, inserting new batteries). This restriction does not apply to CC1310 die revision B or later.

1 Like

Yeah, I noticed this too, was wondering if it might be related to our issue. FWIW, I’ve tried every combo of pressing the button, inserting/removing the battery, shunting the battery terms, etc., that I can think of and this sucker is as dead as it can be.

Just reread that passage, FYI, I left the units with the batteries out overnight, no bueno when I put the batteries back in. Gotta believe this issue with the BOD is the problem.

1 Like

BTW, in case you were wondering what it looks like on the other side. You can see the MCU, reed switch, reset switch, SMT resistors and caps, LED, and I guess the metal can is the clock crystal.

1 Like

Thanks for that. Coincidentally, one of my contact sensor’s battery just died within the last hour so it looks like I’ll be digging into one of my own this weekend. :grinning:

Hope your battery change works OK. I’d hate to believe that any battery change with these sensors results in a bricked unit. BTW, when you pull the battery cover off, you can see the model number and revision on the board. Mine reads DWS3U-P01 v2.1, and there’s a date code of 2020-01-01 on the board, too.

1 Like

Thank you. I may not get to it until the weekend, but I’ll let you know how it goes. :+1:

I replaced the battery in the door sense 3 weeks ago after it went offline … I think the Android app made some mention the battery was dead. Took the old one out, put the new one in, and all is well.

I had one more sensor (not even 3 weeks) go offline. Battery was at 2.62V, This one, however, worked fine after I swapped batteries. Not very pleased with the quality of these sensors so far. IMO, this isn’t a hardware problem, it’s a firmware issue. There’s nothing wrong with the CC1310 MCU from what I can see.

It didn’t go well for me. :frowning_face: My board reads the same except the dates on my contact sensors are 2019-05-13.

Old battery measured 0.57V. Kind of odd that it went below 1V before dying. I installed a new battery (3.31V), pushed the reset pin, got 5 red flashes, app times out trying to add it. Grabbed this contact sensor’s currently working box-mate, pulled the battery (2.97V), reinserted the battery, didn’t automatically reconnect. Pushed the reset pin, 5 red flashes, app times out. Ended up replacing both sensors with new unused contact sensors and will play with the non-working sensors later.

1 Like

This happened to me, too! Thank you for posting this. I’ll call Wyze tomorrow.

I also had 2 bad sensors a month or so ago same issues 5 quick flashes. I agree that it seems firmware related, support was quick to offer replacements but I’m hoping they they are able to figure out a root cause and update the firmware so they don’t have to keep shipping out replacements. I had 2 other sensors with dead batteries around the same time and they had no issues after the replacement which is the strange part.

I found on TI site that this chip will lockup if voktage is low. but version B die fixed the problem.

Look for version b die sensor.

1 Like

I had a similar problem. Sensor battery was dead. I replaced it, and it never responded. Ended up getting a replacement

I had a similar issue. As previously mentioned, these little things are fairly hard to kill. I ended up replacing all of my batteries, then removing and re-adding all of my sensors. No issues since. Rev A too.

OK, last two sensors from the 4 pack failed. One failed by going unresponsive after a battery change. The other ran battery 1 down in 2 weeks, but was responsive and working in the app after a battery change. A week later, it’s shown as offline in the app (2.12, Android, latest version). Deleted, tried reinstalling, nope. Checked battery, down to 2.9 V (3.1 is nominal). Replaced battery, tried again, nope. Moved sensor to within 3 feet of bridge, nope. Rebooted bridge, nope. Rebooted WiFi, nope. Contacted Wyze, 2 more replacement sensors on the way.

I might note that the two contact sensors that came with the sensor kit (2 contact, 1 motion, 1 bridge) are working fine, and have been since install. This seems to be a revision or versioning problem. I’m loathe to open either of the working sensors to see what the rev level is, but I’ll eventually do it. Hoping now that the replacement contact sensors work better than the ones I got in the contact sensor 4 pack.

I had issues changing my batteries recently too. I had to delete the sensors from the app and add them as if they were new and they came back to life. Might be a different issue. :man_shrugging: