Wyze hub issues

My Wyze hub V2 has been acting strange for a few days (unable to arm/disarm via app, no noise made when entering and in “HOME” mode). I did some reading and attempted to reboot the hub - it went offline and now will not connect to the router (WiFi).
But still has all the network information in the wifi area, but under the change connection tab it says it is not connected and I need to plug it into the router. I have NEVER used the wired connection or tried to change it. I have had the system for ~ 16 months.

  1. How do I get this thing to go back to a wifi connection?
  2. Was there a recent update to the app or hub firmware that may have caused my issues?

Welcome to the Wyze forum @pooner_jonez.

Not sure what FW your v2 Hub is on but the latest release was on March 1st 2023 and had an update for a bug that disallowed the hub to switch from Wi-Fi after connecting wired

  • Added support for Additional PINs (2.40 or above app version required)
  • Improved connectivity
  • Fixed a bug that prevented the Environment Hazard reminder from being stopped
  • Fixed a bug that turned off Environment Hazard functions
  • Fixed a bug that blocked switching to Wi-Fi after connecting via Ethernet

Have you tried rebooting your router since you have had this issue?

I would try giving the router a reboot when it is convenient for you, if the hub does not reconnect, reboot the hub again, if the hub connects, update to the latest FW, if not on the latest FW.

If it does not reconnect, the next option would be to connect Wyze support, who may take you through the above steps but then might suggest factory reset depending on outcome.

1 Like

I am using the latest firmware.

I will reboot my router and try it.


If the reboots don’t work, you might try a Soft Reboot by pressing the setup button for 5 seconds until the lights flash and then letting go. It will reboot and reset.

If that doesn’t work, you can try another setup routine but don’t delete anything from the app. Do a new Hub install in the app, name it the same thing, and press the setup button on the back once to get “Ready to Connect”. After it installs it should get the updated WiFi info and shouldn’t affect any of your installed sensors or your HMS subscription.


The reboots did not work. The addition of the hub again DID work and all the sensors reconnected with no input from me. Thank you for that help,

My original issue of not being able ARM/DISARM from the app is still there. My app version is 2.41.5 (5) - that is the only numbers I can find in the app. I cleared the app cache and the issue persists. I am hoping this is something that can be resolved as I find it convenient to use


I am not sure what is going on with the HMS on the server side. There were no issues for the longest time and then recently there are so many posts about app loading issues and setup routine loops.

Are the buttons in the Monitoring Tab appearing and just won’t work or is the entire tab not loading? Are you able to get to the Monitoring Settings?

i am having similar issue, the monitoring tab is blank.

1 Like

The buttons appear, but do not work or reflect the current alarm status. Once clicked, the circle comes up and just turns like it is doing something, but no changes to the alarm status is ever achieved

Not sure what is going on there. I have had issues with mine in the past not loading (blank) or not connecting (spinning wheel), but only on when there is some sort of server outage issue or I forget to whitelist Wyze in the VPN. But, in either case I was still able to arm and disarm the HMS from the keypad and I still got a Push Notification of that activity.

Because both these issues may have something to do with how it connects to the Subscription Verification Server, it might be best to contact Customer Support and see if they are able to reset your subscription account link.

@pooner_jonez, just saw another thread where Wyze has indicated that there is a known issue with the HMS UI.

@al_cardinal is active over in that thread where they are discussing the issue. Please jump over there and see if anything there helps.


Just saw this thread also… Are either of you testing the Beta App?

1 Like

I was testing beta, switched back same issue. They say fixed but not.

So you deleted the Beta and reinstalled the Production app from an APK or from the Play Store?

Play store

If you are part of the Beta Testers and on Android, you will need to install the Prod version from an APK file. The Play Store will only provide you with the Beta Release of the App, when available.

Then to get back to Beta, you would simply go to the Play Store and install from there


I’m having identical issues.
Hub went offline Monday and has never come back online. Tried all suggested fixes per support chat and emails . This is the second hub to fail.
It’s ridiculous that the entire security system and leak detectors rely on this. It creates a weak link because if the hub fails all other devices fail to report and are worthless. In my case, almost 20 devices I depend on.
It’s an amateur design function that needs rethinking.

Welcome to the Wyze User Community Forum @nickdbenson! :raising_hand_man:

Is the hub connected by WiFi or by Ethernet?

Have you done a new device setup on the hub? (Do NOT delete it from the app)

I chatted with two techs and called and not ONE of the THREE of them mentioned holding the button for a soft reboot which worked. Poor training here from Wyze. This worked and I was able to update the software and the hub is now functioning.


Ah yes. Customer Support is a discussion for a completely different topic thread. I have found that they aren’t called Technical Support for some pretty obvious reasons.

At any rate, I’m glad you got a solution from the soft reboot. :+1:

1 Like

I am -
My hub lost connection AGAIN and had to be re-added to the system. This takes care of the monitoring, but do I need to uninstall the BETA and install from the APP STORE?