Wyze doorbell error message code 09

Whenever I get an alert from my Wyze doorbell, and I check the video on my phone, I get an error warning…
Error (code 09)
Failed to fetch the video from cloud. Please try again later. If this happens again, please submit a developer log through Wyze support in settings.

  1. This happens EVERY time something or someone triggers the doorbell camera.

  2. I’ve filed the developer log (ticket # 192566) but have heard nothing back on this.

  3. Has anyone else experienced this, and how can it be corrected?

This is getting annoying. I cannot view the video of the event that triggered the doorbell camera EVER!

All logs go directly to Wyze developers. You will not receive a direct response from our agents after your log submission, but know that it’s being looked at.

I haven’t herd of an error code 09 being related to this issue, only an error code 06. You might that want to try logging out of the Wyze app, then loging back in. Return to your Events, then try to load the video again.

More information on this issue can be found here:

I logged out of the app, and logged back in just now. When I get another alert (because as we all know the world needs more lerts) I’ll let you know if that worked. Thank you!

After logging out, then back in, on the app, I am still getting that same 09 error code, when someone trips the doorbell camera. How can I find out what that error code 09 is, and how can I correct it?

Error code 09 and 06 are very similar. It means that the Wyze app has failed to get the video from the cloud (Wyze’s servers) to your device.

You could also try deleting and reinstalling the app. If that doesn’t work, you may want to contact Wyze Customer Support about this issue!
By phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT
Or online: Wyze.com/support
phone support is typically faster however this isn’t always true due to fluctuation in the amount of calls.

Also see this thread:

1 Like

Same issue for me. All other Wyze cams are working fine, but the new Doorbell CAM gives Error Code 09 for replay of recorded events. Have tried all of the previous suggestions. Have filed developer log Ticket #201611

1 Like

I’ve deleted the doorbell and reinstalled it.
I’ve taken the Wyze app off my phone (Moto e4) more than once, and reinstalled it.
I’ve logged out of the Wyze app, and logged back in.
Restarted my phone after taking all these actions, more times than I care to remember.
NOTHING works!
I’ve contacted Customer Service.
I’ve submitted Developer Logs, way too many times.
No solutions have been forthcoming, and no contact received from Wyze with solutions or concern about the problems I, and so many others have been experiencing.
You need to find a solution, and fix the problem NOW.


I have a Moto G(6) - Android version 9 and have the same problem with accessing doorbell videos from the cloud in both doorbell mode and events mode. All other functions of doorbell work as advertised. I can download the image to a drive and see the video from the cloud, It just doesn’t work seeing the cloud video from the phone.

Contacted support and set logs. No response from WYZE in over 4 weeks. I also have a android tablet that does not have the problem with the same doorbell and events.

I have 4 V2 cameras and 4 V3 cameras without any problems.

Come WYZE let’s fix this!

1 Like

Have you tried calling again? Do you have ticket numbers? What did support tell you?

Hi all,

Just got my Wyze Doorbell today and installed it… Been getting Error Code 09 and/or 06 each time I try to view a recorded event, regardless if CAM Plus is activated for the doorbell or not. Also, Live View is sluggish in HD and SD resolutions. I don’t have these issues with my Wyze Cam.

I bought this doorbell to replace my Ring doorbell… Maybe this was a mistake. :confused:

1 Like

Yes, have called support three times. Last time was last week asking for a follow up and didn’t receive a ticket number from support that they said I would get with his reply after checking. I have ticket numbers. Support can’t tell me anything because they don’t know anything about logs, they go straight to engineering.

I’ve been in this same boat for months now, and it’s getting pretty crowded. I have four devices that I regularly attempt to view my doorbell video playback on. Out of those, only the one that has a newer version of Android performs the way it should. The most I get on the others is a notification and a still image.

Months?? :confused: That’s not a good sign.

My deadline to return this is June 9. If this isn’t resolved in a couple of weeks, back it goes and I reinstall my Ring doorbell (it’s not great, but at least it works properly).

Same here…I have an older version of Android and only get a notification and a still image. I think you have identified the issue.

Which Version of Android is working?

Customer Support ran me through a checklist of tasks to perform. Nothing worked again. I was told to submit yet another Developer Log, and there has been no feedback on that, or any other developer log I have submitted. We don’t need to kick the can any further down the street, what we need is a solution to the problem!

1 Like

The version of Android that plays nice with my doorbell is 8.0.0

I’m running Android 8.0.0, but no go. :confused:

I have android version 7.1.1, and playback from the cloud “can’t be fetched”. Error code 09.