Wyze Cams cannot connect when on Mobile Data Network

Hey guys,

I recently bought a bunch of v3 cams for my new project. Somehow when I am on mobile network, it doesn’t allow me to connect to the cams. When I get on my home’s VPN, or on WiFi, it works flawlessly.

Did some research and it seems like it has to do with the DNS of my phone, but I can’t find a way to change my Mobile Data DNS (??), if that’s even possible.

I used to have a bunch of Wyze Cam Pan, and it was working fine for a long time.

Any reason why this would be any different? Any suggestions? Thanks!

1 Like

what exactly did you find that led you to the DNS on your phone?

just as a test. disable your VPN for a second and see if you can connect with that disabled. that is the only factor I can think of that might block an outside connection from being made directly to something running on the VPN.

1 Like

Thanks for your reply.

Scenario 1: I am connected to any WiFi network - no problem. Cameras work.
Scenario 2: I am out of home, and I try to connect to WYZE app, it takes a long time and eventually fails to connect.
Scenario 3: I am out of home, I VPN into any network, be it my home or office, and use that to access the cameras, no problem. Cameras work.

I only deduced it was a DNS problem because I googled and found someone on Reddit having the same problem, alas no clean solution other than changing the DNS on their phone’s mobile network.

Thanks for your help! Hope this clarifies y situation.

hmmm hopefully someone else will pop in on this. it’s something Ive nerve had to do. I know you can change it when using wifi, but in a quick googling the answers I found were considerably older >5 years and incomplete at best with the general consensus being that you can’t change the dns of the mobile network generally and if so you would probably (just guessing) have to be rooted as you usually have to do for all the “good” stuff.

what lock downs do you have on your home network if any to prevent intrusions? it sounds like 1. your network isnt allowing your mobile in ( which dosent make sense if you can access through other wifi)
or 2. you mobile network is shotty and connections aren’t working correctly there, which we run into quite a bit.

im in a situation right now ( unrelated to Wyze) having trouble with a brand new phone doing what I want it to and im going to have to change my csc code to Indonesia. so I do feel some of the same struggle with technology.

can I ask what service provider you use and what your typical speeds are for mobile?

I’m responding out of Singapore, we are using Singtel and Circles life. Singtel has 5G and download speeds are about 300 mbps, Circles is about 80 mbps on 4G.

Hopefully someone has seen this problem before and we can get some ideas. Thanks for responding, Bam!

That isn’t how the app works. There is no direct connection from the app through the firewall to the cameras, as I understand it. The camera communicates with the Wyze servers as does the app. Then the two devices negotiate a connection…camera outbound through the home wifi/firewall and the phone on the internet. The camera initiates one side of the connection which is allowed by the firewall and the app is allowed to communicate with the camera as an established connection (assuming no firewall rules were created to prevent this.)

Exact same issue here. Very frustrating and pointless if I cannot monitor my cameras remotely.

I see, then what could be the issue?

Not really sure. Just wanted to put that information into the mix so that you don’t go down some misleading rabbit hole. It sounds to me like something with phone settings when using the cell network, but not sure exactly what it might be…not a phone expert.

What type of phone? Android or iPhone? Do you have another phone you could use to test just to see if it is phone specific? Do you have access to a phone with a different OS you could test?

One other thought…have you tried disabling wifi on the phone? It occurred to me that the phone might be trying to use wifi even though it isn’t working. You did say it works if you are connected to any wifi…

Just found this discussion about the same problem:

There are countless possibilities. One possibility is your carrier/service provider or router is filtering. Another possibility, especially common for users trying to access cams from a non-US based location, is being forced to use IPv6 as an APN protocol (Wyze app supports only IPv4). Some things to check… From your phone’s network settings, see if APN is set to IPv6, IPv6/IPv4 or IPv4. Also, from a browser on your phone in a location where you can’t connect to your Wyze cams, run this connectivity test. In the results under “IPv4 connectivity” section, see if IPv4 shows “Supported” or “Not supported”. In the results under “DNS” section, see if the 3 entries show “Reachable” or “Unreachable”.

1 Like

I have the same issue since some days ago that I bought I new phone. Old phone worked perfectly. New one doesn’t work at all on cellular. I have a house and an office. None of them works. I believe it has to do with the phone itself not the carrier since it’s the same not the network in my home or office.

Okay, I’m confused (not 1st time today), If I’m understanding this thread, I can open the app on my phone when I am away from my home wifi, just using cell data,or a friends wifi and see my cameras at home? ( I see there might be a problem, but that is how it’s suppose to work?

I can see all 5 of my cameras using cell data whether I am 10 feet away or 100 miles away. iPhone/Verizon

1 Like

Learn something everyday. Thanks. This is a newly discovered bonus. :smiling_face_with_three_hearts:

Yes, that’s how it is supposed to work. Access cameras, lights, plugs, etc. from anywhere with the app. I use my iPhone when I’m out to check cameras and sensors. Is this something new to you? It is a feature of most of these IOT devices that you will have access from remote locations. The access is still limited to your device(s) and your account so no one else can access them and there is no hole through your firewall granting access.

The cameras were scared when they saw the 50% increase in the price of the V3 today … it is unbelievable. They already lost their appeal to the competition they were; Good, Pretty, Cheap. :scream: :scream:

Thank you for that detail reply. I did the test and have everything you said as good. I can reach my tend secure cameras just fine over mobile network, I can access my Phillips lights, Google home etc just not the wyze cameras. The moment I connect to my home network it’s fine. Super annoying. The whole point was to remotely monitor the property.

Thank you for this reply. As i am typing this response, I was trying out your response and while doing that I realized that my cameras are now working on cellular network. I will have to wait until I run into problems again before I can test out the link to see.

The funny thing is just yesterday, i could never access the cameras from a cellular network. Today, i did absolutely nothing and suddenly it works like a charm. No idea what went wrong. Will update when I run into this issue again.

Meantime, thank you again :slight_smile:

1 Like

I’m having the same issue which is unable to access wyze on cellular.
However on my wife iPhone its working on cellular.
I’m using Oppo find x3 Pro (android)

1 Like