Wyze Cam v3 Pro Firmware Beta Test 1/18/2023

I was able to update each one at a time through the cams settings under device. I did 6 like this without any issues.


V3 Cam Pro ALL bricked by beta

Seriously hard to believe. Today I used the latest iOS beta app to batch install beta firmware (at least I think that is the version) on 6 (six) V3 Pros that have worked for the last month without issue. ALL SIX can no longer connect to the LAN. I have no other problems with any other Wyze cams or devices.

As a test, I reset a V3 Pro camera, deleted the cache in the beta app, force closed the app and even deleted the devices in my DHCP server. Yes, everything is on 2.4G WIFI. When I try to reinstall/reconnect the V3 Pro, it gets to connecting to the WIFI and says “Unable to connect to local area network”. I tried several times. Same issue. I tried the same thing using the release app as well, with the same results.

If I take a brand new V3 Pro out of the box, it connects just fine and updates to the latest release firmware

I chose to do beta testing with Wyze ( I test with 5 other HA companies). I get it that stuff happens, but with Wyze its different. No only was the telephone support group completely ill equipped to help, but there is evidently no V3 PRO firmware file available (or procedure) for flashing the production firmware via SDCARD. Unbelievable. This is Beta testing, not Alpha testing.

I have been a Wyze user and Beta tester since day 1. Support from Wyze has always been marginal, but this is the worst I have seen it.

My only option now is to return all 6 cams … I guess if that is even possible.

Beware of the latest BETA firmware for V3 CAM PRO.


[Mod Note]: Your topic was merged to the associated beta topic for better visibility to Wyze.


This is how I recommend anyone to update that is doing beta firmware. Beta firmware can have issues and the best practice is to update one and see if you experience any issues before doing more.

1 Like

Thank you for the suggestion. Maybe that is something I will try in the future.
Unfortunately, I don’t think batch versus indivual updating should make a difference for 6 identical cams on the same LAN, even considering it’s beta firmware. I assume that since this cam has only been in production for a few months, and mine were all purchased at the same time, the harware revisions are also identical.

From other posts, I see that I am not the Lone Ranger with this issue. The real “problem” is not that the update bricked cams, it is that Wyze doesn’t have the tools in place to correct and move forward with a new beta firmware. I am bothered that Wyze doen’t have an image of the production firmware and a procedure for manually restoring 3210 using an SDcard on a V3 Pro. Every other cam they do… but not the Pro.

1 Like

My comment was not directed at you, and my main thing isn’t bulk vs individual. My reasoning is to do a single one first to see if I run into an issue before I down everything due to a firmware that has a glitch. If I do not experience problems with the first one then I do the rest.

Just so you are also aware I do forward the issues and feedback.

I don’t know if using an Android phone to update makes any difference but I see a lot of iphones stating they are having issues.

I always do one cam first. I choose the least needed cam first and go from there. I am surprised there is no way to download the firmware like the other cams. Hopefully they can fix or correct it with a new firmware.

1 Like

Updated one cam. It became unresponsive. Leaving it alone for now and won’t update the other two until this issue is tracked down.

Log: 898704

1 Like

I have sent your log up to the team.

1 Like

I upgraded v3 pro and it went offline.
After troubleshooting, I can confirm that v3 pro beta no longer connects to Netgear SXK30B3 Orbi, but can still connect to Netgear R7000 DD-WRT.
Thus, I see 2 possibilities for those affected:

  1. Connect to another WiFi access point
  2. Wait for firmware update and update them by using your phone as the access point (for upgrade only)

Wyze really need to allow firmware downgrades from beta to production for times like this

1 Like

We usually do, I am trying to see why we don’t with this or what the instructions are to do it.


Allow downgrade of beta firmware back to production

Please allow downgrade of beta firmware back to production.
V3pro beta firmware is one example at the moment.

[Mod Note]: Your request was merged back to this topic as your request is satisfied by existing functionality (pending WyzeJasonJ’s instructions).

I tried what @nhawk mentioned, and I was able to get the “bricked” v3 Pro to connect to my iPhone as a hotspot if I used the “more compatible” setting and tried the setup (without removing the existing camera entry) using a beta Android Wyze app (since connections failed if I used the same iPhone that was supposed to be the hotspot). The cam reconnected and other than changing its name to the new one I assigned, it remained in the same group with all of the same settings that it had before the upgrade. The firmware version was successfully reported as being the latest one.

I then tried the same process, but I tried re-setting the camera up using my normal, non-hotspot network. Connecting failed twice. So it seems there is something about the setting of my original network that the latest beta firmware doesn’t like?

Same issue here, updated (2) Pros and now they are dead. Trying to setup as new with the setup button fails to connect to Wifi. Haven’t been able to get a solution from support so far. I have some bricks.

If you don’t have another AP or an extra phone to use as AP, you can bring the cam to public WiFi and try to upgrade them there (once there’s a new firmware or a method to downgrade).
Or ask a friend to start WiFi AP on their phone, while you setup the cam on yours😉

I’ve learned my lesson, no more beta for me

I upgraded 15 units with bulk update.
5 failed the first time the rest went fine.
The 5 went just fine after clicking on the retry or whatever button, bulk again.
All 15 working fine.

BUT, 30 second skip ahead or back on SD card playback doesn’t work at all now.
It was messed up to begin with, but now no workey at all.

1 Like

30Sec back, went back 13 hours
30Sec forward, went forward 11 hours (hours is not a typo)
I’m on the beta firmware.

1 Like

Any other official response from Wyze on what we should do?? Or are we just supposed to live with these bricked cams until it’s figured out?

The new beta firmware update apparently can’t handle the security setting on the network being WPA2/WPA3 Personal, after changing my security to only WPA2, both my V3 pros are connected now. Even though the update indicated it had failed and no longer would connect, after this change, they connect and show the latest firmware update.


That’s weird, because my v3p’s are connected to an AP that uses WPA2/WPA3 Personal. I guess I’ll just call it good luck then. In fact, based on the less-than-stellar reviews by others, this recent beta update has been the only experience with the v3p’s so far that’ve made it possible to stream 2K resolution. I had to use “SD” for the longest time. This is good information to have though in case something goes wonky with my v3p’s and I’ll change auth mode to WPA2 only.