Wyze Cam Pan V2 playback not working from events

One of my V2 Pan Cams will only playback from the live feed and works fine from there. If I try to use playback from an event, I get an error saying that the microSD card is not found. My other V2 camera is playing back fine so it seems like a problem with the camera.

Customer support says that it’s a known issue and they’re working on it, but I don’t see it on the list of known issues which seems odd. Is anyone else having this problem? The camera was only recently unboxed and I’m not sure if it ever worked correctly. I wonder if I just got a bad camera.

If you check status of the uSD card from the Advanced menu, what does it show?
The screen capture would indicate that the either the uSD card or the card read/write hardware in the camera has died. Have you tried a different uSD card, or tried that uSD card in either another camera or other device? Yes, SD cards can fail.

The the SD card works perfectly fine from the live view (see picture below).

I only get that error from the events view. I’ve formatted the card twice, I’ve done a factory reset on the camera twice. I tried a different card and it shows the same error and this card works fine in my other camera. In the advanced menu, the SD card is visible and is recording.

It’s not the SD card. It’s the camera.

So much for that idea…

Welcome to the Wyze User Community Forum @1234! :raising_hand_man:

It is a known issue and has been reported. The Known issues page isn’t fully updated with many bugs that are isolated and not widespread.

I have not read yet of any solution or fix.

Here are some links to topics that discuss it:

Unless I’m missing something, the first two are v3, not v2 and the last one is a different issue where the camera doesn’t recognize the SD card at all.

My bigger question is- if there is no fix, why aren’t they sending me a new camera? Mine should still be under warranty.

It has happened on different cams in the past. It isn’t isolated to a specific cam and has been seen and fixed in the past. It seems to be a firmware or app code issue in the link of that button. Not sure what is causing it as I haven’t yet experienced it so I haven’t waded into the weeds following it. You might want to search the forum for the specific issue and post in those threads to see if anyone who has experienced it and found a resolution can point you to better info. I found references to the same error popup going back several years so it has happened before. I was merely trying to get you in front of others who have experienced it.

I can’t tell you why Wyze Customer Support does what it does with respect to your cam doing this and Warranty Replacement requests. It isn’t a hardware issue so that may be why replacement isn’t an option.

I guess I don’t see how we know it’s not a hardware issue if it’s isolated to my camera. I can’t find that this has been as issue with anyone else with the V2 camera and it’s not happening with my other V2.

They had me submit a log today with the same exact info that I’ve already given to customer support so I guess I’ll see what happens.


Because the SD Card is recording video from the cam fine and the playback is playing fine. That is the hardware. You can both write to and read from the SD. The hardware works

The problem is with the link button in the App UI that isn’t working because something on the server isn’t communicating with the cam correctly. That is software.

That makes sense except that it’s isolated to my one camera from what I can tell. I assume if I get a new one, it’ll work fine. How does that happen with a software problem?

In other words, why can’t the communication issue be on the camera’s end? I’m a layperson with this, but it just doesn’t make sense to me that it’s only the software when everyone isn’t having the same problem.

I can be sure as I am not a developer. But it is somehow tied to a verification of the cam MAC on the server. It has happened that way in the past. It was isolated to specific users and specific cams with seemingly similar services and settings. Honestly, if Wyze will replace it under warranty, it might be a quicker solution.