Wyze AI Still Not Learning

I’m so disappointed in the Wyze AI for my cameras. The V3’s at times identify pets and people and the V2’s don’t seem to be learning at all. Most of the time both cameras don’t identify pets being walked by people and they never identify vehicles, unless they are parked and someone walks by them. The only thing they are good at is detecting motion, which can be annoying when it’s birds, bugs and even pollen in the air. Is Wyze ever going to fix the software? Oh wait, probably not because they can’t even fix the V2/Pan camera pink flash clicking bug.

3 Likes

My dog’s butt is always recogniced as a person :rofl: :rofl: :rofl: :joy: :rofl: :rofl: :rofl:

5 Likes

It seems like more and more now the AI is seeing dogs as vehicles. And half the time it doesn’t even see vehicles. Then other times no matter what makes the movement it’s shown as a vehicle. I’m sorry but the AI is broken and wish Wzye would spend the time to fix it, instead constantly using resources to make new products.

1 Like

Are there any vehicles in frame in the event? Parked or anything? Are you submitting these errorous vids for teaching?

Wyze has teams doing both.

Yes, I am aware that AI will label recordings as a Vehicle for cars parked, when something triggers the event. This is ridiculous in itself because a parked vehicle isn’t moving. But I have many recordings where there are no vehicles in view. Also often labels big dogs as vehicles and rarely sees little dogs. This learning process for AI seems to be taking way too long. And yes, I’m constantly submitting the videos to Wyze, but because there are so many it gets tiring. This again is just another software issue that Wyze isn’t fixing, instead they’d rather be releasing new products, which if software based will also have bugs.

1 Like

Hey all, this is Shawn from Wyze AI. Totally understand the frustration of getting wrong AI detection result. Due to the time required for each iteration of AI model update, we are updating the detection model every month. You can check the monthly newsletter for recent changes. Once the video is submitted to Wyze, we’ll fill them into pipeline and use them for training.

But I want to make it clear also this is not a guarantee, due to the nature of the AI technology. We’re trying to push the limit of the performance to find the balance result for all customers, while in some cases false detection will happen.

In short, please check in next month release and see if the problem is getting better.

9 Likes

Once a month? That’s a pretty slow learning process for this “AD” ( Artificial Dumbness). It’s certainly not intelligent. Just tonight every person walking their dog was labeled as a person and vehicle, there were no parked cars anywhere.

Look, I get it that this technology isn’t perfect yet but then you shouldn’t advertise it as if it works perfectly. Because I hate paying for a feature that doesn’t work, especially when the company makes it a point to pop off about how great it is. And parked vehicles shouldn’t labeled as vehicles for every motion sensed in view.

1 Like

AI modeling is designed to be a constantly iterative learning process. A month between releases is absurd. Your backend systems need to be updated in real time. One of my cameras no longer picks up people and vehicles—and that’s pointed at my front driveway and yard. Which, what’s the point? Another picks up insects and is always notifying me. I’d rather see who’s approaching my house than count the number of bugs that buzz by my camera. I consistently upload my videos to Wyze with what these cameras should and should not be recording and notifying me of. Which goes back to my original point. Everything submitted to your modeling algorithm should be instantaneously become part of your learning model, parsed and deployed. I’ve already disabled the bug-counting camera and no longer depend on my vehicle/person camera. Again, what’s the point of having these products? Rather than pushing new offerings out to completely differentiated market segments seemingly every week, why not perfect what you already offer and then move on to your next initiative? This entire Wyze experience (including not just my cameras, but also two now-mothballed Wyze “smart plugs”) has become an exercise in futility and frustration. I’m actually rooting for your success, but please do better.

2 Likes

I completely agree! The AI is basically a joke. It constantly does not see pets and often people, yet see’s parked vehicles. Seeing a parked vehicle is a useless “feature”. Wyze really needs to stop adding things and fix what the already have, that doesn’t work correctly. And…stop using AWS because these outages are really getting old fast!

AWS is one of the biggest scams in who knows how long. It’s inherently buggy and lacks any genuine security safeguards. But these screw ups are ultimately the fault of Wyze and its AI contractor. Seems they have little knowledge about how machine learning should work. Data input, data interpretation, data parsing, data output and subsequent reaction based on data. That’s the simplified version, but this type of process should be completed in near-real time. That’s how most companies leverage AI. Banks, for example, need sub-second AI input and feedback to monitor both existing fraud and new forms of fraud. Otherwise, ¯_(ツ)_/¯, expect to lose money. Wyze and contractor may not have the resources to support the hardware and software needed for this type of data-feedback system loop, but they should look at this as a long-term investment and commitment that benefits their entire product portfolio. Otherwise, people like you and I are going to abandon the platform. So, to Wyze, invest now and benefit later. After all, it takes money to earn money.

1 Like

It’s been how long now and the Wyze AI is still only about 30-40% correct. I have my vehicle parked in the street and my camera watching it. When other vehicles go by, the motion is detected but the video isn’t labeled as anything. But when people walking their dogs go by, the video is labeled as a Vehicle and sometimes it also adds a Person but never see’s the dog. It’s so hit and miss that I just don’t understand why Wyze is adding new label detections when the current ones aren’t consistent enough yet. I’d thing if they can get those accurate, then you add others. All I’ve wanted was for my motion detection to notify me when people are near my property, that’s it but it doesn’t always see them so I end up with a lot of video to sort through. I might as well just let it record any motion and turn off all the labeling junk.

Good Morning - l have 6 cams monitoring the activity around my yard, mostly for the wildlife we have in rural NH. I consistently submit videos to help in tweaking the AI. There are many times that animals and things (from raccoons to insects in spider webs) are tagged as “Person”. I just untag those and submit. Many times it thinks wildlife are pets (raccoon, possum, fox) and I do the same. May I suggest another category for animals or wildlife? Birds, bats and owls could be tagged as well?
Thank you for your service - Paul

Same. A couple weeks ago, my PanCam v1 with CamPlus (pointed at driveway and street) straight up stopped doing any AI detection at all. No changes to the settings; everything is still enabled correctly, but no vehicle detection, person detection, package detection, or pet detection. I’ve disabled and re-enabled CamPlus. I’ve restarted the camera. I’ve turned off and on detection and notification. Still broken. If it does not magically turn on again in a week or so, I guess I will have to cancel CamPlus.

You are not alone with your problems w\ the WCPv1.

I was working w\ Wyze in the DM to find the cause to some CP\CPL recording issues when my tests revealed that the cam is also not activating on motion as it should or tagging AI as it should. Same as you have reported.

The issues were never resolved. And I tried every remedy you did and then some. I am going to delete and reinstall when I get time, then flash back the FW to see if that fixes it.

Here is the original thread:

2 Likes

Thanks for the confirmation. Appalling. I am glad you still have the patience to work with Wyze to resolve this, but I am afraid I do not. My CamPlus subscription was going to renew next month, but I am canceling it since CamPlus Lite does a much better job for less money.

1 Like

Sorry it isn’t working out for you. I only have the one pan, the rest of my many are V3 and one VDBv1. All of the V3 are working as expected and have been improving. I have the CP unlimited license, so one cam acting up until they fix it is inconvenient, but not the end of the world. The pan is indoors and very low use also as an intruder alert cam only when I am away. Will post back when the status changes

1 Like

Same. One Pan v1, one VDB v1, one GDC, and four Cam v3. I’m not inclined to pay for Unlimited when the one I do pay for does not work. Since CP Lite works well enough on the other cams, I may as well stick with that. Cheers!

2 Likes

Don’t need more categories that won’t work!

@skst, I have posted this issue with the WCPv1 short recordings even though it is assigned to CamPlus to this month’s Fix-it Friday thread.

If you are still experiencing this issue, feel free to follow the link, like the post with a heart coin, and add your experience in a reply post (if you are so inclined).

1 Like