View On PC/Browser (Windows / Mac / Chromebook)

TLDR appropriate response:

  • It works in Chrome and some other browsers (not Firefox).
  • It works on most Cams (ie: not Battery Operated Cams though)
  • You need Cam Plus

It works fine for me. Sometimes it takes longer than other times to load.
The Picture in Picture feature with this in Chrome is awesome.

1 Like

Even when using tinycam I had to use BlueStacks. I have been using wyze app or tinycam through BlueStacks almost since the beginning of owning the camera. I am guessing well over three years now . I did try LDPLAYER my older computer, where McAfee did not tell me or warn me , and it is working even better than BlueStacks as far as not disconnecting constantly . I had not heard about this native Android support. I assumed that was for the phone. I do not wish to pay for service and it was my understanding that Wyze was going to be charging.

appreciate you. I soley use chrome. Do I need to be paying for cam plus on all cameras or can I pay for one and have access to all my cameras on this beta?

Currently only the cam that has the cam plus license tied to it can be seen in the Webview. If you have one single cam plus license, then you can only view that one cam on the webview. Cam Plus licenses can be switched to different cams (sometimes free trials haven’t allowed this though), so you could technically view a cam in webview, then when you want to view a different cam, you change which cam has the license applied to it to view a different cam. This is tedious, and not convenient, but if you are on a budget, it does allow that flexibility. But you’ll still only get to view one at a time.

I personally have cam plus on all of my two dozen cams, so I can view any and all of them at the same time. This is much more convenient for me, personally.

Is this coming to Cam Plus Pro anytime soon?

This was answered in the “Fix-It Friday” thread:

1 Like

I would be happy if it just worked for cam plus. I continuously try Explorer, Avast, Opera and Firefox. Firefox never works and the others may get 3 or 4 out of 5 camera’s working for a few minutes and then nothing. I have 3 wyze v3 cams a v2 and a pan1. Most of the time it takes a bit of work to get them all to work on the android app. Looks like a long road before we will see success enough to be able to depend on these for security purposes on any platforms.

1 Like

agreed. Nest cams do a 2FA login approving device and then periodically do a recheck every week or so or I presume if there is some incident Nest is concerned about. This approach would be helpful for Wyze as well.

1 Like

How long should it take for the cam images to be available on the browser interface. Sometimes they come up within 10 seconds while other times it is 5-10 minutes or more. Are there any workarounds, tricks to get the cam to be available? If I go into the cams on my iphone or ipad it is almsot immediate. I am accessing from my Macbook thru the browser sitting at the same location so wifi should be fine. It seems to be the handshake from the browser app with the cam feed?

1 Like

I think they were testing some updates recently. They mentioned something about it during thier discord fireside. Cams definitely used to connect a lot quicker, but it has seemed to get more and more delayed lately. I can only guess why, but hopefully they will push more improvements to get the cams to connect more reliably and faster again.


Thanks. I have been waiting 1/2 hour. I tried logging in / out as well.

Hi sometimes it happens to me … if so you can always sign out clear browser history or refresh while logined in. If that don’t work power cycle the camera by unplugging and wait a minute and then plug back in . Should do the trick .

1 Like

I have tried to get LiveView on my V3(Firmware latest last week) on my PC. I can see all my events but when I try to get LiveView I just get a spinning load signal. Ever since beta I have never been able to get it. Can anyone suggest what might be wrong, since the events are accurate and properly date-stamped.

1 Like

same for me. I tried clearing cache. I tried different browser. I treid login / out. Events work fine. livestream does not work for me either currently. It did work previously.

All 3 of my cameras all of a sudden spinning here too. Did reboot router, reboot cams. Still working on Andriod phone. It’s not us, it’s Wyze

1 Like

I was on chat with Wyze earlier this afternoon. I sent them a screenshot of your comment to let them know that it was not just me. I tried for 2 hours with a few Wyze customer chat folks. All pointed back to me to do device, network resets / reinstalls of everything. I will try again tomorrow. I did everything but remove/add my devices as they are working and have a bunch of rules attached. I do not have time to rebuild everything…

Mine are working on iPhone and iPads. I am on current firmware. They work fine. I can see the events in the web browser app. The livestream is frozen… Tomorrow may be better.

I checked on another Wyze Forum on Facebook for Canada. Two other people who replied so far are on web livestream view and it is working for them just fine. hmmm.

My Camer’s are working just fine too! Need to power cycle … Sign out unplug …wait a minute and it should work. If it’s working on your phone and have no problem then do the above. I don’t think it’s wyze.

1 Like

Personally I would not put a lot of effort in this Beta web view until they come out with a more solid working model. Any updates they do can crash your view and then they will ask you to essentially rebuild on your end. I try it on 3-4 different browsers every couple of days and only once or twice have I got all 5 cams to boot up. Usually get 3 to work consistently the others just keep spinning. The times I did get all 5 running a couple of them stopped after about 15-20 minutes and just froze. I have 3 -V3’s a V2 and a pan 1. It alternates as to which ones will show up. Maybe someday it will work but not worth the hassle at this time. They have plenty of testers, save your sanity.

1 Like

Thanks. Good reminder. I have put it aside for now.