V3 Pro keeps disconnecting - I have to power cycle it for it to work


Since some days ago, my V3 Pro has been disconnecting from the network (or something like that, I can’t really know) and I have to disconnect the USB cable, wait a little bit, then reconnect it for the camera to work again.

The symptoms are: I can’t access the camera from the Wyze app. It says it’s offline. The small status LED on the camera blinks, IIRC, between red and blue when this happens.

I have several cameras on my house, V1, V2 and V3, V3Pro, and, If I recall correctly, this is the second V3 Pro that has this problem. The first one stopped working completely some months ago, I had to go back to a V3 I had lying around. I think that camera started doing this, until it was impossible for it to connect again to the network.

I keep all of my cameras on the latest available version. Right now I have another V3 Pro that is working, but at least once before something like this happened and I had to disconnect and reconnect it for it to work again.

How is the camera powered? Using the supplied USB cable and power brick? And what wifi equipment are you using? How many devices in your house are on the WiFi? Have you tried that v3 pro in a different area of the house close to the wifi source perhaps?

Hello, thanks for the quick reply.

The camera is powered with the supplied USB cable/brick.

My router is a TP-Link Deco X75. I have 3 of them in my house. The camera is maybe… 6 meters from the router, although there are 2 walls in between. But the other V3 Pro that stopped working was even closer (3 meters or so).

The Deco app says I have 21 devices in my network right now.

I “power cycled” the camera just this morning before going to work, as it was with the problem. I haven’t returned but still the camera went offline at some point of the day. This to say that while outside of the home, there is not much WiFi traffic to interfere with the camera. And the devices that consume the most bandwidth (AppleTVs, PS, etc.) are connected by cable. I really doubt the problem is about that. The other Wyze cameras I have (some V2 and some V1) have never had this issue that I can remember.

Which node is the v3 pro connected to? The closest one? Have you tried the camera in a different location? Or can you force the camera onto a different node?

I don’t remember which node it connects to. It should connect to the closest, but I am not sure. I think I can force it to connect to some node in particular, I will try once it connects again (I haven’t go back to the house to power cycle it…)

My Wyze Cam v3 Pro has also been disconnecting as well for 3-4 days.
Please try: 1. Force close app and retry
2.Power cycle the camera.
Connection failed

It happens either every few minutes to hours. I have had issues viewing on the Samsung Galaxy 10 android cell phone and my desktop pc.
I have deleted and added back the camera as well as the wireless device. Restarted the pc and router/modem. I have Windows 10 Pro. The router/modem is a Motorola and it and the pc with the TP-Link usb adapter are 4ft away.

Wyze Cam v3 Pro firmware version:
The newest is
I have not upgraded as everything was working well prior to these several days.
The camera is indoors and uses the power adapter.

I use a TP-Link Wireless USB adapter for the desktop pc.
The driver is the latest. I have used it for about 6 months. No issue until these past few days.

TP-Link AC600 USB WiFi Adapter for PC (Archer T2U Plus)- Wireless Network Adapter for Desktop with 2.4GHz, 5GHz High Gain Dual Band 5dBi Antenna, Supports Win11/10

UPDATE: Just updated to
Checked again and the newest is
Now updated to that.
Now I wait :upside_down_face:

It looks like my issue is fixed. The video has not disconnected. :grin:

I have power cycled the camera and changed the options in the router to have the camera connect to the nearest router, which is the main one actually.

It lasted for maybe 30 minutes or so. Right now it’s again disconnected and blinking between red and blue. The firmware is the latest available:

I saw that the camera kept recording while in this status, which at least is good news (in case I need to check something at some point), but definitely I can’t keep restarting the camera every 30 minutes or so. And as I said before, I have another V3 Pro that just stopped working, I was never able to reconnect it to the network, even to another router.

So, from the 3 V3 Pro cameras I have… 1 is for all purposes dead, another one is marching towards that, and the third is working, but without any explanation for the failures of the other 2, I can’t really trust it.

By the way, I have been at home this whole time since the last power cycle of the camera, and there hasn’t been any disruption to the WiFi signal, Internet nor anything like that, at least not that the router reports or I was able to see. So I don’t think this has anything to do with the WiFi network.

I don’t know if the V3 Pro that is working now has something different than the other. Maybe some revision on the hardware? I do think I bought that later, the other 2 are probably from when Wyze started selling them. There is no indication on the Device info page of hardware version nor anything like that.

Tbh this is something that’s been ongoing for a LONG. Time. Every couple days i get up and both my v3 pans are offline. I’ve done all the trouble shooting, all the power options blah blah blah

For myself it’s been an issue for over 6 months which is completely unacceptable and ina months or 2 I’m going to be swapping out my cams to something else which is a sham cause I really like wuze and have several different styles of their cameras

In my situation, I had 1 Cam V3 at my Front Door that had issues connecting to my router at channel 6 on my 2.4Ghz network. On my ASUS AC86U router, you could see the device keep on trying to establish the connection, but no luck. My other 4 Cam V3 had no problem connecting on that particular channel.

In the end, I had to change the channel specifically for it to connect. I never had that problem before so it was really weird for me to diagnose. After a little while, any time I switch it back to channel 6 it would exhibit the same problem as before.

If I remember correctly, Deco app has the option called “Connection Preference” so your devices can specifically connect it to a specific node and Wi-Fi band. I have also heard reports that sometimes mesh network have issue connecting devices on the 2.4Ghz network. Alternatively, you can enable IoT network in the “More” tab on the bottom right in the app and set it as 2.4Ghz only. You basically create another dedicated wireless network like a Guest network, but I am not sure what is the difference (Guest network is probably isolated). From what I read online you can only connect to the main Deco router on a Guest network whereas IoT network allows you to set connection preference to connect to a specific Deco.


Thanks for the info. I did change the settings on the Deco app so all the Wyze cameras use only the 2.4Ghz band (they can’t connect anyway to the other one, but this way I guess the router doesn’t even try to redirect them to the other band?) and to the main router.

I haven’t set an specific channel. The Deco app reports that “everything is great” regarding the channel saturation and so on, but I will check if it is possible to set the channels manually.

I haven’t tried the IoT feature. Mostly because I would have to reconfigure all my devices again, and in several cases it’s somewhat tricky to access them… And being that that’s just another 2.4Ghz network using the same routers, I don’t know if it’s going to make any difference if the problem is the camera itself. As others have said, this is not so uncommon apparently.

Edit: I have checked and there is no way to specify a channel for the networks, at least not in the app. It is using Channel 2 for the 2.4Ghz network.

I have changed the preferred Deco to another one (also near the place where the camera is) and restarted the Decos. Let’s see if it connects and stays connected. I haven’t power cycled the camera since the last time, some days ago.

A lot of IoT devices especially 2.4Ghz devices such as Wyze cameras and MyQ devices have trouble connecting to a mesh network. As mesh network don’t have a dedicated 2.4Ghz network, the 2.4Ghz devices can’t “see” the network. My guess is that sometimes the mesh network can’t lead the correct devices to the correct network (2.4Ghz vs 5Ghz). Some users will try to temporarily disable the 5Ghz network so the Wyze camera will connect and then enable it back afterwards. However, if the Deco system reboots for any reason (updates or power outage), then the Wyze / MyQ devices can’t connect to the network again.

An alternative solution to the above is probably enabling IoT network or Guest network and set it as 2.4Ghz only. I don’t know if this will help your particular issue though.

I will try with the IoT network, at least with this camera, and see if something changes. I seriously doubt it though - the camera was working fine in the same environment for months, until it did not. No changes to the WiFi network, number of clients, nor anything like that.

Anyway, it might be in any case better to have a separate network for the IoT things, I just don’t like the prospect of having to reconfigure this kind of things were you have to do several steps and not just setup the password…

Here are FREE apps to to see which wifi channel are in your area and being used the most and least.

Turbo WiFi Analyzer

WiFi Analyzer

You have to log into your router to see which channel you are using so you can change it. Mine was set to Auto. Using the above apps I saw it was on ch 6 which was being used alot.

I determine that ch 9 or 10 were least used so I am trying ch 9 for now.
Here is a screenshot showing Turbo WiFi Analyzer
I am Motorola on ch 9


I created the IoT specific network on the Deco and moved the cameras there. So far, all of them remain connected. So it might be the solution.

There are 2 specific things that are different between that network and my main one, at least as far as I can see on the config:

  • There is only 1 band being used, 2.4Ghz. I don’t know which channel is, the app doesn’t say.
  • The security is different: my main one is WPA2/WPA3. The IoT uses WPA/WPA2. I am inclined to think that the problem is related to this.

I don’t think that the fact that there is a 5Ghz network with the same name will cause issues, as I believe the Wyze camera only has a 2.4Ghz radio… anyway, let’s see how it goes on the next hours/days.


Thanks. The Deco app has an option to identify and optimize the channels used, and it has always said that the setting is “perfect”. I run it from time to time, but I have never seen it report congestion nor anything like that.

I haven’t tried any other app in that network to study the Wi-Fi channels, mostly because for Mac is somewhat difficult to find apps that work.

That’s great news. I think you’re right that WPA3 might be the problem.

The IoT / Guest network suggestion was because I have read on TP-Link’s subreddit where users had problem connecting to their Deco XE75 mesh network with their Wyze cameras. However, since you are able to establish connecting already then it is very likely that isn’t the problem. Deco X50 was another mesh network which I have seen which have problems connecting with their Wyze cameras. The IoT / Guest network at 2.4Ghz only seem to fix that problem (assuming it doesn’t cause other issues like connecting to the internet).

That is correct. Here is a Wishlist requesting WPA3 support for Wyze devices :slight_smile:

Well, it’s not that the problem is the lack of WPA3 support. The camera was connecting, the only option is WPA2 in that scenario. The problem was that it kept disconnecting after a while.

Bear in mind that there are 5 other cameras on this setup, from V1 to V3Pro, which did NOT disconnect as this particular one.

As the change was to WPA/WPA2, I am guessing it is still using WPA2 to connect. Or maybe if it sees WPA available it will use that, and that’s why it has not failed… yet? I don’t know.

But the problem is not the lack of WPA3 support, not in this particular case anyway. Anyway, it would be great if they support the newer protocols, of course!

I switched to ch 9 for wifi from Auto, see screenshot. This morning I am getting:

Please check your internet connection or power cycle the camera.
Device is offline (error code 90)

Please try:
1.Force close app and retry
2.Power cycle the camera.
Connection failed

I am now trying ch 10.
I have power cycled earlier and removed and added back the device. See above post from me from 3 days ago. I should not have to do more then one time.
The camera is not in a good position where I can easily do this. Getting out the stepladder is not what I want to do…
All I can do in power off and on and reset the wifi channel.



2/16/2024 7:24 AM PT - We are aware of an issue with our AWS partner which has impacted device connection and caused login difficulties. We are taking steps to mitigate the problem on our end as we work with AWS to resolve the issue.

6:31 AM PT - We are currently receiving reports of offline devices and login difficulties. We are currently looking into the issue and will have an update as soon as we have more information. Thank you for your patience.