v2/Pan firmware Release Candidate Test 7/6/2021


  • Wyze Cam v2: 4.9.7. 787
  • Wyze Cam Pan: 4.10.7. 787

This update is only supported by Wyze App 2.22 RC and above versions.


  • Fixed a potential issue that could result in Error 06
  • Security improvements


  • If you experience connection failures when accessing the live stream the first time after the firmware update, please fully close and reboot the app or refresh the device list before opening the live stream.
  • iOS will display “Firmware Update Failed“ after the firmware update even though the update succeeded.


• Firmware update experience

• Live streaming and Event viewing

• Overall camera performance and stability


Due to the latest Hub Beta firmware MAJOR problems (and with no communication from Wyze about what’s going on with it or if anyone even acknowledges there is something they are looking into), I did this firmware update more carefully, especially since the release notes here say that there is a known active bug that says the update failed on iOS when it didn’t actually fail which indicates to me that at least some known bugs were known but not addressed/fixed yet before this release to beta, and so there could be others. I decided to start with just 2 v2 cams and my cam pan (one of the cams has had the connection error issue in question appear sporadically so it seems like a good test candidate). Using Android and the account tab for updates I told those 3 devices to update. All 3 devices said the update failed.

I thought maybe the same thing was happening on Android (Android 11 using a Google Pixel), and perhaps the updates say failed, but were really successful. So I went out and came back in to the account tab to see if it showed a change. The Pan Cam now showed it was successful:
But the 2 V2’s still said their update failed:

So I went to check on them individually through the Home tab.
One of them (North Cam) popped up a notification that there was an update available. I told it to update this way, and it was successful.
The other Cam (South Cam) was knocked offline by the update attempt. It was totally unresponsive after the update fail (but was working fine before the attempt) The only option I had was to reset the power and hope it wasn’t bricked. I reset the power to it, and it booted back up. I selected the device from the home screen and this cam did not give me a notice there was an update like the other one. I had to go into settings, and there in settings it DID recognize there was a pending update. I told it to update again. It said it failed again:

I went out, and went back into the device, and at least this time it was not knocked out of commission. I went into settings again, and I noticed it is showing the new firmware version afterall in the device settings screen:

That indicates that it was actually successful, but when I clicked on the firmware version button, it is telling me that the previous screen is wrong and that I am still on the older firmware version and still need to upgrade:

I exited the app again and tried going back in one more time, and now it shows it is up to date as it should be.

And the account tab now shows all 3 are updated correctly too:

Again, I am using Android, and had the same issues as the release note stated happens with iOS (said it failed when sometimes it didn’t).

So in summary: from account tab, all three said they failed, but pan cam was successful, from individual device, one of the V2’s said it was successful and actually was successful as it said. The other one was knocked out by the first attempt and had to be completely rebooted, then still said it failed the second attempt, but ultimately showed to be successful.

Hope that helps. I might wait to try my other 5 V2’s for now since this firmware appears to be a little buggy from that standpoint, and after my recent worries with the Hub Beta firmware having so many problems with no way to roll it back or know what’s going on. Playing things safer now that bugs have increased without communication.

I will update after checking streams and events throughout the day and see if it seems to be reliable, especially on the cam that has sometimes had the issues in question.


Just loaded the V2 FW, don’t have a PanCam. FW Loading took a little time, but finished successfully. I did it through the Firmware Updates in the Account area.

So far the camera loads and streams as expected.

1 Like

I have had issues like this when I decided to use the mass update in the Firmware Update area. But when I do one at a time, it seems to work without issues. At least more regularly. Wonder if the issue is with the Mass Update of FW.

1 Like

Wow… this has been a disaster one for me. I stopped at one Pan that didn’t come up. I’m leaving the others well enough alone.

At least 10 of my V2s either failed or it blew away all the networking. I’ve had to reset up a couple already. Tread lightly on this one IMO.

1 Like

Showing Update Failed in Android is not something we knew. Could you help us submit a log under the device, please? I want to take a closer look into the issue.

Pan Cam Device is offline after update. (error code 90)
I will try to cycle power when I get home.

You may just need to kill and restart the Wyze app.

Unfortunately, App kill /app kill and device restart didn’t bring camera back. I’ll power cycle when I get home and see if that brings it back.

If you could, please provide a SD card before powering cycle your device. It will help us debugging the issue even though the power cycle fixed the issue.

Thank you!

To get the SD card log, you can pop out SD card and re-insert into the camera? After two chime sound you can take out the SD card. On a PC/Mac with a SD card adapter, please put your card inside and send me the log_XXXX.txt file under SD card root directory.

And please also make sure your Wyze app is 2.22 RC and above. New firmware needs the latest wyze app to work with.

This is why I’m very hesitant to install beta firmware now. Most of my cameras and other items are out of warranty. Wyze makes it very clear, if a beta firmware (or any firmware for that matter) bricks your device and it is out of warranty you are just out of luck. Buy a new camera, sensor, lock, whatever.

1 Like

I’ve got some important views with my remaining pan cams and difficult to reach areas as well. I suppose next firmware release and after a week or so I may update them. I probably need to revisit putting most of my cameras back on release and a few easy to access models to continue helping with beta testing. Today has not been fun re-flashing and then odd behavior where cameras had to be rebooted several times to go back online even though it was already claimed firmware was up to date. I feel like I may have introduced instability while last rev was stable for me.

After many attempts to update 8v2 and 3 pans, 1 v2 still have error code 90 with flashing blue light.

Log submitted 245218

Forced closed application, unpluged cam without success.

Update failed. Ran it again and it succeeded. Now 4 of my cameras are offline. :disappointed:

I submitted a log for each Cam

This one is the V2 that failed at account tab and required a reboot then said failed from settings update but it worked

This one is the V2 that failed from account tab, but then in settings update it was successful (even said it was successful)

This is the pan cam that said failed on the account screen, but it was successful:

All of those were using the android app.

Thanks for indicating someone is watching this thread and aware of or looking into the issues. That’s one of the biggest things we like to see if we’re willing to risk our devices to help you out. Appreciate it.


Well stated and fully agree.


Flashed one V2 without issue other than having to force quit the app to get live video.

You have bonus points with me, just for seeing your front door is French:

Sadly, I am losing my French fluency from lack of use (studied it all through High School and College, and also volunteered living in Haiti for 2.5 yrs speaking both French and Haitian Kreyol…I now speak Kreyol better than I do French, but wish there were more people around to talk with regularly. Now I’m tempted to rename a bunch of my devices to French & Haitian. :slight_smile:


Could anyone with the (error code 90) issue provide me a SD card please?

We are trying to identify the issue as many of you are reporting it (Thanks a lot!). Trying to identify the issue, the SD logs are much more helpful:

To get the SD card log, you can pop out SD card and re-insert into the camera? After two chime sound you can take out the SD card. On a PC/Mac with a SD card adapter, please put your card inside and send me the log_XXXX.txt file under SD card root directory.

1 Like