Wyze Cam v2, v3, Pan, and Pan v2 Firmware Released - 3/17/22

Hi, Forum Friends!

We have Wyze Cam updates with security improvements and AI Event bug fixes releasing today! :muscle:

Wyze Cam v2:
Wyze Cam v3:
Wyze Cam Pan:
Wyze Cam Pan v2:

Read our Release Notes:


All of my V3’s and Cam PAN updated OK …My 6 V2s will not update " Update Failed" Tried multiple times …

I think I am going to wait 24 hours, and let a bunch more people test this firmware before I jump in!
I wish we could get more details on the “security improvements”.


Have you tried restarting the v2 Camera’s via the App or Removing Power from the Camera and then applying power again.

Also note, sometimes it works to clear the cache in the App and if you have an Android, do a Force Stop and Clear Cache from there as well. Then restart your device and try again.

This update broke 3 of my V3 camera’s. They no longer connect. I now have to manually roll back to the old version. This also happened on the beta version of this release. These are cameras I got when the V3 first came out. Is there a hardware problem with these cameras?

1 Like

Sorry for the trouble. After updating the new firmware, did you see any error code when connecting them to the live stream? Thanks.

My Cam V3 now gives connection errors after upgrading firmware. I’ve tried resetting the camera and removing and adding it from my account and completing resetting it multiple times and still not works. My v2 cams updated fine and connect ok.

Please help - how can I get my V3 cam working again?

Sorry for the trouble. May I ask what is the connection error code and what is the LED status you saw on the V3? You can try to power cycle the cam again. If it’s still not working. Please submit a log and post the log number here. Thanks.

1 Like

Still not working.

What is the status of the LED light? Is it solid red or flashing blue? Please submit a log (you can submit a log from Account → Wyze Support → Submit a Log) and post the log number here. Thank you very much.

It appears to me that the connection errors may not be related to the firmware update but ,. to the app update itself.
Because cameras exhibiting problems have not been updated to recent firmware

I’m not sure, even when I tried to manually install the update they failed to connect, but it was only with 3 of my V3’s. My other 5 V3’s updated with no issues.

@WyzeBaohua I submitted an error report. Log ID: 507205. And the error in the app is “Connecting camera by secure channel. (1/3)”

The camera just keeps rebooting itself. The only way to fix it is roll back to previous version manually.

1 Like

Three of my four V3 cameras took the firmware update with no problems this morning. The fourth V3 camera took the firmware update only AFTER I did the following: 1. Deleted and reinstalled the iOS app on my iPhone. 2. Rebooted my home internet by powering off and powering back on my modem and router. 3. Unplugging the V3 camera for around 10 minutes. 4. Repowering up my V3. Firmware loaded immediately.

1 Like

All 30 of my operational Wyze cameras have had this update for a while - I’m a beta tester. No problems with the update or use afterwards. This is V2, V3, and original Pan.

1 Like

Thank you so much for the log. We will check the log the investigate this issue.

It appears the camera keeps restarting. There is no LED light until after I do a factory reset. After I do a factory reset, the light is red and I’m able to successfully set it up again and scan the QR code however after setup it says “Connection failed” when I go to the camera in the Wyze app. I’ve tried doing factory resets with the SD card out multiple times and keep getting the same results.

1 Like

Please submit a log (you can submit a log from Account → Wyze Support → Submit a Log) and post the log number here. Before it says “connection failed”, was it connecting 1/3, 2/3 or 3/3? Thank you.

Log ID: 507422

1 Like