Time on iOS notifications is wrong

Please post a link here so we get notified!

I was actually able to fix my Android by clearing data, uninstalling, restarting, and reinstalling. My wife’s iPhone, for which I am obviously less familiar, we uninstalled and reinstalled and it’s still displaying wrong. Not apparent where to wipe data/cache on iOS.

Thank you.

You can clear app cache by going under Account > App Settings > Clear.

Didn’t do any good for me though. Didn’t try uninstalling/installing the app. Especially with the new app version out, I’m not sure about updating to it just yet.

Is there a system cache to clear in iOS? On Android you have the app’s internal cache and then a system cache for the app; you can clear the apps internal cache and then see the remaining cache in the system settings.

edit: missed a question mark.

It seems deleting and reinstalling the app is the best you can do on iOS.

Other than Wyze app cache, you can delete browser cache, which shouldn’t matter in this case.

Just noticed the same issue on android after trip to Asia and back.
Come one Wyze it’s been 4 years now, still not fixed?
Tried some of those sync device, see if it helps.
If not, going to try the clear app data/cache.

Going back to older posts on this thread, the original issue seemed to happen due to daylight savings as well, and the workaround was to reinstall the app. That doesn’t seem to fix the issue for most of us, at least not on iOS.

I noticed this issue since the end of June. I assume the bug cropped up a little before then, or we should have seen more posts on this.

App reinstall doesn’t fix the issue consistently on Android either. The bug still exists for both OS.

I just set up one Wyze V3 and the time notification is three hours behind. I never traveled out of the time zone. I uninstalled and reinstalled the App on IOS, cleared the cache, turned off and reconnected both camera and iPhone with no resolve, Also I sporadically get notifications, if I get one and there is motion after I won’t get another. I probably will return this if I can’t solve this in the next day. Frustrating!

If you never traveled to another time zone, perhaps you can try what this article says. It didn’t help me but it might help you.

Tha August Fix-it Friday is up. Please like my post under that thread if you want to vote for this notification time issue to be fixed.


I’ve started seeing this issue since traveling to Europe and back to the US. My iOS notifications have a time that is now 6 hours ahead. My family also see the same problem on their phonies. As a previous iOS developer I can tell you that the messages in those notifications come from Wyze server side. The app itself has nothing to do with the notification until you tap on it. Some how the Wyze app had previously realized I was in a different time zone and told Wyze. All notifications since have been stuck in that time zone. What I don’t understand is why it didn’t do the reverse when I returned to the US. Frustrating !


Happening to me as well on iOS. I haven’t traveled anywhere. Been on EST timezone, setup the camera last week and it’s always been wrong. Time within the app is correct, time in the notification is off by 3 hours.

Hey devs, however you’re pulling the date for the events tab, do the same for push notifications, not event.create_time + timezoneOffset or whatever is happening.


Looks like enough people reported this issue that Wyze is looking into this:

1 Like

@WyzeJasonJ suggested manually changing the time zone and I was able to fix this issue.

In iOS: Settings > General > Date & Time > Set Automatically (uncheck)

Set your phone manually to the current time zone you are in, and that seems to make the Wyze app update Wyze servers with the correct time zone. Hope this works for everyone!

Thanks for the tip, although I don’t know if it bothers me enough that I’d have to manually adjust time zones during travel.

Yeah it didn’t really bother me since I usually see notifications right away.

Anyway, for people bothered by it you can try this.
Not sure if all the steps are needed:

  1. Manually set your phone’s time zone to another one.
  2. Wait 10 minutes.
  3. Manually set your phone’s time zone back to your current time zone.
  4. Unset the manual time zone override.

This is not something you should have to always do, this is just something we are looking at that will cause the times to match again. If it works it should only be a one-time thing.


Ahh, okay. Thanks for clarifying. Let me give it a go.

I live in eastern time zone and just came back from Iceland. My app has the correct time, but my notifications still show +4 hours on the time stamp.

I deleted and reinstalled the app. I turned off the automatic time zone setting and reset it.

NOTHING is changing it and I don’t know why. I have tried everything suggested on this forum with no results. This is ridiculous.

Hallelujah! This worked for me. My notifications were stuck on two hours west. I manually changed the time zone to five hours east, rebooted my phone and waited 10 minutes. Then I went back into settings and switched my time to automatic, rebooted again and waited another 10 minutes. Presto!