Time on iOS notifications is wrong

YES, this worked! Thank you.

1 Like

Unfortunately, this process and every other process recommended did not work for me.

While I was hopeful, this algorithm and every other recommended remedy listed in the Wyze forums have failed to correct the time zone differential between Wyze notifications and phone time. The Wyze mothership still has work to do.

That is too bad. It looks like you’re on iOS?

Are you in the same time zone as your cameras? Did the time on notifications change when you manually set your phone time zone to something else?

The time on my notifications were off by 12 hours after I traveled out of the country. What I did to fix it was:

  1. On my iPhone: Settings > General > Date & Time > Set Automatically (uncheck checkbox)
  2. Set my time zone to London
  3. Wait 10 minutes
  4. Set my time zone to EDT (my current and camera time zone)
  5. Wait 10 minutes
  6. On my iPhone: Settings > General > Date & Time > Set Automatically (check checkbox)

After step 4 my notifications were already showing the correct time. Step 6 was just to set my iPhone’s time zone to be automatic again.

Hope this helps.

2 Likes

Got the same problem, did the steps on my iPad and now it’s ok, even on my iPhone without touching it. Thanks

1 Like

Same issue here. New cam set up yesterday. I don’t travel, don’t mess with time zone settings. The time on all notifications is off by 3 hours. Log submitted. This issue dates back to 2019???

I see what IL1 posted and hopefully those steps work for others successfully.

I came to this thread to leave a comment due to the fact the time on my notifications corrected itself without me doing a thing. I haven’t been paying close attention but as the last app update was 3 weeks ago I don’t think it was a bug fix there. Considering push notifications come from a remote server that generates the text of the message, I’m thinking Wyze might have fixed it on their end.

1 Like

Same!
I uninstalled it on my iPad and it fixed my phone and iPad

As for incorrect notification time, nothing i have tried seems to work. Phones calls to Wyze also does not help. The people there dont seem to know there is a problem. Wyze is only interested is selling, not fixing.

1 Like

yeah useless “solutions” provided here
timestamp on video is in different timezone compared to time on notifications and on slider in playback mode, how ridicolous 4 years not fixed

This isn’t a 4 year old issue, it is a newer issue that has popped up and people have posted on an older issue thread. This is being followed in our Fix-It Friday and there is currently a work around to try and get it fixed.

:clock4: Discord - Camera time and notification time do not match :clock430:

We believe we’ve identified the root cause of this. In the meantime, please try manually changing your cell phone’s time zone to a different one, leave it in the other time zone for 5 - 10 minutes, and then change it back. We’ve heard back from customers that this workaround has helped with this problem. If this hasn’t worked for you, please let us know!

Link to Fix-It Friday thread

After a month of trying different things I finally got the right time notifications. I set the time on both the iPad and phone manually. Deleted the app on both. Turned them off for 10 minutes and then back on. Set the to auto and then reinstalled the app on both devices. Since then the time has been correct. Not sure if all this was necessary but it worked.

Bernard Kaufman

1 Like

After a month of trying different things I finally got the right time notifications. I set the time on both the iPad and phone manually. Deleted the app on both. Turned them off for 10 minutes and then back on. Set the to auto and then reinstalled the app on both devices. Since then the time has been correct. Not sure if all this was necessary but it worked.

1 Like

Deleted App
changed time to a different time zone
re-installed app
opened app
change time zone back and Set Automatically
finally works!!!

1 Like

And Wyze had no idea how to solve the problem. Told me they would investigate and get back to me. That was months ago. Wyze customer service is totally useless. I have never found them to be of help.

Bernard Kaufman

I’m having this same issue and not sure how to fix it.

Turn off auto time set… delete the app set the time manually. Reinstall the allturn on auto time set. That worked for me.

Bernard Kaufman

1 Like