Time on iOS notifications is wrong

Same issue here. Just for clarification, it’s just the alerts in the task bar that show the incorrect times. The alert inside the app’s events tab displays the correct time and each camera shows the correct time.

Clearing app cache did not work for me. I suspect the problem will correct itself with time. I spent a week in a time zone that was +6hrs from home and noticed the issue. Then I spent a week in +7hrs time zone and now the alerts reflect that. Hoping 3-4 days in my home time zone will fix it.

I have the same issue but it has happened after the daylight savings change. I too have updated the time on all cameras. We need an update time across all system button that does all cameras and app at once

Still an issue in 2022. It’s annoying to reinstall the app twice a year.

I am also experiencing notifications that are two time zones off after traveling. This relates to my cameras and original connected sensors. This does NOT relate to my Wyze Lock as notifications for this have a correct time. I have cleared the cache and deleted the app and reinstalled, with no success. I will submit a log.

Still happening in 2023…
Just got my doorbell setup and noticed the app notifications were 5 hours off.
Time within camera was correct, phone time is set to automatic, never had issues with this with other apps. Just this one.

Tried everything: clear cache, sync time, restart app, delete app, reinstall app, signed out, signed in, changed iPhone time to manual, revert back to automatic, restart phone, factory reset doorbell and set everything back up.
Was on chat support for 30-40 minutes, but kept getting disconnected. To their credit, they emailed me, but never responded to my reply.

The final nail for me? I said “ok I’ll just turn off notifications for motion” but I still receive them even tho the toggle selected off…

1 Like

This is still happening with Android as well.
I’ve cleared the cache, synced time and deleted/reinstalled the app. Notifications are still an hour ahead of local time. Timestamps in camera and app logs are correct time. Pretty sure the problem started when I returned from a trip east.

Still an issue mid-2023. Unacceptable.

1 Like

I don’t have that issue using iOS.

This currently happening to me 7/31/2023. The timestamp on the notification is an hour ahead of the actual time. The camera itself has the correct time. Is the answer still to delete the app and reinstall?

1 Like

That fixes it for some people, but didn’t work for me.

That also did not work for me. Cleared the app’s cache, the app cache in the system, cleared data (wipes everything), uninstalled and reinstalled, setting the phone’s time from automatic to manual (and back again)… Nothing seems to resolve this issue for me. And we traveled +7hrs, so the notification’s timestamps are really messed up.

Deleting the app and resintalling it from google play fixed this issue for me. Thank you for everyone who posted this.

Did not work for me either. Deleted a couple of cameras and reinstalled without cure. Nothing works. Using iPhone with everything updated. Someone, PLEASE, find a cure and post here.

The cure is for Wyze to fix their code. They don’t care.

I am still experiencing this issue. I’ve tried everything (see above) and ultimately turned off notifications altogether for Wyze.
I submitted a log file to their support and tried to discuss it with their support team.
I encourage anyone still seeing this to take a screenshot and “Submit a Log” under Wyze Support in the Account Settings in the mobile app.
That’s the only way they’re going to fix this.

I was provided this templated response:
"Thanks for sending the log! Our engineering team received your log and is now aware of this concern. Your log, together with the troubleshooting steps that you tried will be greatly helpful for the ongoing investigation. I may not be able to give you a timeframe for now as to when the update will be released because we are still working on it. Once we deploy the patch fix for this issue, you will receive notifications in your app that will encourage you to update it. We appreciate your patience during this time.

We will take this experience as a tool to continue improving the level of service we are giving to you and to the rest of our customers. We are actively working to cater to these experiences for the betterment of the products and the app."

Seems to be the same issue as posted on this other thread. I’m seeing the same issue after international travel and submitted the logs to Wyze and Support.

Yet another thread on this, it appears…

If many people are bothered by this issue, perhaps we should vote on this for the next Fix-it Friday.

Honestly I am getting notifications at the right time, so it doesn’t bother me that the timestamp on the notification itself is off. Other apps don’t even show a timestamp on notifications and I never really felt the need for it.

I would happily vote on this for Fix-It Friday.
Didn’t know that was a thing (I’m new here).
Please advise how to.

Here’s the post from this past month:

I’ll add an entry when the August fix-it Friday comes out. :+1:

1 Like