Sense hub keeps going offline: firmware bug?

I’ve been using a Wyze Sense setup at my vacation home for over a year now, to monitor door, motion, climate and leak sensors. Worked great for the first year or so, but a couple of months ago the sense hub suddenly went offline, taking all the sensors with it. After much fiddling & research I was able to recover it by doing a power cycle (unplug hub from power, hold button for 10 sec). Hub came back and all sensors with it! Great, yay Wyze!

Then a few weeks later it did the same thing, and power-cycling again fixed it. I also applied the latest firmware update in case it was a bug. But then last week it went offline again, with the same fix!

Since the home is in another country I can’t very well pop over and reset it every time this happens - I need the system to be reliable! Since it was reliable for a year I’m wondering whether a firmware update caused this problem or whether there’s a hdw problem and I need to replace the hub itself.

Has anyone else run into this behavior? If so, when? Have you found a permanent fix?

Thanks in advance for any helpful info,




I have to first give you more kudos for your addition of a local Siren to the HMS workaround post! I have linked to it many times over and used your template to install an indoor and outdoor siren & use Alexa Arm\Disarm commands & Wyze shortcuts to control it. It works great!

I have my hub connected by Ethernet, so there may be a difference if yours is connected by WiFi, but I have not experienced an offline issue since I installed it 19 months ago. It is operating on FW (November 28, 2022).

One troubleshooting question would be to ask if there are other WiFi or Ethernet devices at the remote location and if those are also experiencing offline drops. It might indicate a WiFi or ISP issue.

I would suspect that it is going offline due to a WiFi connection loss (if that’s how it is connected). Since there is no really good way to reboot the hub remotely because if it’s battery backup, the only thing I can think of would be to:

  1. Install a smart plug on the hub, cut the power, allow enough time for the battery to fail, then turn the plug back on and allow the hub to reboot. NOTE: this is an untested theory. I have not tried this.

  2. Install a smart plug on the router so that the entire network can be rebooted to establish a new connection.

  3. Use a Router WiFi Monitor\Rebooter that will reboot the router any time the WiFi or Internet ISP connection is lost.

Hope this helps!

Hi @SlabSlayer,

Glad the siren post helped, and good point about the wifi vs Ethernet connections. You’re right that I’m connected via Wifi only (my router doesn’t have an ethernet port), and the hub is definitely losing the wifi connection. But none of my other devices (incl. Wyse cams) go offline, only the hub, and since the hub worked fine for a year and I haven’t made any changes to the router, I really think the problem’s with the hub.

Great idea about the smart plug for the hub – will go ahead and install it. BTW, I had already tried putting a smart plug on the router (for a different connectivity problem!), but realized that once I switched the plug off I could no longer switch it on again, since the router was now off and I couldn’t connect to it! Thought about putting a timer on the plug but don’t really want to power the router on & off every night.

Keep the ideas coming…

  • Dave

Do you have a phone at the remote location?

A local periodic reboot schedule would be all that is effective for a smart plug on a router. Beyond what @WildBill suggested, you can also consider a Rebooter Cord. It can be scheduled like a smart plug for regular reboots, accessed for manual power cycle of the router (off then on in one command), and it will automatically power cycle the router if it detects a dropped WiFi connection:

I’ve been having the same issue for a similar amount of time. I was connected via WiFi, but my issue persists even after connecting via Ethernet.

I can also add that when I cannot connect to the hub and the sensors cannot be reached, I am still able to successfully re-add the hub as a device, but it doesn’t correct the issue. Only the reboot corrects the issue. It to me feels of a big for sure though I’m not sure when it may have been introduced, or if perhaps it’s related to hub age instead (like sense v1 was).

Welcome to the Wyze User Community Forum @fjbennett!

I doubt that the hub is exhibiting the same behavior that caused the early EOL for the V1 sensors. That was a Texas Instruments caused component engineering issue.

Also, there haven’t been widespread reports of this issue. Those that did experience it have been solved by firmware updates or network connectivity improvements.

So when you do a repeat setup of the hub without deleting it, it works for a bit but still goes offline both while connected by Ethernet and WiFi? A soft reset will also do that?

What firmware version do you currently have installed?

I’m not suggesting that it’s the same issue as the V1s, only that they have been previously vulnerable (overlooked) an issue where simple age caused unexpected failure.

No, while the hub is showing disconnected, and I do a repeat setup without deleting it, the setup completes successfully, but continues to show disconnected. Unplugging, reconnecting the ethernet does nothing. Only a reboot of the hub restores the connection.

Once it is showing connected, it will continue to work for an unspecified time, until it is shows disconnected again. Without any notification, so I’m never really sure how long that has been the case. I have had my hub connected via Ethernet and Wifi both, I went through the effort of reconnecting it to Ethernet thinking wifi may have been a cause, but the issue persists.

My hub is running

I am on the same up to date firmware. I have been using the hub for nearly two years via Ethernet and haven’t had any offline problems the entire time short of the AWS Service outages. Since Wyze initiated the Offline Push Notifications, I have received only one and it was a momentary blip that recovered almost immediately.

One step I take, given the importance of the HMS above any other device I have, is turning off all QOS settings in my router so that the router can’t make decisions about which device on the network is more important. I also designate my HMS as the top priority device. This restricts the router from dropping bandwith to the Hub IP and forces everything else to suffer if there is any issue the router needs to resolve.

The fact that a new setup does not resolve the issue but a reset does would lead me to believe that the router may be having an issue and the IP is stale. When the hub reboots, it gets a fresh IP. There have been instances of other devices stealing IP addresses from Wyze devices… or should I say routers reassigning stale IPs to other devices.

Another factor I haven’t researched much is what happens if the hub overheats. I do have devices that will flake out if they get too hot.

I’m not saying it isn’t the hub… But it is worth looking into.

I wasn’t aware of the Offline Push Notification change (it appears support isn’t aware either as they said it wasn’t something that existed but agreed that it should) but nonetheless, didn’t get a notification that it was offline. I typically only notice the hub is offline when I go to check on a climate sensor and it is offline because I can’t reach the hub.

Stale IPs aren’t really a router issue, but a device issue. In any event, I’ve kept an eye on the IP and the same IP is re-issued on reboot so it certainly isn’t a “stolen” IP situation. For added sureness, I’ve just also reserved that IP for that device.

Even if it is a QOS related issue, the hub should certainly re-connect automatically and not require a reboot to do so making it again a device issue. Further, rebooting the router also doesn’t resolve the issue, ONLY rebooting the hub does (that I’ve found so far). I do appreciate the suggestion though, I’ll make some QOS changes to see if it helps. Failure to reconnect on network restoration, even if it is a network issue, surely has to be considered a device flaw.

Another thing to note as I’m not sure if it’s relevant but at very least points to something overlooked, after reboot when this happens, the hub volume defaults back to “med” instead of “high” where I set it.

I totally understand the issue with shaking these sorts of things down, it can be very complex. It could be some strange bug that only exists with users that use 3 keypads, 6 moisture sensors, and 6 climate sensors for example. Hard to chase down until someone else with similar issues comes forward, which is why I added that it’s happening to me as well.

1 Like

Thanks for all the info & suggestions, @SlabSlayer and @fjbennett - interesting to know that the timeout occurs regardless of whether the hub’s hardwired to the router or is Wifi only. (I had assumed the latter.)

One other new piece of info: I have a second Sense Hub at my home in Seattle; it’s also wireless-only, but has never lost connection. It’s on an earlier firmware version ( than the one at my vacation home (actually, a boat!), which is on That’s one reason I thought it might be a firmware problem.

The obvious next step would have been to upgrade the Seattle router and see if it then starts going offline, but I was reluctant to do that because I was at the boat (~6K miles from Seattle) and couldn’t reboot the Seattle hub if it went offline. However I’m back in Seattle now so will try upgrading it. If it starts going offline then it’s definitely a firmware issue!

  • Dave

It was implemented 12/19/22:

1 Like

That’s good news - wonder if they implemented this because of the problem with the hub going offline all the time? :wink:

Considering that very few users have that network connectivity issue, it probably isn’t the best reasoning for the feature. It is more likely that it is to meet the requirements of the Monitored Connectivity feature for the Monitoring company so that a certificate can be issued and submitted to insurance providers.

Yeah, that makes more sense…

I also have this issue at a remote property. Started back in November. I was on WiFi and it went offline. When i got it back online i connected Ethernet. Now about a week ago that went offline. Internet is fine, rebooted the router and it seems fine. I haven’t been able to reboot the sense hub as the house is about 2000 miles away…

Sounds like the same issue. Firmware is

I like the smart plug idea. I’ll have to set that up next time I’m out there.

Yep, exactly the same symptoms!

I am having exact same issue. Tried all troubleshooting steps of resetting the Wyze Sense hub, using Wifi, using different port on Router, changed Wifi Router… None helps.

Only a power recyle (Turn Off, wait for 10 seconds, Turn ON) seems to be the fix.

This is the solution I have put to use (using a Wyze plug – what a tragedy :crazy_face: )

Reading this post, looks like a firmware issue.

I am same firmware as all above - Firmware

1 Like

That is great that something is working! That was actually a shot in the dark and an untested theory I had for a reset. Now I have so many more questions.

How are you getting around the battery backup not kicking in and keeping it powered up and logged in? Or, are you letting it run the battery down?

Does the power cycle reboot the hub? Or, is it just the transition from power to battery and back that does the trick? The reason I ask is that if you have it connected by Ethernet and you also have the WiFi network configured, when you unplug the Ethernet it is supposed to go to WiFi. I am curious if the power to battery action triggers some sort of IP refresh w\ the router.

Just trying to understand why it works to try to pinpoint a cause. Since it isn’t happening with all units on that FW, it is really hard to lock it down to bad firmware.

I am not sure if the battery backup with wyze sense hub has died down, I do keep getting the alert for low battery

Yes, power cycle reboots the hub. I have the Wyze hub on a smart plug, connected to a UPS. Power cycle every day in the morning and late afternoon to be sure this is working at night :grin: