HMS Sense Hub Offline - how to reset the connection?

Just recently installed HMS. Within a few days the sense hub went offline. When I click the device on the Wyze app, it says “check Internet connection”. All I can do is click on report an issue which takes me to submit a log to support. Is there a way to re-setup the device. I tried to hold the reset button for 10 seconds and it says, “please follow instruction on your Wyze app” but the app still shows the device offline and there is nothing to help me troubleshoot the connection. Anyone has this issue before?

Just to add that all my other Wyze devices are all on-line and only HMS Wyze hub sense and all the censors (motion and doors) offline.

Haven’t received mine yet…have you tried a complete power cycle of the hub? Probably requires battery removal and unplugging it.

This is to help you during setup. This informs users to follow the Wyze app prompts to setup the base.
Now that you have pressed the setup button, the hub is factory reset, you’ll need to delete it from the app and set it up again. You may also need to re-link the sensors.


RESOLVED!! Thank you for the tip. It works. I have to delete it from the app and went thru the setup all over again.


What kind of a solution is it that when you lose network connection for whatever reason you must delete and rediscover all devices. Come on Wyze you can do better.

I was told by support that they have troubles with the Ethernet connection and they had me to delete / reset and start from scratch with a WiFi configuration.

When I asked about how to reset there was no such option. You cannot power cycle the device as you cannot disconnect the backup battery.

I expected a method to power cycle / boot the system.

I am monitoring a remote property so I am counting on reliability and the ability to resolve issues remotely… Glad I was on the original install.

The install went smoothly connected via Ethernet, discovered all devices, and completed all monitoring setup. BUT when I placed the system in test mode it immediately went offline. I wonder if there is an abandoned account stranded on the monitoring platform, but as I recall from the panic button design they do everything real time at the time of an event.

The reinstall over WiFi was fast and smooth as expected and things are good so far since.

But I knock off points for no method to boot system and would really like the ability to do that remotely.


Brlepage, I initially set up my home monitoring system by first connecting my hub via ethernet cable. Once I got everything up and running, with all sensors attached, I needed to move my hub to a location more central to all entry points, not near my router. I unhooked and moved, plugged back in, and then found that the hub was now showing “off-line”. I could find no way to even try to find or connect to wifi, not in my app on my phone or online. I had to move my hub back to the router, which defeats the purpose of the siren. What do I need to do to get it connected via wifi so that I can move it to the correct location?

Unfortunately, at this time there is no way to switch from Ethernet to WiFi once setup. You’ll need to reset your hub and start over connecting to WiFi during setup.

Just finished setting up my Wyze monitoring system, and in the end, it required me to update the firmware. As I initiated the update, it times out after a while and the whole system goes offline. Called customer service and the poor guy had no clue. Went through the whole reset. Same result. Need Help ASAP, please. Thank you

Can’t you just go through the setup and skip the firmware update for now? Wired or wireless? I’d try wired just for a better connection.

It does not allow you to go forward without the update. Once I connected the hub only through wifi, it was able to update firmware and works perfectly fine. Thank you for responding.

It seems that almost anything can make the Wyze Sense Hub go offline. And once it is offline, the only way to fix it seems to be to hard reset it.

Wyze Support calls this a “power cycle”, but they are lying. It is not a power cycle. They tell you to hold the reset button for 10 seconds to “power cycle” the hub, But that is not how you power cycle the hub. The hub cannot be power cycled. Holding the reset button for 10 seconds does a hard reset, which means you must re-add the hub to your account and re-synchronize all of the sensors. If some of the sensors are hard to reach, this is extremely frustrating.


Unplug the power to the hub and then hold the reset button. That actually shuts it down. Reapply power and it should boot.

1 Like

Hold the reset button down for how long?

My Sense Hub is running on battery right now, and I held the Reset button for about 7 seconds. I will not hold it for 10 seconds, since that will Hard Reset the device.

You have to hold it longer than that. If you don’t need to do it now…don’t. However, if you have a problem again, disconnect the power and hold the button until it shuts off. I have done this a few times and as long as the power is disconnected it didn’t reset the hub.

1 Like

Is this a hidden feature? Because I have not seen this documented anywhere. Great info though!

It’s mentioned in this article:

  1. Press and hold the Reset button on the back of the hub for 10 seconds. This will power cycle the hub.

That article is not correct. If you follow it, you just reset the hub. If you unplug it from power first and hold it you will actually turn it off, but only if you disconnect the power.

My power “hiccuped”, which caused my hub to go offline #headscratcher

I unplugged the hub, then held down littl’ button for approx 10 secs. The hub unit acknowledged my effort.

It didn’t completely start wyrkin’ until after I reconnected power to the hub.

I’d like to thank all the little posters who helped me resolve my issue within 10 mins. I’ll have my people call yer person #hehe

1 Like

I have the same issue. They tell me not to reset the unit and wait for an firmware update that will fix this issue. The thing is this was 2 weeks ago. I paid for a year of service and I cannot even use it as it’s offline and not connected. I have a feeling it will be even longer as Everytime I talk with support they cannot give me an estimate on how long it will take. The Wyze warriors or ninjas are unable to see the logs you send but instead have to wait for a software technician to see them and report back to them. I am a little frustrated with this product right now. I love all my other wyze products but this one right now has been a flop. They said it would be addressed in the next software update but the last software update did nothing to fix the issue. Should I just reset the unit and set it up again? How long will it last?