Rules (schedules) Not Saving On Wyze Plugs

This is some general feedback in addition to an issue.

First, I just got six new plugs. I grouped three of them and created a schedule immediately with no issue. Problem was the schedule didn’t ‘end’ at the specified time and I had to manually turn off the plugs. Today, I attempted to edit the schedule that I have active on the weekends, to set a temporary ‘end’ time to see if it would work. It did. I then attempted to change the schedule back to what I wanted and it will no longer save. In fact, I cannot save any schedules at this point. As a troubleshooting step, I deleted all the schedules I had an am unable to add new ones. It goes through the process, when I hit save, it just reverts back to the ‘Create Rule’ screen.

I have completely uninstalled the app (first I deleted the storage and cleared the cache) and am still not able to create new schedules. Very frustrating for a brand new product. Why can I not create schedules any more?? I am unable to apply them to the group I created or to any of the individual plugs themselves.

The verbiage used in the app is poor. The schedule I am creating is to ‘turn on’ the plug at a certain time. I pick a start and end time, but it’s not clear in the app that the end time will turn the plug back off. I realize this is common sense, but I was second guessing what ‘end time’ means when the schedule did not work last night.

Also when you are editing a rule, please add a button that says ‘Save Changes’ rather than just leaving the huge ‘Delete’ button at the bottom. It is standard usability to have a dynamic button appear if a change is made. Right now, I hit the little back arrow and hope what I changed is saved.

I think you can improve the wording/usability in the app Wyze.


  1. Why can I no longer save any schedules for my plugs? Any assistance would be greatly appreciated.

  2. Where are the schedules saved? Are they uploaded to the plug or somehow reliant on the app. I would assume they are uploaded to the plug otherwise other users could potentially overwrite schedules on each other.

1 Like

UPDATE: This is a BUG!!

I’ve discovered that you can NOT set a start/end rule under certain conditions. I could set a start/end for my plugs if I started it at 6am and ended it at 8am. But if I try to pick a start time of 3pm and end it at 10pm, it will NOT save. Easy recreate steps below - wyze support please verify this and file a bug.

  1. Click through to add a new rule
  2. Choose ‘schedule’ for a plug
  3. Set the ‘start time’ for 3pm
  4. Set the ‘end time’ for 10pm
  5. Try to save it (it will NOT allow the save and will simply go back to the rule type screen)

Interesting. I just tried to reproduce this on iOS, but it works correctly for me. I wonder if another Android user can confirm that they’re seeing this too?

I agree. As someone who writes code, I think it’s confusing and it opens up a lot of potential questions about what happens in certain scenarios. If a plug is supposed to be ON from 12:00-3:00, for example, is the server continuously checking to ensure that it’s on? Taken literally, the computer code part of my brain would suggest yes, but I’m not sure if that’s what happens in practice, nor would that be very useful. What’s happening (I think) is simply that two events are firing – one at the beginning and one at the end.

I haven’t tested every potential scenario, but for my rules, I’ve set them up as two simple on/off rules, rather than one rule with durations, since the behavior is more predictable and the logic makes more sense.

There was a discussion about this issue the other day over here:


Thanks for checking. To confirm what I am doing.

  1. Open App
  2. Click ‘Edit Rules’
  3. Hit + button on upper-right
  4. Click ‘Schedule’
  5. Pick a plug, any plug
  6. Choose ‘Turns On’ → Next
  7. Set a ‘Start Time’ of 7am
  8. Set an ‘End Time’ of 10pm
  9. Give it a ‘name’
  10. Hit ‘Save’

At this point, what happens for me is it will just go back to the ‘Create Rule’ screen where I can choose ‘Shortcut’, ‘Schedule’, or ‘Device Trigger’. If I don’t set an ‘End Time’ works fine.

I am running Wyze v2.6.42 (I have already uninstalled/reinstalled/cleared storage/cleared cache).

I am using a Google Pixel 4, running Android 10 (build QD1A.190721.007.A3)


Yes. I just did all of that again and it works as expected for me. It goes back to the same screen that you described, but my new schedule is listed in the Schedule section.

The first time I did it, I didn’t bother adding a name, so I tried that variation this time, but that didn’t make a difference. Out of curiosity, does your rule name have anything non-alphanumeric in it? I didn’t try that, but if a developer forgot to escape something properly in code, I could envision a scenario in which something like a single-quote/apostrophe character might cause a failure.

I’m just naming it ‘test’ for the exact reason you mentioned (trying to keep the testing as basic as possible). I’ll see if there’s a way to record my screen easily and post a link.

Including a link to a video here.

Note that the rule ‘test’ does not get saved. Also another issue is if I go to create a rule again right away, you’ll see it doesn’t show any devices that support automation. I can work around it by going back to the main screen, but another bug.

Another thing to Note is when it goes back to the ‘Create Rule’ screen, I have to hit cancel to get back to the rules screen. That is not picked up in the video as there is no feedback to hitting cancel in the app.

I came here to report this exact bug. I have Android, and when trying to add an end time to the schedule for a plug, the app kind of crashes (not completely, but that screen does).

And I agree. The wording is almost a bit confusing, and I wish there was a save button.

1 Like

I believe you. I’m just hoping we can get another Android user to test it to try to narrow down the cause. For example, is it something specific to your device/account/network/whatever, or is it pervasive in the Android version of the app? Sometimes it’s hard to pinpoint.

Have you tried the hail-mary approach of trying to clean-slate it? Delete the app completely, restart the device, reinstall it from the app store, etc? Sometimes that kind of thing fixes problems that don’t have a super obvious cause.

Ah. Good. You tested it too? Sounds like a pervasive Android problem maybe. That’s good, it should make it easier for them to address it. (Well, it’s not “good,” but you know what I mean. Haha.)

1 Like

I did the following:

  1. Force stop app
  2. Delete cache
  3. Delete storage
  4. Uninstall app
  5. Reboot phone
  6. Reinstall app

This also happens on my wife’s samsung galaxy s9 and will happen on my wife or via 4g LTE. Another user just posted the same issue, which hopefully will validate the issue to support.

Thank you for all the replies/suggestions!

1 Like

I came here to report it, but checked to see if anyone else has this problem.

I created a schedule for the plug without an end time and it worked, and then only adding an end time, it caused the crash.

Good, that sounds like more than I would have done. Haha. This should definitely be reported. I’ll tag @WyzeGwendolyn here so that she can direct it to the proper team internally.

In the meantime, you might be able to get the functionality you need by making two rules without an end time. One rule that turns it on and one that turns it off. That seems like a cleaner way to do it anyway, (Unless they change the verbiage) but that’s just my opinion.

1 Like

Also crashing for the bulb.

Someone reported a similar problem the other day, and now I’m wondering if the two are related. That one never did get resolved, as far as I know.

The schedules are saved the same way as everything else in the app, which is in the cloud. The Wyze server tells the plug via your internet to turn on or off, based on schedules, button in app, etc. If you login to your Wyze account on a different device, everything will be the same as your other device.

If another user creates a schedule, I think it will only show up for them. The plug will attempt to execute the schedule for each user, depending on their configuration, which probably will lead to weird behavior. That’s my assumption anyway.

I’m still having this problem. To get around this lack of functionality in the meantime, I’ve made an applet on IFTTT. Doesn’t work as well as the Wyze app but at least it works. I’m guessing there’s bound to be more people with this problem after Black Friday.

1 Like

I tested this, I see the same bug on Android app version 2.6.42. I have a Samsung Note8 phone.

If you make a new rule, do you see the same problems as this thread? Your rule broke earlier, and I’m wondering if this problem might have caused it to break.