Wyze bulb on/off rules don't fire when scheduled

Any idea why my rules sometimes fire and sometimes don’t? Manually turning the bulbs on and off using the Android and iOS apps works fine so my connectivity is good to the bulbs. Really don’t get why this keeps randomly failing, because it DOES work most of the time.

My rules are configured to turn lights off in the morning and turn them back on (or “end”) at night. Is anyone *else seeing this? It’s kind of driving me crazy.


I’m having same issue. I’m ready to return these blankety plugs. They’re not smart at all. I set up the schedules so many times and still won’t turn my lamps on and off. Ughhh


I read this post after having to manually turn on and off 10 bulbs and 8 plugs today. Let me say I like Wyze and the products I own. However, the Rules/Schedules function for both Plugs and Bulbs are inconsistent and I can’t rely on the product to perform as set up. In the last month I have deleted and recreated the rules multiple times/reset the devices with no success. The Scheduler worked fine before they were turned into “Rules” . I don’t know what is causing this and suspect its in the app programming. My hardware is all connected and works fine when a manual command is sent. All the products have the latest firmware updates.

I moved over from TP-Link/Kasa to consolidate on Wyze products. If they cannot fix this issue I’ll have to move back. The Kasa Scheduler function never had an issue and I could trust it to work.


I also didn’t have issues until schedules got replaced with rules. I thought if I just deleted my old scheduled tasks and created new rules then things would be all compatible and groovy. Got a solid day or two out of the rules before I started seeing problems.

It’s irritating to watch the clock while staring at something that’s supposed to turn on or off at a specific time and watch that scheduled time come and go while your "smart"device just sits there sucking electricity without changing to the appropriate state. I have a request in with Wyze support to look into this but guessing I won’t hear back before Monday.


I have 2 Wyze plugs still in the box from my early adopter order. If the bulbs I already have in service won’t obey the rules I’ve configured, I don’t see much point in even attempting to use the plugs. Really hope this gets fixed soon because I’ve seen a lot of app and firmware updates but nothing to address this issue.


@LAWoman and all,

Sorry to hear you’re having trouble with schedules not executing properly. I don’t believe this is a widespread problem as we have not seen very many reports of this in the forum. I realize that doesn’t make it any less frustrating for you though.

There may be a common thread here that support could track down. Have you all submitted Support Requests? If so, please post your ticket number here as well as the version of the app and firmware that you are running.

I’m not a Wyze employee, but I will ask a Wyze manager to look at this discussion tomorrow.


My ticket number is 351633. I just updated the app to v2.5.36. Bulbs are all running firmware v1.2.0.146.


I am having issues as well with my rules, i have a rule to turn on my bulbs at 7 pm and later turn them off at 11:59 pm. What ends up happening is that the rule is getting executed also at 7 am :S . Like somebody programmed a check assuming 24 hours format in the server but the app uses am/pm

1 Like

@daygonative How long has it been since you submitted the support request?

I set up a similar rule to turn on a bulb at 4 pm and off at 11:59 pm. This is still due to the scheduler not being able to handle past midnight conditions. It light turned on at the proper tine, but didn’t turn off. I had put the end time in the same rule as the start time. That works for a couple of other rules I have. In this case it didn’t. So I removed the rule end time and created a second schedule to just turn off the light at midnight.

Another method would be to create an “inverse” rule. That is where you turn OFF a light or plug at 1 am, for example, and end the “off” time at 7 pm. I am doing that type of schedule for my porch light and a plug that lights a couple of sculptures. They seem to work perfectly for me.

I use 7 schedule rules and 18 trigger rules. They have been working for me through all of the recent updates and changes over to the new “rules format”. I do not mean to imply the current implementation is perfect. As a former programmer, I know there is always room for improvement. But, as @Loki mentioned, your best approach is to open a service ticket and work with the tech staff to resolve your issue.

If you want help from this forum too, please post screen shots of your rules. Those are helpful to those of us who like pictures. Reading is hard. :grinning:


it seems that that works with plugs , I put the end time in the same rule as the start time and it worked .
Tried it with a bulb and it won’t work

1 Like

@HDRock, it is working for turning off and on my porch light. The rule set the bulb to off at 6:30 am and ends the off condition (thereby turning the light on) at 6:30 pm.

(Now that I’ve said that out loud, it’s going to fail.)

See the screen shot.


Oh, so ya set on off but no on :slightly_smiling_face:

Yeah, that’s the funny part. The “end” time is the end of the off time, so it flips the condition to “on”.

It is kind of kludge, but it works. :wink:


I think I will hold off on buying bulbs for now, but I do enjoy your logic.

Hi everyone,

I’m sorry to hear about the trouble some of you having been having with Rules. For the kludges that people have been using, I can say that we are working on improvements that will help with the process.

For those with schedules not firing successfully, could you please contact the support team through this link?

Support Request Form

We would like to look into this further and get everyone up and running. @daygonative, I’ll check on your ticket and get eyes on it if you haven’t received a response yet.

@LAWoman, we apologize further for the loss of your weekend.


Thanks for the advise! , i will try it today. Anyway more than having a solution right away i commented on this thread to make it visible to the Wyze team. I appreciate continuous improvement rather than 1 update every 6 months or so like other platforms, even if these are not perfect.

1 Like

Sorry for the delay - was a bit preoccupied yesterday!

I submitted the request Saturday night (10/12) and got a response yesterday morning (10/14). Just sent them a few screenshots upon their request this AM.

Haven’t had any issues with the rules since Saturday night but it’s a sporadic problem so I wouldn’t be surprised if it didn’t happen again until this weekend. Here are screenshots of the rules that failed to fire Saturday night.

I checked the rule history and instead of 4 events there were only 2. There should have been 2 for the morning and 2 for the evening.

1 Like

I’ve had this exact problem with my Smart Life Plugs. Delete the scheduled times so there’s no schedule and it still behaves as if there is still one. So this is a problem across brands

1 Like

I’ve had this problem intermittently as well. The schedules seem to not be as good as the rules. Hopefully the improvements you’re working on get rid of the kinks.

1 Like