Bulb Schedules Fail Saturdays

I have 3 bulbs that are scheduled to turn on and off every day of the week in the evening. For the past 4 Saturday’s the bulbs have failed to turn on or off. The rule history shows that they are not receiving the commands. I’ve checked the scheduled rules and they are set for ‘Every Day’. While I have had numerous issues with having bulbs turn on and off as scheduled this is somewhat unique in that it appears to be regular. Anyone else have regular issues on a particular day?

1 Like

There is a related thread here:

Wyze Plug does not follow scheduled rule on Saturday only


I am going to see if I can draw a little more attention to this issue. It is a known issue and I haven’t found an answer for it yet. Hopefully Wyze will look into this and resolve it. I am still experiencing the same issue with mine. Rules/Schedules work perfect Sunday through Friday but fail to work on Saturday.

1 Like

Well the schedule is still failing on Saturdays, I thought it might actually work since they all turned on on time this week but then they failed to turn off. They are also somewhat randomly failing to turn on or off on other days which means I pretty much have to check every day if they work.

I have a number of smart plugs that are not Wyze and they work without fail and have done so for a long time. Not sure why Wyze cannot get their act together on this. They should very easily be able to figure out the extent of the problem and its solution.

Try deleting & re-adding the rule. I had a recent server problem that affected my scheduled rules that was fixed by doing that (the rules were executing an hour early). Actually, I only had to change the time & change it back, but I’m not sure that will work for a day of week issue. If you have a lot of scheduled rules, then just delete & recreate a few, making note of which ones you changed. Let us know if that helped or not.

All my rules, including bulb rules, are executing normally. I haven’t ever had a Saturday failure as far as I know, but I have checked my rules log back to at least Nov 2nd.

I’ve tried this in various combinations doing the bulbs individually and in groups, separate rules for start and end etc. Others have reported the Saturday problem.

My guess is that the Wyze back end is doing maintenance or something and the commands just don’t go out. Based on my rule history the bulbs are just not getting the commands, I never have problems with the bulbs when I ask Alexa or use my smartphone to turn them on or off so it doesn’t look like a connectivity or bulb issue.

When did you try this, because it has only been the past 2 weekends that I have seen recreating the rules work. If you did it before that I would give it another shot.

1 Like

It was more than 2 weeks ago. One more time then …

I won’t guarantee it will work, but it is worth a shot

Interesting! I had similar issues after daylight savings time with both of my cameras. I ended up “removing” the device on my app and restarting from scratch with them. I have had no issues at all with them since (and I have various schedules for the induvial bulbs that happen on different days). Might be worth trying to reboot them completely.

Believe me I’ve tried everything and have spent way too much time on this already but it was a while ago (schedule failures are a long standing problem with me). As it turns out, just the other day I changed my Wifi and effectively had to re-add the bulbs (kind of) so I may have done what you are suggesting. As I’ve said before I’ve never had problems with controlling them–even after schedule failures–with Alexa or the Wyze app so I suspect it’s the Wyze backend which sends out the scheduled commands.

Bummer! And I meant to say “bulbs” not “cameras” above. Resetting the wifi/power outages/unplugging didn’t do the trick for me. However, as soon as I clicked the red button labeled “Remove Device” and set it up again from scratch (took about 1 minute total), I was good to go. I recreated the schedules and everything has worked great the last month (this all happened around DST). Hope you get it figured out!