Issue with Sleep Routines for Wyze Bulb Color

My light bulbs are supposed to turn on at 10;10pm every night, but they keep turning on closer to 10:30pm. Is anyone else having this issue? Thank you.

I think someone reported a bug where schedules run late when the time ends with a zero. Please try setting your turn-on time to 10:11. Would love to hear if it makes a difference.


Okay, thank you for the recommendation. I’ll try that, and let you know.


That appears to have resolved the issue. Thank you. What I don’t understand though, I didn’t change the time on two of the bulbs, but they still went off the same time as the times of the bulbs I changed. I’m so confused.


This has been an issue for a lot of us in the past. I had routines run on schedule for months and then it stopped working. Once I adjusted the time, everything started to work.

I beta test the newer apps and FW. I have been involved in the new Rules Engine and can let you know that this issue has been resolved. At least it is functioning as expected. :slight_smile:

Hopefully the new Rules Engine will be released soon. They are gradually releasing it to testers to ensure they resolve any issues first. Then will release it as a production release then. I am not sure of the dates.

I am not an employee of Wyze, just signed up to be a beta tester. :slight_smile:

Glad you have it working.

@Seapup is always spot on with these support items. you were in good hands. :wink:


Well, that’s good to hear that they plan on releasing a new rules engine. I’m just trying to be patient, because I know bugs are to be expected. It can be frustrating though. Especially when I depend on the bulbs as a means of waking up for work. Yes, @Seapup saved me from the headache of figuring it out on my own. I appreciate your reply, informing me of this matter.


Are you also having a problem with getting different bulbs to turn on at different times per schedule? It sounds like you have one rule/schedule triggering multiple bulbs.

No, all the bulbs are set to go off at the same time individually via the “sleep routines” feature. But, they were all going off 20 minutes late, until I changed the time from 10:10pm to 10:09pm. Now everything works. The weird thing is, I forgot to change the time on two of the bulbs, but they all of the sudden started going off at the correct time. Maybe the Wyze team just fixed the bug, and it was just a coincidence.

1 Like