Sleep routines

Hi.
Having trouble getting sleep routine for Wyze color bulb and BR30 bulb. Selecting a start time does not seem to turn the bulb on at the selected time. Is this meant to be used (bedtime setting) when the bulbs are already powered on prior to this routine?
What I’ve done so far: cleared the app cache in Pixel 7. Re-paired the bulbs and re-set the router. Removed Wyze from Google Home Assistant so that only the Wyze app controls the bulbs.

Thoughts?
Thanks

I’ve been aware of this feature but had never played with it before now, because I use automations in Google Home to do this in the morning, but for grins I just set up a “Wake Up” Sleep Routine, and it seems to be running as expected. I enabled it for a group (where I have three Bulb Colors installed in a ceiling fixture), and the lights came on dimly at the appointed time and brightened in increments for several minutes.

I then set a “Bedtime” routine. With the lights on at 100% when the routine started, I could see over time (in the app, on the main screen for my 3-bulb group) that the lights began to dim in 5% increments over time.

I then changed the “Bedtime” routine start time and tested again to see what would happen with the lights off at the appointed time. At the time the routine should’ve started, nothing seemed to happen. I believe this is the experience you described.

That’s the conclusion I would reach based on my limited testing.

Here’s what I did (what I think maybe is the effect you’re trying to achieve):

  1. Create a Rule of Schedule type to begin at the time you want your “Bedtime” Sleep Routine to run. This Rule should turn on the appropriate Bulbs and set their brightness to 100% (or whatever you want).[1]
  2. Set up your “Bedtime” Sleep Routine to begin 1 minute later (because I think the Wyze app allows those kinds of adjustments in 1-minute increments only).

I understand why you’d do the other stuff in your troubleshooting, and I think it’s reasonable, but I wouldn’t expect it to have any effect on this issue. I think this is just the way Sleep Routines in the Wyze app are designed to work. Having said that, I think you’d be safe re-linking Wyze back to Google Home. My Wyze account (and Bulbs) remained connected to Google Home throughout these tests.

I hope this helps. Let me know if more detailed instructions and/or screen shots would be of any benefit.

:pencil2: Edit: Incidentally, I just found this in a Support article, and I think it provides the answer to your first question:

Tap the toggle next to Bedtime.

  • Duration is how long it takes the bulb to dim from its current state to 0% brightness.

The highlight is mine. This is essentially saying that if the bulb is off or at 0% brightness when the routine starts, then it’s already at the end state for the Bedtime routine.


  1. In my tests I began with my Bulbs only at 0% (off) or 100% brightness; I haven’t yet tested to see how the routines work when the Bulbs begin the routine at a different brightness percentage. ↩︎

Thank you for your amazing and detailed approach to solving this. I’ll need some time to test various aspects of the “Sleep Routine”. Thanks so much!

You’re welcome and thanks for giving me a problem to solve. I like situations that make me think through a problem, and this exposed me to a device/app feature I hadn’t ever used before.