Anyone else having trouble with schedules lately?

12.9.21 update:
When I removed the brightness and temperature setting from the schedules, the lights have worked perfectly. I’m guessing that when the color was trying to set just split seconds before the light turned on, it would mess up the schedule of the light turning on. Now that I separated the schedules (you could even separate them 1 minute apart), it has worked perfectly again. Has anyone else tried that?

Also, the plug schedules seem to be working now.

Anyone else having trouble with schedules lately? I have a lot of schedules and triggers set (mostly for my light bulbs and plugs). The schedules have been haywire over the last few weeks. I had the same schedules on my living room bulbs for over a year now and never had to mess with them. Lately, they have been coming on and off at random times and not following the schedules. They still work when I turn them on and off from the all, but the schedules aren’t. I have deleted the schedules and redone them. I even tried to delete one of my plugs and re-connect it and now it won’t reconnect. It just gets stuck after I choose the Wyzeplug wifi signal. I am wondering if a recent update messed them up and if anyone else is having issues?


Experiencing the same plug scheduling issue, after updating app to (9/1/21) 2.24.34 and updating the firmware on my plugs!!! Reset the schedule several times with no resulting correction! I’m considering returning the plugs.

1 Like

Yes… same here. I have events scheduled to turn on 2 bulbs at 7pm every night. This past week they have worked probably 20% of the time. One turns on, the other doesn’t or the opposite. Or like the last 2 nights none turn on.

AND the new bulb UI is horrible!


I have the same problem with both my original white bulb and the newer colored bulbs. The original loses the WiFi connection often and doesn’t restart itself back at last known condition. The newer bulb doesn’t respond to the “rule” set up on when to turn on. Funny, it does turn off at about the right time in the morning, but I have had to set an alarm on my phone to check and see if the thing turned itself on or if I have to do it remotely. I can’t do that with the original bulb because it’s at my other house in the desert 100 miles away. What’s going on? Things were working well for a while, then in the last few weeks it’s gotten fluky, and I have done ALL of the updates available for all of my WYZE equipment.

Have given up trying to set up a schedule for four different plugs. The outside plugs work, but the two inside plug schedules never work consistently, even with the app update. I’m thinking of getting ones from a different company.

Same here, my schedules for plugs are not working properly at all!
Very annoying, hope there is a fix ASAP !

I have always had problems with SCHEDULES, some days they work, some they don’t. I have deleted my bulbs and added them back; deleted the Rules and added them back. I am really frustrated. With the update which added the ability to tie to Sunset / Sunrise, I thought maybe SCHEDULES would work that isn’t the case. Last night one of my lights came on based on the set schedule but the other light didn’t. The light which came on automatically, did not turn off in the morning. The light which did not come on at the scheduled time, I turned it on with the Wyze app at bedtime; it did turn off itself in the morning.

After a chat with support, they had me re-pair the plug from scratch by resetting the plug, and then create a new rule with scheduling.
That day the plug turned off properly at night.
The next day the plug turned on and then off as it should have. I was very happy!
But today, sadly, the plug did not turn on this morning, and I had to activate it manually on the Wyze app.
I will re-pair it once again later on, but can’t keep doing this on a daily basis.
Support, developers, please follow up with this issue and let us know when it has been resolved and once an update will fix this as the scheduling is a key feature of these plugs.
Thanks! :grin:

Same problems here with multiple bulbs not working according to set schedule. For weeks now. Definitely a issue if all of us have the same concern recently, I’ve done a factory reset so many times now but nothing works. Also tried setting up schedule using only Alexa app but the same problems persist.

One of my lights worked on schedule yesterday but not the other one. Today neither worked on schedule. So very frustrating :exclamation:

Attention Wyze forum support: has this issue (schedules not working properly on plugs) been reported to your developers?
Are they working on a fix?
My plugs are totally unreliable when it comes to turning on or off via schedule configured by a rule.
Seems I need to use other plugs (from TP Link, which work properly to schedule on and off) for now but would prefer to have all my devices from same manufacturer to not need multiple apps for control.
Please fix the basic functionality of your plugs ASAP
New items are fine but only if the original ones are not neglected, as seems to the case with devices triggered by a scheduling rule.

1 Like

This is mainly a user only community. If you want official Support response, I’d suggest contacting them through the following means:

Support contact info.

Thanks for the prompt reply!

Could you not share this internally with developers?

I have contacted support and they had me re-pair the plug and create a new rule.
This did not help.

I then re-paired 3 times since, swapped my plug with 2 others that were unused, all with no success.

Seems there is an issue!

Moderator Note: Personal information has been manually removed from this post. Such information often gets included inadvertently in an email signature block when replying by email. The forum software attempts to automatically remove email signatures but it is not always successful. When replying to the forum by email, it is best to remove the signature block yourself before sending.

I am not a Wyze employee. I am a fellow user such as yourself. Mavens and Mods are both members of the user community.

I am curious on this, if you got to the rules history in the app, what does it show for the time the rule is supposed to trigger? Can you post a screenshot of your rule with all the actions included in this post please?

Also be cognizant of replying via email, as it sometimes appends your signature to your forum post. I don’t know if you wanted that personal information included in your reply. If you don’t edit the post I did flag it for the mods to remove your personal information.

My rules show that things executed perfectly. I guess if it says they were maybe it’s me that is f*"$(|d in the head. Beyond frustrated with this crap. The response from the company is always the same canned bull crap

Possible but lengthy solution. I’ve been watching the logs of the scheduled events and what I was seeing mostly, not always, was that things like bulb temp or brightness was going off before the actual light was turned on. In my opinion this is a software issue that needs to be addressed by prioritizing commands. I.e. on first, then brightness, then temperature or color. I’ve experimented with setting a schedule as follows

Original schedule:
Carport on 530pm, brightness 100%, temp 4500k
Carport change over 930pm brightness 1% temp 2700k
Carport off 7am.

New schedule
Carport on 529pm
Carport brightness 100% 530pm
Carport temp 4500k 531pm

Carport change turn on 929pm
Carport change brightness 1% 930pm
Carport change temp 2700k 931pm

Carport off 7am

This time consuming [Mod Edit] scheduling seems to work. Literally a different rule for every operation 1 minute apart so these [Mod Edit] bulbs don’t get confused and changing brightness before the bulb is even on… This light went from never being right to 2 days of perfect. I have added another bulb with this same scheduling to try it again. This bulb consistently didn’t even turn on at all so we’ll see. Fingers crossed.

MOD NOTE: Post edited to conform to the Community Guidelines.

Anyone have any luck getting schedules to work?
I gave up and put my Wyze plugs in my backup box until I hear that the scheduling feature is reliable again, as I have spent many hours struggling to get this basic feature to work properly.

1 Like

The only thing that is working (not perfectly) is to set up schedules in Alexa (if you use it) and remove from Wyze. I’m getting about 95% accuracy on the schedules I set for the 9 bulbs I have. Wyze should do better.

The ones I’ve reset with the above process have been perfect since I’ve done them.

The scheduling for my bulbs works fine, it is the scheduling with my smartplugs and outdoor plug that do not work.
Hope Wyze support can confirm they have an issue and address it!

Michel Lepeltier

1 Like