Scheduling plugs

Scheduling plugs is completely fubar on my Note 9 android app. I can schedule an “On” time for a plug, no issues. However, ANY schedule that includes an “Off” time barfs - whether a combined, or separate rule. I’ve force closed the app, no help.

1a - If I try to schedule both on and off time, no schedule will actually appear, after saved.
1b - If I schedule an on time and save it, then try to add an off time after, the chosen plug (or plug group) shows “Unknown device” (or Unknown group).
1c - When I try to schedule anything after these errors the app says I have no devices capable of scheduling.

2a - If I try to schedule only an off time, no days will show as selected after saved.
2b - Even if I try to select them after I’ve saved it, they won’t stay selected.

I wanted to schedule holiday lights but I can’t get any plugs to turn off on schedule.

I attempted this same schedule on my android tablet, and the exact same errors occur.

I submitted a support ticket #392950, with a log file.


This must be an interaction with a specific version of Android. With my Insignia tablet running Android 6 I think, I do not have any issues. With iOS I don’t have any issues so I am guessing whatever the issue is, it seems to be pretty specific. Be interesting to see what Wyze says.

I see there’s another post. Didn’t show when I searched.

Yep there is at least two of you😁

I am having same issue with my plug. Using updated app, updated, firmware and using a galaxy s10.

I have the same issue with my plug on the wyze app v2.6.42 on Android 10. I have a plug set to turn on at 10:30pm and turn off at midnight. I didn’t realize that none of the days are selected even though I selected them when creating the rule. I try to go back in and select the days but it won’t save when I exit it. Similar to situation 1a on Rick’s post.

1 Like

Well my tablet is now affected as well. I don’t know if I just did not notice it before.

1 Like

Running app v2.4.62 and I setup my plug and it seems to be working. It does save all the selected days after I exit the rules.


I just tried a different time setup and it failed to save the days I selected this time. It’s not working like it should. :face_with_raised_eyebrow:

1 Like

As long as I have it set on AM it works, but if I add a PM setup time it fails. This AM time setup below keeps all the days selected after I exit the rules.


You should be able to fix this for now by making two rules. One to turn it on, one to turn it off. From a code logic standpoint, this is easier to follow anyway. Using a duration for on/off functionality suggests that it will “Turn On” continuously for the entire period of time, which doesn’t make a lot of sense. I don’t think that’s what happens in practice, per se, but the way they implemented this logic bothers my code brain. Haha.

No. Read the OP. I’ve tried making two rules and it simply does not work.

Add to that, if any off time is set to PM it fails, as I note it the other post similar to this. If the time is set to 1159pm the rule immediately fails, but edit that rule to 1201am and it works.

1 Like

Yes, same here, on at least one plug. In my case I wanted a power at a plug to be available all day, bit not at night. (Small heater I wanted to make sure was off at night.). With a few tests, it seems to have worked and save correctly, if the on duration was 12 hrs or less … Otherwise same strange behavior ad OP. I got around the issue, (so far), by scheduling an off time for night (11:00pm to 5:15 am,). So far, so good. I suggested to support, that perhaps the 12 he am/pm clock logic is off, and maybe there should be a 24 hr/military time clock option in the app. She suggested I add as a suggestion in the forum.

1 Like

Wyze doesn’t seem to understand military time, which my phone is on always. Instead of adapting to the phone setting, the app “resets” my 2300hrs to 11:00pm.

My schedules were less than 12 hours… only 4 hour in fact (1830 to 2230), so it isn’t associated with a 12hr or less schedule, but when the end time is programmed for - any PM time.

Hmmm… Come to think of it… It may have worked up until 12:01pm…so that would match yours. Code wise, a 24 hr clock SHOULD be much simpler to program. When I suggested a 24 hr clock option, they said they always suggest that. Then I went back to the program, and didn’t find such an option, and didn’t want to mess with my phone config, as I had come up with a work around. When I replied back, they suggested adding the 24 hr clock option as a suggestion in the forum. So, guess THAT fix … Isn’t. :frowning:

The 12/24 hr option is already on the wishlist.

I found out that the days will save ONLY if you create a rule that’s pm to pm. I made a 11:20 pm to 11:21 pm schedule for a plug that saved properly and worked. I think it should work with any pm to pm time though.
Similar to what @StopICU33 was saying that his AM to AM rule worked.

@None you tried scheduling a 6:30 pm to 1030 pm and it didn’t work? I also got that weird unknown device error too when I went back to the rule and tried to modify it. I think you would need to create a brand new rule instead of modifying an old one. Also, I noticed it wouldn’t let me create any rule for scheduling devices on too for a temporary period of time. It said none of my devices were supported

I agree that this problem needs to be fixed!


Been there. Done that. Tried everything. No dice.

1 Like

FWIW - Wyze replied to my support ticket - told me to try logging out of the app, and back in. Over mobile data, that seems to have allowed me to edit existing plug rules so that I can have a 6:30pm to 10pm schedule. Also, allowed me to make new schedules without any issues.

Just need to verify that it works on the home wifi.

Shocking that this is all it took.



That worked for me too. Thanks for updating us. That was a surprisingly simple fix.