RTSP firmware - feedback so far

Just wanted to share my feedback on the firmware for rtsp.
I have motioneye and homeassistant setup to consume the rtsp feeds, 6 wyze v2s.
Motioneye is running on a rpi3. Homeassistant is running on a synology ds916+.

I have two stability issues were the rtsp feed becomes unavailable/drops after a certain time period.
The time period does not seem to have any repeatable pattern.

  1. It drops and this is reflected in the app with the rtsp setting being toggled back to off
  2. It drops, but the app still shows rtsp as enabled

For both instances regenerating the rtsp url seems to re-enable the stream correctly.
Other than that thanks for the push for this feature!
Can’t wait for it to be stable so we can further integrate into our home automation platforms.
Great work!


I have seem the same issue … with all four cams v2

1 Like

Tried on Motioneye and VLC… drops pretty consistently and image is 6 second lag

Hi there. Thank you for the feedback. We are working on a fix.

1 Like

@WyzeArthur, thanks for the update.

I operate my Blue Iris (BL) surveillance system on it’s own VLAN and the cams don’t have Internet access (only BL has access) . I lose connection to the Wyze Cam V2 after 10 to 60 minutes. I need to power off and back on once or twice, and sometimes need to access them with VLC to kick-start them before Blue Iris connects.

I assumed that the V2 cams are trying to reach Wyze servers and when they can’t, they go into an unknown state. However, I may be experiencing the same issue as the OP.

I checked the log, but it looks like it’s encrypted or compressed and not readable by notepad, etc.

FYI: Tried using my old android phone (4.x) but found out it’s too old, so I used noxplayer android emulator and was able to set them up initially and installed the beta firmware.

1 Like

I’m not an expert on RTSP, but I’ve read that many implementations of it on other products have a method of requesting/fetching still images out of the feed? Home Assistant and other software use this feature of RTSP, but it seems Wyze’s implementation of it doesn’t include the ability to fetch still images natively. People are coming up with crude methods of grabbing them like using ffmpeg and a script to grab a still and save it to a local folder, then point to that folder to use it. Or after adding to MotionEye, using a trimmed down version of a URL that points to a still. I don’t use MotionEye at the moment so that one isn’t available to me. Just wondered if this feature was planned or not difficult to enable. Thanks!

1 Like

Is this ability to fetch, something the client application would natively do if the data is made available by the camera source?

Second, if that method is used, is it supposed to yield a superior stream?

For Home Assistant, yes, the “still_image” variable is a required one for adding the camera to the GUI. And I imagine that other software just use stills by default to reduce the workload on the camera when a stream isn’t necessary.

With this enabled, no, it doesn’t result in a better stream because the request from a client is for a single still image - just less workload on the camera and less data on the network.

This isn’t a feature of RTSP because RTSP is nothing more than a streaming protocol. A lot of IP cameras provide a “snapshot” URL for this exact reason.

For the OP, I’m also seeing the same issue with the RTSP stream dropping until I manually regenerate the URL (even though the URL has not been changed).

1 Like

Sorry I replied to a different post. This Is the original but I will leave this here unless the mods deem it unrelevent

Sorry got disconnected

B: is there a specific place I can find the current firmware updates? I can’t seem to find the link to the latest firmware for the beta updates. Clicking on the “Update” link really isn’t good enough for me as I prefer to manually update so I know what I’m using.

and C: I’ve had a lot of repeated disconnects and drops. Sometimes it seems to drop the stream and still show a static image every 10 secs or so. other times I can get both the stream and an updated image to display. and then sometimes it’s dead on both sides.

I know a lot of this is software that is pulling from the camera but I’ve also tested with VLC and iSpy and can verify that the RTSP Signal drops after an indeterminant period of time regardless of bandwidth or remote client interaction on a dedicated WLAN and VLAN. This can be seen in wireshark. Let me know if I can assist in any way as am an IT Vet of 20+ years and have been working with Home Automation since X10

Tonight I tried again with Blue Iris and turned off “use RTSP/Stream timecode” and turned on "Use RTP/UDP ports, set the port to a unique value for each (i.e. 7100, 7200) and it seems stable now (see image below) for about 2 hours now. Do you have the ability in Ispy to turn on RTP/UDP and assign a unique port to each Wyze cam (i.e. 7100, 7200,…)?

Check out this link for released updates:

Also, according to WyzeArthur (see link), they are planning to take the RTSP version out of beta around May 8:

No i wish I had Blue Iris. Looked into getting it today though. Right now i’m trying to save up for a new PowerEdge server I can Proxmox or EXSi and migrate everything over. Originally I was going to try and keep everything down to a RPi and hardware for porting easily to other homes but i’ve obviously outgrown the basics for my own home. Once I do I plan on making a dedicated VM and loading Blue Iris for a complete DVR Facial Recognition system.

That’s great news about them taking it out of Beta though. I though they had decided not to include it in the final build because they wanted to reserve space for other features. The ability to tie these cameras into 3rd party sources is what truly makes them shine IMHO

Also, if i could figure out a way to use the “Send RTSP keep-alives” in any software other than Blue Iris that would probably help. Maybe the could add that feature into the app?


Go over to ipcamtalkDOTcom, Blue Iris on sale 49.99.

I think ESXi and Proxmox have GPU passthrough, which is good, as Blue Iris can take advantage using the GPU for processing. I have a dedicated system for BI right now, but with computers for Home Assistant, Plex, Emby, OpenSense, etc I need to consolidate everthing in the future.

So far I have the new RTSP enabled firmware on two WYZE V2 cams, which I am using with iSpy from my Windows 10 PC.

In the first week I ws running the new firmware I have observed a couple of occasions (every 2 or 3 days) where the RTSP feed from a particular camera hangs (i.e. the live stream image was frozen several hours earlier than the actual time) - even though the video feed through the Android WYZE app continued to work properly. When the RTSP stream became hung like this, the RTSP parameters as shown in the WYZE app were still set correctly, with RTSP enabled. These RTSP hangs occurred independently across my two cameras, with no relationship to each other.

Each camera is connected through a small and totally reliable wi-fi network, where they each report signal strengths over 90%. Also please note that I have each camera assigned a manual, static IP through the DHCP settings in my wi-fi router - so each time a camera is rebooted it gets the same IP address.

Restarting the iSpy software (which should force it to reconnect to the cameras) could not get the live RTSP streams working again, but after “restarting the device” from the WYZE app - the RTSP stream from each camera would again start working properly again. Currently I mitigate this issue by using the WYZE app to restart each camera every other day.

From how often these RTSP stream hangs seem to happen, I wonder if there could be a memory leak in the camera’s RTSP routines that just effects this feature?

Im running into the same problem and my setup is almost identical. I set the Cams up on an independant WiFi Network and WAP with a hidden SSID hardwired into my router. You can watch the traffic with Wireshark and see the RTSP stream drop. It for the most part seems to stay stable until under heavy use. If multiple people start trying to access the stream it seems to freeze the live stream but continues to give an updated still image. Although sometimes both do fail as well. Support says they are aware of the issue and will release an update to fix it.

Another quick way to fix the problem is to goto into the RTSP Settings and then click on the Regenerate URL Link. That will restart the RTSP stream without having to reboot the cameras. I prefer this method so I don’t have to reposition the PTZ after the reboot.

Thanks i’ll have to look into that. My employer sells old hardware they remove so im thinking of picking up a small Dell PowerEdge server and either Proxmox or ESXi it. Then im going to pretty much do the same thing your doing and build VMs for each segment I need. Although I truly am amazed at how much ive thrown at the RPi and its still rocking. But I can definitely see the lag especially compared to other peoples Home Assistant instances ive seen on videos and such. Not sure what I’ll do with the RPi after though. Sure I can come up with some use for it.

Thanks for the reply and this useful tip - it works for me too and is a little faster than restarting the software for the whole camera.

Is there a technical reason why RTSP was chosen over ONVIF protocol?
ONVIF would allow 2 way audio and PTZ control… just a question lingering in my mind.

And it would be really helpful with the RTSP and some novice users, if we could set the IP and ports for each camera with the app, not having to rely on dhcp reservation…
And, the camera “name” we set in the app, if it could also become the network device “hostname”, it would allow for easier identification with network software and utilities.

@WyzeArthur @WyzeFrederik

@WyzeArthur Same issue here with rtsp on one of my 3 cameras (camera is called "Dining Room Camera). Always stays connected in wyze app pretty reliably but drops out on blue Iris very consistently and have to use the regenerate button in the wyze app to get the stream back inblue Iris. Do I have a hardware issue on this with the wyze cam? Or is this a known issue with the firmware that may be corrected with the next release?