Initial RTSP testing feedback

Just started testing RTSP on my Wyze Cam Pan. So far it’s going great. No problems with flashing the firmware or setting up the RTSP.

Easily integrated into Synology Surveillance Station, Home Assistant, and Alexa. Also works great in SmartThings (using Generic IP Camera SmartApp). Only thing I am having trouble with is Actiontiles because it won’t do RTSP camera (only MJPEG).

WITH the RTSP integration, I am thrilled with my Wyze Cam purchase. In fact, I just bought a few more! Without the RTSP integration, they are still great cameras, but not of too much use for me as the cloud doesn’t easily integrate into all these things without using a work-around (Tinycam Pro tying up my tablet).

Just thought I would offer my initial impressions so far with my beta testing. I haven’t tested too many features yet, but so far so good!

1 Like

Thanks for the positive report re integration with Synology Surveillance Station. I look forward to connecting my Wyzecams to my DS218 as soon as the RTSP support is available.

1 Like

I too have just integrated with Synology Surveillance Station (first time using it), and so far so good. Just figuring the settings etc, but so far, so good. As others have reported, sometimes the feed is a little glitchy/jumpy, with some random, blank, grey frames in some recordings. Not sure if this is an RTSP or Surveillance Station thing? I suspect it might the latter, or my congested network??

1 Like

I have a little bit of random events, but it happens not just with Surveillance Station. I see it in Home Assistant and am seeing it elsewhere (Actiontiles, etc) – BUT it is not just with the Wyze cams. I have other camera brands as well and they are doing the same thing (caching, failing to load without a screen refresh, etc). It could be my network, or any number of things, but since it happens with more than just the Wyze cams, I am not ready to attribute the cause to them until I track it down.

I haven’t noticed too much of a problem with Surveillance Station, but do occasionally get gray frames when viewing using the RTSP feed via Home Assistant or an AppleTV app that views the cameras. Of course, I use those more than I do Surveillance Station so the issue might be present there too. Not an issue with my bandwidth however, so it is just a glitchy RTSP feed sometimes I guess.

Thx for the work on this.

Using HASSIO and picture entity card in UI-lovelace.

For the most part it works very well. However, streams will randomly become unavailable until such time as you go into app | advanced settings | RTSP and regenerate the URL. This fixes it (active again in UI) for a random period of time.


Yes I am having similar experience. They wouldn’t work at all when I updgraded Home Assistant to the newest version, so I had to downgrade. Still having intermittent drops though.


HASSIO VM (0.92.2) is working for me. Streams show up but drop intermittently due to RTSP going offline at the cam.

(Confirmed by testing with VLC when it drops from HASSIO. When you try to access the cam using RTSP via VLC you get an error that it is not available).

Experiencing this exact issue with both Wyze Cam v2 and Wyze Cam Pan. Cameras stay connected to network, continue to be accessible via the Wyze app however RTSP stream dies after a while, sometimes after a few minutes sometimes after many hours, neither seem to survive beyond a day. Going into the Wyze app on the phone, navigating into RTSP settings, clicking Regenerate (making no changes) causes the stream feed to immediately reconnect and start working again. Validated with multiple clients, Blue Iris is my primary but also confirmed same behavior with VLC player.

This has been reported on multiple beta threads and Wyze has already indicated that they are working on it…

1 Like

This is great news - I haven’t been able to integrate with synology successfully. Could you tell me your settings? I don’t know what source path and port to use. The web address the RTSP setting in the wyze cam app doesn’t seem to work in a browser either.


How did you add it to surveillance station? I don’t seem to succeed…


Here are the settings I used (below the italic words would be your specific parameters such as your unique password, username, ip address, etc)

Camera Name: (enter anything you want to call your camera)
Brand: [User Define]
Type: Streaming RTSP
Path: username:password@IP address:554/live

Hi, unless you have an RTSP plug-in on your browser, the RTSP:// address won’t work there. The source path and port I have used is: username:password@IPAddress:554/live

i tried with port 554 now, as you said, but Cameratest still failed.
Where did you get that port number? Could it be another? What else can I try? Can regenerate work?

I haven’t tried any other ports. 554 is the default port for RTSP. Have you tried the “generate camera URL” feature in the Wyze software? It is possible my RTSP firmware (which was the beta version) is using a different port than the newer official RTSP software they released. Interestingly enough, in HomeAssistant, I used the same URL, but left the :554 off and that seems to work in that program (without specifying any port).

yes, when the url is generated it gives an url without port. and that url fails in Surveillance station.

That’s a bummer. Sorry it doesn’t work for you. For me, it is working just fine. Maybe I got lucky with the right combination of firmware and surveillance station version, or something like that. I really don’t know what else to try to get it working for you. Good luck.

1 Like

Yea, this doesn’t work in Surveillance Station at all. In fact I have another camera where just like, this, it works fine in VLC but not in SS.

This has been an issue since about 2 years ago when whatever update Synology did to SS broke my other cams and it’s now creeped into this situation. Lame… ;(

You’re right! I had it working at one point, but due to some updates it stopped working ultimately. :frowning: