Real Time Streaming Protocol (RTSP)

When you say assigned a different port… Is this just within BI? I thought the RTSP feed was locked to 554? I do wonder if these cameras are somehow impacting themselves. Using the commonly discussed means to add these cameras to to BI, I see patterns where all my 4 V2 cameras drop at the same time with seems a bit coincidental. The drops got bad enough, I have just shut it all down until I get some answers as I was spending too much time trying to keep it all up and running.

true, but then doesnt it depend on what the purpose of the live video is?

if my purpose is to record motion events and have a reliable video that I can use to identify someone, then retransmission of errors that could otherwise result in visual artefacts might be preferable…?

if I want a live stream that is uninterrupted and always live, even if data is missing, then UDP would be better because it would never lag and just drop error packets.

i guess the question is, how much would a camera be able to lag on TCP before the software does some sort of correction / time synchronisation and just cuts a hole in the video?

and what could I tweak in my software to try and reduce the visual artefacts I am seeing while using UDP (since I would use that if it didnt look crap).

Once I got home yesterday I found that my computer was completely off as well and I never shut it completely down. I think i must have lost power briefly. I unplugged / re-plugged the wyze cams and they fired back up. I will keep an eye on this, but I think this is just a side effect of intermittent power blips.

Is there a log an user can pull when the RTSP disconnects requiring reboot? Was working fine for few days then no more. Reboot through App fixed it. When RTSP stops, app shows cameras just fine.

Had one V2 Cam + Older Firmware and another V2 Cam + Beta v2 firmware. Both went dead regardless of firmware.

Before I reboot to get RTSP going again, was wondering if there was log we can take a look or send to Wyze for investigation.

Thanks.

Series of stills, merged using ffmpeg - more granular control for me.

Yes, BI allows you to change the RDP/UDP port:

Thanks for the info. I am still seeing frequent drops, but this is trending in the right direction. I see some mentioning of issues on mesh networks and such, so that might be the culprit as well. Thanks again for the assist. I think we’re getting close to a stable feed…

I have been having very frequent drops until I disabled this setting on my Netgear Orbi router.

“Enable WMM (Wi-Fi multimedia) settings” << specifically for 2,4 GHz as that is what these cameras use.

I got here by researching various issues, but this article helped.
https://routerguide.net/airtime-fairness-on-or-off/

I still drop, but less frequent and the connection doesn’t drop all together. Still testing, but this is the first real headway I have made in weeks.

1 Like

@madtaurus would you mind sharing your configuration for iVideoN and tell us how the performance has been? I tried iVideoN on Linux but the stream seemed to freeze after about 20secs and doesn’t auto resume.

@blaze4fun what are your conclusions using Wyze RTSP with iSpy? Have you been successful and satisfied to this point?

@lxsharpxl How is this holding up for you and what NVR software are you using?

Configuration is pretty easy using iVideon. I simply just put in the RTSP URL as it is showing in the app, into the iVideon Server configuration.

Regarding performance, it is a bit of a mixed bag. I have had a few times where I’ve had to restart RTSP or restart the camera, in order to have iVideon be able to do any detection. During these times where it isn’t working, the wyze app is still giving notifications.

@madtaurus thanks for the feedback. What OS are you running iVideoN on? As mentioned, I’ve tried it in Linux and the feed won’t stay up for even a couple mins before freezing.

I’m on win10 pro. Running it on an i5-4670k non over clocked and 16gb ram. Os is on an SSD and the recordings are to a WD Green 4TB.

On the machine where you’re running zoneminder, if you use vlc to fetch the videostream directly, is vlc able to maintain the stream for a long time?

Its actually been very stalble and consistent but theres a few seconds of delay. Im currently using MotionEye, however i started with synologyNVR and it was great. I liked it better but was to expensive for alot of cameras.

@madtaurus Its worrying that you have had to restart things to keep it working. If your cams stop working and you are not around to restart and something bad happens, you might as well have never had the cams. I’m hoping we can get to a rock solid state and not have to worry about such things.

iVideoN is the easiest application I have ever installed on Linux. (This Russian outfit certainly offers a very polished solution). Wish every Linux app was this easy to install. Having said that, its disappointing that I can’t get a stable reliable RTSP feed from the Wyze cams to it.

If anyone has any suggestions of how to get Wyze cams to work smoothly with iVideoN Server on Linux, I will appreciate it.

I agree. I can’t pinpoint exactly what the trigger is for it failing, though I do use the Wyze app as a backup/verification tool. If iVideon does not notify me when the Wyze app notifies me, I know that I need to give the Wyze cam a restart for RTSP. That said, it does not happen often.

Running Linux with ZoneMinder in a Docker Container with the latest RTSP beta firmware (flashed the beta but sure it was network settings) with sold stream with slight artifacting with high motion. Check your WiFi AP MMS settings and Airtime Fairness. Turn OFF Airtime Fairness and try changing WMM (ON worked for me) to see if it changes your reliability.

Did you try the test I suggested a few days back, i.e. :