Real Time Streaming Protocol (RTSP)

Well then I guess your stuck with the released version as it is. :slight_smile:

Open source firmware may be a better solution. I haven’t tried it.

None of the open source stuff is good, unfortunately.

We are working on an update for RTSP to improve it from its current state. But I don’t have much information about that since I’m not very involved with feature development.

3 Likes

Just sharing some info on the Lag issue.

I received my 2nd wyze yesterday, installed the same RSTP firmware on the same SDcard as my first cam (did not re-download).
my 2nd camera has NO LAG, first one does.
the 2nd camera also has a crisper cleaner image.
the bit rate in the top of the image (and in BlueIris) show 130-170 kb/s for Camera 2

camera 1 has the lag, and a dirtier image
the bit rate in the top of the image (and in BlueIris) show 24-50 kb/s for Camera 1

wyze app camera settings > info > wifi signal 82% for BOTH CAMERAS
wyze app quality on HD (supposedly) for BOTH CAMERAS

BlueIris is also showing camera 1 max frame settings at 10 fps but struggles to do 8.5 frames incoming.
BlueIris shows camera 2 set for 10 and consistently receives 10 fps

hmmm…

mesh network. both cameras are close to access point. good signal.

When I use the Wyze app to change from HD to SD or 360P
NOTHING HAPPENS on camera 1 . No change to image quality…
I think this is broken, perhaps it does not change after flashing the RSTP firmware???

but works fine on camera 2… camera 2 is running perfect rstp.
confused.

I purchased 6 cameras and quickly realized that the issue here is 2.4ghz wifi. Our network becomes completely saturated (99% according to my AP) with MotionEye/Zoneminder watching every camera. Our only fix was to have our software only watch about 3 cameras total, then use the Wyze app for the rest. This seemed to alleviate the network issues. If these had USB ethernet support or 5ghz wifi chips there would be no issues.

2 Likes

Hi there. This is Arthur from Wyze.

Since its release, the RTSP firmware had been downloaded to more than 2000 devices. Thank you all for supporting this feature, and sincerely I am sorry for some ongoing issues that undermine its performance.

The current RTSP version is still the beta version. We received many valuable feedback, and we are working on fixes. The updated version is scheduled to release around May 8th.

Here is a list of what we know and what we are doing:

A. Connection drop:

  1. I received 16 reports on this issue, mostly with Blue Iris, iSpy and Motion Eye.
  2. Symptom: As the RTSP connection drops, Live View is still good, and the feed could be restored by turning off and on the RTSP toggle, or by rebooting the camera.
  3. I received error code 800274D from Blue Iris. Our engineer suspects it was caused by Router functions that limits local network data flow, such as Airtime Fairness, advanced setting for Netgear & Asus routers.
  4. We are currently testing a new version of firmware with all the mentioned players to see if we could prevent this issue.
  5. For some user, this issue was solved by:
    (1). Adding the cameras (e.g. to Motion Eye) as RTSP/UDP camera
    (2). Switch to RTSP over TCP
    (3). Blue Iris settings example: https://global.discourse-cdn.com/wyze/original/2X/d/da2686bb28abfe958c6d95f539185a69ac753ea8.png

B. Other devices in the same network drop offline when RTSP is on:

  1. I received 5 reports on this issue. It does not always happen, and resolved automatically in the next day.
  2. All users stated that their network should have more than enough bandwidth.
  3. Our engineers suspect it could be caused by:
    (1). Conflicting IP address or other router related settings
    (2). Overall network usage is too high.
  4. We are trying to reproduce this issue, but not yet achieved. If you are in similar situation, please send me the camera Mac address and the type of router you are using to hzuo@wyze.com. Thank you.
  5. For some user, this issue was solved by:
    (1). Assign static IP or reserve DHCP for the camera to avoid possible conflicts.
    (2). Change video resolution to SD or 360P

C. Frame Skip

  1. This issue refers to “stuttering” video that jumps every few seconds. This issue happens mostly to iSpy and PotPlayer, and in one case Omxplayer on Raspberry Pi.
  2. It happens when the player did not complete playing the 2 seconds of each video clip, before the new clip (i-frame) came in and refreshed the video, skipping several not-yet-played frames.
  3. Suspected causes:
    (1). video player software limiting frame rate to lower than 15fps to preserve CPU usage, but this does not always produce the “stuttering” effect.
    (2). Player or device issue causes decoding and playing to be slower than necessary.
    (3). Connection not stable, bit rate fluctuated to lower than necessary level periodically.
  4. We are testing some changes to improve this issue.
  5. For some user, this issue was solved by:
    (1). Switching to other players (e.g. VLC)
    (2). Increase buffer size / video caching time.
    (3). Change video resolution to SD or 360P

D. Delay, comparing to Wyze App Live View

  1. I received many reports on this, but only less than 10 users reported longer than 5 second delay.
  2. According to our engineer, the implementation of RTSP data transmission would require it to buffer 2~3 video clips (2 second each) before sending one out. That is 4~6 seconds in buffering. Comparing to Wyze App Live View feed that sends out every frame and buffers less than 2s, RTSP would be 2~5 seconds behind.
  3. Currently we do not know how to reduce it beyond 2~5 seconds. We are collecting reports on longer than 5 seconds delays, and we should be able to fix that part.
  4. For some user, longer than 5 second delays was solved by:
    (1). Changing video quality to SD or 360P, and reducing player caching time.

Thank you for reading through this. We are definitely working on improving the RTSP version of firmware, but it will take time, especially that the cause to some of the issues are unknown and we have not yet reproduced it in our office.

If you run into any of the above issues, or if you have experience solving any of them, please post it here.
If it involves personal or device information, please send it to hzuo@wyze.com.
Thank you.
Arthur.

14 Likes

Very happy to have RTSP available now! I put it on all 3 of my cameras. I was hoping still images would be enabled in a final release? Many users are resorting to crude methods like a script that uses ffmpeg to save a still to a local folder, or relying on MotionEye’s still images it produces.

1 Like

Thank you for the detailed explanation.
Why is it in “launched” status rather than still in under “testing”?

I do not currently care about the lag time because:

  • I am recording to an NVR
  • This is not a real time intrusion detection system
  • I have configured my system to be automated
  • There is no need for me to be notified of motion, but there is need for me to have good evidence of events

If the trade off is good video quality versus a few seconds in a buffer, I’ll take the good video quality.

Also, to @dusthead, using ffmpeg isn’t crude. It’s clever. :stuck_out_tongue: My software of choice, Netcam Studio, can automatically take images and generate timelapse, but I’m testing the capabilities right now.

1 Like

I’m almost certain I’m running into this same issue with 3 cameras. I already have a pretty well saturated 2.4 band with about 70 devices (echos, smart switches, lights, sensors, etc) connected at any given moment. Running motioneye with 2 wyze cameras (on 360p) and 1 IP cam was semi stable, but I noticed that Home Assistant wasn’t acting as snappy anymore and automation’s began failing sporadically. Asking alexa to turn on/off something would result in a 50/50 chance of getting “I’m sorry device name isn’t responding…”
My setup includes:

  • 3 Wyze V2 Camera’s
  • Home Assistant and motionEyeOS running in docker on an i3 Nuc with 8GB of RAM
  • Linksys WRT1900AC running DD-WRT v3.0-r39538 std (04/16/19)

I have a spare router that I’m thinking of dedicating to just the wyze cameras to see if that helps solve my issues. Thoughts?

I was considering getting another AP. It looks like our Unifi AC Pro AP’s can be meshed together. I believe I could add 2 more, and they could each cover the other wifi channels. I was thinking about getting another one and running everything on another channel, but still this channel could get saturated as well… hard to say.

I moved it to Launched because the RTSP firmware became available to the general public instead of being limited to beta.

1 Like

I have the delay, connection loss, and frame-skip issue. I’m using Blue Iris. unchecking “Skip initial HTTP DNS and reachability tests” in the Network IP configuration page of Blue Iris helped a bit, but not entirely.

were there any feature changes in RTSP when moving to GA or is it the same as it was in beta?

Is it possible to install the new RTSP firmware without using the app?

this would be great.

It was the same as the beta but we have an update expected in the next week. I don’t know if there will be any feature changes but we do plan to have function improvements. :slight_smile:

AlbanyHDTV, It varies depending on your router, but you have to go into the port forwarding section on your router settings. From there, you make the Wyze cameras static IP address so it never changes. Once you’ve done that, you forward the ports for each camera. The Wyze cameras use port 554 for RTSP. So for each cameras IP address you forward internal port 554 and make up an external port for each one such as 10554 11554, 12554, etc. For example say your first camera’s IP address is 192.168.1.110, on the router port forwarding section, you would forward external port 10554 and internal port 554. next camera would be external 11554 and internal 554, etc. Once all that is set up, you can use a camera viewing app to view the cameras using your home IP address instead of the internal 192.168.x.x address.

1 Like

Just installed the 2.3.60 iOS beta. Updated 2 of my 4 WyzeCam 2’s to the latest firmware 4.19.4.48. All works well, and I have RTSP streaming to my AppleTV & iPhone with no issues. I love it! However, the camera that I didn’t upgrade the firmware on now won’t authenticate (tries 10 times & times out). That camera is running firmware version 4.9.4.37, which is the current production version. I’ll go ahead & upgrade the firmware to match the others (a little harder to do since it’s outdoors & up high). Just thought the team might want to know.

https://www.reddit.com/r/ZoneMinder/comments/bif1y1/i_got_the_beta_version_of_wyze_wyze_software_not/[ZoneMinder RTSP]
so i found that on reddit, confirmed it does work, how well you ask well still testing… took me a bit to realize there was some config issue with storage in ZM but all seems happy with the stream and record now