Remotely revert to an earlier firmware version

We need the capability to remotely revert to an earlier firmware. By remotely I mean by doing a reboot over the net, no physical action pressing the reboot button.
Example - I upgrade the firmware on a system that was working fine hoping to take advantage of an advertised new feature, like flying unicorns (Happy! (TV Series 2017–2019) - IMDb).
Then we decide other changes in the system, like loss of motion detection make us want the previous version.
IF we had an sd card in there with the PREVIOUS binary it seems that we should be able to select to boot to that.

Agree … it would be a great feature … particularly for newbies who have to revert back to a prior firmware. Would save WYZE a lot of headaches if many new owners or beta testers need to revert back to prior firmware.


never mind, apparently this is available now under the beta app under upgrade–> have a problem—>revert firmware

I think it’s only available when there is an upgrade firmware available. If your fw is already on the latest update them it just says"your firmware is up to date!" and shows the app version. Then you can’t click on the have a problem button to get to the firmware versions to downgrade to. This is what I’ve seen on the non beta app.

I think the revert to earlier firmware should be an option when you have the latest firmware… Not just when you have an older firmware.

Actually they took it away.
According to WyzeTao:

Hi, we did it because the new beta firmware can’t be downgraded to or firmware or lower. We are going to release a new beta firmware which overwrites a few files from the old f/w. It is a ‘breaking’ change which is not reversible. If you downgrade, your camera will be at flashing blue state forever.

If you want to revert back to older firmware, please manual flash the firmware via .

BTW, our beta firmware (coming out soon) has a fix for timelapse download issue.

1 Like

Thanks I didn’t know that!

I have unplugged my cam pans until this glitch is fixed. When is the estimated time to release the new firmware?

Please create the ability to revert firmware for cameras through the app instead of the current process of downloading it to an SD card. The current process requires accessing and moving cameras which can be very undesirable. In my case some of my cameras require a ladder to access, and moving them to access the SD card means moving their position from one that required many attempts to get just right the first time and getting them back in that same position will require a lot of work. Also it messes with the detection zones that have been setup. If WYSE can push firmware through the app, then users should be able to as well. This is especially important for beta testers who may have to revert firmware when key features like notifications don’t work in beta firmware.

On the firmware update screen, show all the available supported firmware versions and allow the user to select which version to install. I hate climbing ladders and going through the manual process to roll back firmware when there are bugs or issues in the Wyze firmware. this should be an easy update to the app and we can roll back firmware from the app.

For as long as I remember, the beta version of the app allowed me to roll back my camera firmware but I’ve just noticed that this capability is missing from v2.22.12 of the app. Does anyone know why or is this just another bug?

" What will happen if I don’t update to 2.22?

The next time you update your Wyze Cam firmware, you will no longer be able to access your Wyze Cams in the Wyze app."

I get motion notifications but zero playback, and can’t view live feeds. Error code -68 on all cams. I’m going to reflash each cam because this firmware version was made to ignore communication if cam, app and phone aren’t current. (I can’t revert either)

Not a bug, a feature.
They took that away months ago with a (to me) flimsy excuse. So now I go to an akp mirror site. Download the APK I want and load it.

I’m running an Amazon Fire (Android 5+) which I loaded w/ app V2.19.4 and it sees my V3’s w FW just fine.
I can’t set rules with it but I don’t need to.
And what do you mean by:

You can load an older APK or grab older FW version and reflash.

  1. Download the Wyze app v2.18.15 beta apk from APKMirror and install it.
  2. Go to the settings of the camera whose firmware you want to revert.
  3. Tap Device Info > Firmware Version > Have problem? > Revert firmware

Tried it on my Fire - seemed to work with a V2 on FW V4.9.7.675 (gave me 2 options) but on a couple of V3’s w/ FW V4.36.3.19 it immediately crashed to the Wyze app home screen when I tapped on the firmware version.
Still a good tool for the toolbox, but selective.

Okay, Wyze app v2.18.15 beta offers me the option to revert the v2 cam firmware but not v3. I tried some earlier versions that support the v3 cameras but I can’t find any on APKMirror that offers the option to revert the v3 firmware. Maybe that functionality has been blocked in some other way. Does anyone know?

1 Like

Hello Friends, since the last updated of the firmware to version, my 4 wyze cam v3 gone on solid red, and on the app appears CAMERA IS OFFLINE, CODE ERROR 90, since that i’ve try power cycle, reset the setup camera and flash the firmware with a micro sd card to a any older version, but without luck, nothing happen on the cameras at all, the 4 cameras still keeps the solid red light in front, without accepting routines of RESET the camera, or power cycle, neither flash the firmware, i did everything i red on the Wyze Troubleshooting Support,…

I recently spoke with Amazon in order to return all the 4 cameras if someone of Wyze Support doesn’t help me…

Somebody by any chance, got resolve this issue ???