New Beta firmware for Pan and v2 launched on 6/29 (Paused)

After upgrade to just released for pans and V2:

  1. none of the Pan cams will now return to detection position. This has been a long standing problem which had finally resolved with recent upgrades and now is back.
  2. All cams are catching person sitings but still giving false alarms
  3. one V2, which was unplugged during batch upgrade, will not upgrade. Tried restart, power cycle and turn off /on to no avail.

Check individual camera
Device Settings–>Device info–>Firmware Upgrade->Have Problem

On my (which still says (“Your firmware is up to date”)) I’ve 3 Reversion options (YEAH!!).

1 Like

Just says I’m running the latest firmware. Stuck on .90

Have used the the option to revert to last version but Pan cam still won’t return to detection position. Looked to revert to 1 step earlier but only option was upgrade. Did that and three option revert is back!
Now reverting to 2nd oldest version.

Hey @WyzeRoy why are some people able to update and some of us stuck on .90 with no update options?



Betas been paused. Update next week.


OK, I successfully downgraded to… My Wyzecam Pan is back working again… No more Beta firmware for me.


1 Like

Same problem /question, except all of my cams upgraded but one. It’s stuck and won’t budge. All V2’s.

I feel lucky that when I first went to upgrade the software wouldn’t :slight_smile:


Here’s one for the books. Upgraded pan 4 cams. everything worked but return to motion detection.
Decided to revert one to working version. Went back thru all 3 options under the ‘have a problem’ with no success.
Wound up reflashing to the last version on the support page. It worked
Here’s the odd thing - now all 4 cams work, 3 under the latest and the one under the old version.

My Pan fw is It does not show that new fw is available. My V2’s fw is I am not seeing an fw update available for these either.

One of mine did the same thing. Another person posted that she just kept trying and eventually it took After about thirty tries I gave up
I tried power cycle, re -install, and eventually wound up having to do a factory reset followed by reflashing an older version of firmware, Then the cam itself upgraded to the new firmware.
All is well now. Hope you don’t have to go that far, but that is a road that worked.

Note to Wyze: firmware upgrades/downgrades definitely needs to change.

They should be easier and from within the app on both production and Beta.

Using the SD card for any firmware upgrade/downgrade should be a last resort, like when the cam is bricked. So, keep that.

Normal upgrades/downgrades should be available from within the production app, and normal upgrades/downgrades PLUS Beta upgrades/downgrades should be available from within the Beta app.


As they were before for a short time. That was great!

1 Like

and now only three work…one has ‘retired’. I am at a loss. Seems like they randomly work on the motion detection return from day -to -day.


As I wrote on April 25th

I think that would be a really nice feature to have. Ideally though, we shouldn’t need to constantly be reverting.
In terms of allocating what seem to already stretched -thin resources I would prefer to see more problem fixes.
So, I guess I fall squarely in the middle!

Since it’s there in the Beta I do not see how it would take much more resources.
I understand when they make a major change, as they did recently, that will not allow one to revert we would have to do the SD card dance

I gladly shout my agreement. While this should not be needed except in rare circumstances, more flexibility in upgrading and downgrading FW is needed.