[Beta]New Beta Firmware Released on 1/31

Hi all, hope you are having a great day! We released the latest firmware to the Beta testers. Here are the release notes. If you ran into some issues before. Much appreciate for helping us verify the latest fixes, especially, the Night Vision not working issue, and the unexpected reboot issue. Thank you so much.

V2 ( & Pan (

  • Fixed an issue that may show no video when downloading the time lapse.
  • Added some log to help look into the night vision not working issue.
  • Fixed an issue may cause alert clips to fast forward.
  • Fixed the camera unexpectedly reboot issue when in a poor network.

V1 (

  • Fixed the camera unexpected reboot issue when in a poor network.

Update doesn’t complete, says update failed and bricks cam V2 Installed Version

Same here, update failed and camera no longer connects to wifi. Rebooted 4 times. Camera makes clicking sounds, pans back and forth, waits, repeats cycle every few minutes. I had the last beta version installed from two weeks ago and the Android app was the latest version from around the same time, v2.1.17.

I deleted the device from the app, ran through the setup procedure again and it’s back now. I had to run through setup twice before it bound though. I’m not going to update the other cameras until tomorrow when I have more time to spend on recovery, it’s too late to mess with that this evening. The camera does show so it did make it through the firmware install, something to do with reconnecting to the wifi afterwards.

So I had reset the device and reconnected it sitting in my office near the wifi router. I think I saw an error 45 once or twice and then a reconnect success and a live video feed. Upon moving the cam back to it’s original location (about 25 feet away from the router) and it’s not connecting again and giving me the error 90. I cycled power, it did a yellow and blue flash, then a blue solid. I checked again and not on my network, no video feed. After a minute or so it cycled itself, yellow blinking light, and it panned around one full turn and then looked like it powered down, no lights. Did the firmware update do something to restrict the radio power? It is once again not connected to the wifi network and appears to be a paperweight. I’m going to bring it back to the office and power it up to see if it rejoins the network from in here.

Edit to add:
Moved the cam back to the office, it ran through one cycle of yellow light, blue light solid, I didn’t see it in the app though, error -90. It cycled again on it’s own, yellow, blue, then it was back on the network (from the same room the router is in, about 4 feet away) with a live video feed and motion tracking.

Upgraded 10 V2s and two Pans in a batch. One V2 and one Pan reported upgrade failed, but a second attempt worked on both. When I got my truck home, I was able to upgrade my V2 dashcam without incident.
I had never noticed any of the issues that were fixed, so not able to test much with it.

Have 4 camera, got failed upgrade on two. The two camera would not start but after about five minutes the cameras starting working and looked at camera detail and shows the upgrade actually took place. I did not power off/on or physically touch the camera. JUst operated via the app,

Upgrade failed on all 4 cameras and received following message after it tried to reconnect “Please try to power cycle the camera (error code -90)”.

2 came back up on their own, the other 2 I had to Turn off and back on again via the app…

My Pan updated with no problems.
My V2 had the problems others had. Failed update, Error code -90. Unplugged / replugged power twice before it was found by the app again.
Seems ok now. Firmware did update contrary to the message.

Also got “Upgrade Failed” with frowny face image (nice touch!). Connection was lost for about 3-5 minutes, then came back. Info shows it did indeed update to .28 version. So upgrade shows failed, but actually did work

Thank you all for reporting the issue of the firmware bulk upgrade. We are working on improving the mechanism and the accuracy of the upgrade results.

My cameras were updated individually not bulk.
One problem i just noticed. The Pan camera lost it’s saved pan positions.

My v2 via direct update failed as well. My 3x v1 cameras worked fine via bulk update.

I posted this issue in another thread and then found this one which I believe is the right place. I have three v2 black models. All three have Sandisk 32GB SD cards. Upgrading from to was successful on one of them however the other two would not respond after the upgrade. Removing the SD cards made them work again. I tried reformatting the SD cards externally but any time the SD card was placed in the camera it would not respond in the app. Finally had to downgrade to to get them to work with the SD card again.

Thank you for reporting this issue. We will look into it. caused both my Pan cams to be completely unstable, they both now drop offline showing the 90 error code. They also seem to periodically reboot themselves tried resetting one of them but still same issue and reverting the firmware fails on them as well. So I basically have 2 bricked Pan cams until you send out a fixed firmware or send me so I can revert via the mSD card.

Thanks, one correction the downgrade was to not

My Pan camera is becoming very unreliable.

This morning it is back to night mode. On/Auto/Off setting have no effect.
Turning the camera Off/On through the Android app have no effect on the night mode problem.
I tried Restart Device through the Android app.
Now the camera is showing error code: 90.

Nothing that hasn’t been mentioned already, but I did a bulk upgrade of 3 v2s from to and 1 out of 3 failed. I tapped “Upgrade” again on the failed one but then it lost connectivity for abut 15 minutes (please reset camera, error -42). I tried connecting every 5 minutes and on the third try it connected, so everything seems to be working now.

Sorry to hear that. In the last update of firmware, we received several reports about night vision not working. We suspected it may be caused by the new IR Emission feature, much appreciate if you can send us device logs if the NV not working or IR not working stuff happens again.