Firmware downgrade

I need to downgrade from the current beta Cam Pan Firmware to the previous release. Is there a link to get it from? I’m needing to test an IR issue with the latest FW release.


Can you do it from the app?
Settings>Device info>Firmware upgrade>Have problem? >choose version



Got it.


Im on android app v2.3.16 and there is no “having problem?” in the firmware upgrade section. please advise

Howdy all,

Can I infer from this thread that if I install the RTSP firmware version for Wyze Cam Pan. I can later revert to the mainline firmware if there are features I want there that are not in the RTSP version? I suspect the answer is yes as long as the firmware is downloadable and the camera can be manually flashed, but I’d like to see comments before I commit to the RSTP firmware branch which they say will not be further developed after GA availibility.


Same problem on Apple iPhone

I’m trying to downgrade the Pan’s firmware since it doesn’t record anything. But I don’t find the setting “Have problem?” I guess regular users don’t get to downgrade them - just in the beta? Too bad, I was hoping to get these working today.

@KWLA, @stageautodealcuracao, @josephmatheney

The “having problem?” option was in a beta app version that no longer exists. To flash the firmware, you have to follow the link to the support site noted above.

Yes, you can revert to the production firmware after flashing RTSP by using the support site link noted above.

Does the MicroSD card need to be removed before downgrading and then upgrading again?

The firmware upgrade / downgrade is not dependent on the SD card being in place or not.

so i can leave the SD card in while i downgrade and then upgrade, ok thanks

No, firmware downgrade is a manual process that involves removing the SD card and putting the older firmware file on it. The card does need to be removed and connected to a computer to do this. Firmware upgrade can be done through the app and does not depend on the SD card being removed.

This is a dead link now. I’m having trouble finding a good description of how to manually install a particular firmware version.

Here’s Wyze Support . Just type “firmware” in the search box.

I didn’t find that link, or the suggestion to just search for it particularly helpful. I was specifically looking for how to install WyzeCam firmware when the usual method using the app doesn’t apply. In the meantime, I did find something helpful, in this thread: Stuck in RTSP Firmware, Can't Update Look for the reply by ilyakam .

Here you go:

Downgraded Firmware back to the November release for the Pan Cam and it fix this issue for me. 2020 Firmwares are broken just like this entire year has been!

My new Wyze Pan camera is on the latest Firmware and refuses to accept any other firmware. I tried the November 2019 and Jan 2020 releases from here and neither of them worked. I also tried the RTSP firmware from here
I know how to manually load firmware from V2 Cams in the past and it goes through all the steps (blue light after holding setup while booting). However, at the end of it all, it’s still on the same firmware. Any ideas?