Can’t upgrade to RTSP firmware on Wyze Pan

I am trying to upgrade the firmware of my Wyze Pan to the latest RTSP firmware that is version

I have tried 2 Wyze Pan using firmware and respectively.

I am following the instructions and to be frank they are not that complicated so I am not sure if it’s the Pans aren’t wanting to be upgraded anymore or if I’m truly doing something wrong which I don’t think is the issue. I’m out of options now. I only want to use the RTSP option so if I can’t get this working I will return it.

Try formatting the SD card you are using in a PC. using the deep, or full, format option. Sometimes the cards have issues even though they may function in another device or even in the Wyze cams. Overwriting and reformatting usually will fix that, or tell you you have a bad card.
It is crucial when flashing firmware to follow the setup-and-insert cord directions exactly, otherwise you don’t get flash you get essentially reset.
Failing that, try a Factory Reset, then try flashing the RTSP FW again.

I can’t format using a PC but can try using my Mac. I do believe I’ve followed those instructions to the letter at least to the best of my ability.

Mac will work -here is the industry standard recommended program for formatting them. Be sure not to use the quick format option.
The time holding down the reset is critical. Too long and you wind up with a factory reset, too short and you just reset the cam.
You didn’t say, but what is happening when you try? Once you succeed the Cam is still accessible and works thru the app - you just have the option to generate and copy an RTSP URL for use in other software.

Does this thread assist you at all, or make the instructions clearer?

1 Like

Very good point. I forgot to mention the ‘demo.bin.bin’ issue!

1 Like

I’m doing just that. I have extracted the firmware as it is a bin file and just renamed it to demo.

At the risk of offending or belaboring the obvious, you said rename to ’demo’ - it literally must be ’demo.bin’

The extracted file is already of extension .bin so I only need to rename to demo without changing the extension.


Well - I’m out of suggestions other than contacting
Wyze Support. You can open a ticket online or call in person. I have recently had good response via phone. Live support is available:
Monday - Friday 5 am - 6 pm PT

Saturday 8 am - 4 pm PT
Wish I could do more- please update us as to the outcome!

1 Like

What size SD card are you trying to use? I’ve experienced and heard that only 32s and 16s work for folks.

1 Like

That’s right I’m using a 32GB Sandisk A1

I just finished struggling with this. On a Mac, I formatted the Micro SD card as EX-FAT. I transferred the demo.bin file to the root directory. Inserted the card. Held the Setup button. Connected the power. The light would not turn blue and the camera would boot up normally and start moving around. If I kept holding the button, it would just perform a reset. I checked whether the camera could read/write to the SD card; and it could. I retried the operation a few times without any luck.

So then I reformatted the Micro SD card as MS-DOS (FAT), and repeated the steps above. This time the light turned blue and I was able to install the firmware.


Nice! Thanks for posting the update!

Very interesting. Some have recommended EX-FAT highly. I’ve never tried it. I use the SD Card Association Card Format Program and, so far, have not run into problems.

I’m not the OP but wanted to share my similar experience while using a mac.
I should also note I used a 2GB sd card. Hopefully that helps them.

1 Like