Pan RTSP Firmware Wont Flash

Hi, I am trying to flash RTSP firmware on the Wyze Pan and am having no luck. I successfully flashed it on two of my three V2 cams, (just havent tried the third yet). So I know the process, only changing out the different demo.bin file for the Pan specific one.

The Pan just continues to bootup like normal. Is there a different filename the Pan is looking for on bootup? Seems like several people are having the same issue that I am.

1 Like

I’ve got one here on my desk, and I just flashed a V2 a couple hours ago too. Let me give it a try and I’ll get back to you.

1 Like

Mine went smooth as butter and is working and streaming to VLC here. Just bought this new pan this week at Home Depot. Hereis the simple video I watched to do the flashing.

1 Like

Yeah I was able to flash two of my V2s, with the V2 RTSP Firmware.
It is only when I tried the Pan, with the Pan RTSP firmware that I encounter difficulties. Its like the Pan never checks for Firmware.

Extra steps I have tried, along with the entire process with each step. None of the below worked.
(edit: Clarification, these are EXTRA steps I tried, along with the full procedure, in an attempt to get the overall process to work. Please do not take this list as sequential steps to try.)

  1. Factory Reset the Pan
  2. Re-register the Pan to my account.
  3. Format the SD Card on the Pan
  4. Format the SD Card on Windows
  5. Format the SD Card on Windows Using the formatter.
  6. Change demo.bin to Demo.bin
  7. Hold until just after the light turns blue.
  8. Hold 2 seconds after the light turns blue.
  9. Hold 5-6 seconds after the light turns blue.
  10. Try a different SD Card (original is Wyze32GB), new as 32GB Samsung Evo Plus.
  11. Try normal, non RTSP firmware.
  12. Hold the button 30 seconds total, irregardless of blue light.
  13. Different Wyze Wall Charger
  14. Different Wyze USB Cable
  15. Re-downloaded the Pan RTSP Firmware (maybe corrupted?) and tried flashing again
  16. Tried copying the zip to the SDCard, and extracting from there, then renaming the file there, while it is on the root.

I had to do none of the above to get the RTSP to work on my V2’s. Why is the Pan problematic?
The fact that I was able to get the V2’s working, should prove that I know how to do it.

I reviewed the video you sent over and I am following precisely those steps.

Is there a different/another way I can force reset this Pan maybe? Or how else do I get it to check for a new Firmware file?


Sounds like you’ve done it exactly right. My pan was the exact same procedure as the V2 was. I’m guessing you could open a support ticket though I’m not exactly sure how you do that. But if you’re in a return window, I’d probably go that route unless anyone else has any ideas.

Side note, and I know this doesn’t help, but I had a V2 a couple weeks ago that would reset every time it lost power. I’d have to go through the whole QR code setup. So they can do screwy things.

Not sure if that was a typo in your steps, or not, but I’m pretty sure the process is case sensitive, so Demo.bin should actually be demo.bin.

I think you are right. All of the attempts, except one, were with demo.bin.
I found one post where someone was having a similar issue, but had typed it as Demo.bin. After several hours of trying this, I figured I would try it with cap, but it did not help.

I’m having the exact same problem with my PAN cams. Tried different cards, Used InitDisk( to format. Formatted on the cam. I tried many of the other steps mentioned above, with no joy. All of my V2s flashed without a hitch.

Same problem as Tarpanet: my Wyze Cam Pan will not correctly get the rtsp auto.bin file after holding the reset button and attaching the usb power. The camera starts orange, then flashes orange, then you get that “Ready to Connect” audio message.

Need rtsp for this camera to be useful to me. Wyze please fix asap. At least provide some information on when we can expect a fix please.

Update to my story: I have 6 PAN cams. The two I have been unable to flash, were bought at the same time, in Oct, 2018. The other 4 were bought months before, and when I tried to flash them, all 4 accepted the RTSP firmware with no problem. So, I’m assuming that something was different in the production run of the 2 that I can’t flash. Hence, it seems like a hardware issue. I imagine, there is no fix, at least via software.

I have recently purchased two Wyze Pans.

Thanks for info. It’s possible Wyze is too small a company to provide a reliable rtsp solution. Will research a different vendor if I don’t hear back from Wyze.

Hi all, thought I’d piggyback to this forum as I have another thread open where we believe we have identified an issue with a specific hardware model (S/N starts with F00) that has a bootloader and does not allow the pan to check for ANY firmware, and thus will not load any, RTSP or otherwise. Take a look, although I myself am still stuck some other users have had luck with a sideload bootloader workaround:

Ultimately Wyze clearly has an issue with the bootloader for specific hardware releases of the PAN that they either know about and are not putting the time into to correct… or they do not know, and hopefully with this post they may be able to action it. Seems like from our other post it should be an easy fix for them, here is hoping.

1 Like