Password Limitations for Mesh Router

Just setup a two pack of the Mesh Routers and ran into a problem (?) with the WiFi password. I’ve been using commas, apostrophes and other punctuation marks in the passwords for my older routers without any problems. However, the new mesh system doesn’t seem to work with those. Is there a list of what special characters work or don’t work wit the system?

2 Likes

The only one I know for sure that doesn’t work is the apostrophe ’ .

I do know that * @ " ! ? work… but only thru trial and error.

1 Like

Apparently a somewhat “known” issue at least on discord. This has been submitted as a “Fix It Friday” item over there.

1 Like

Thanks. I found that on discord in the fix-it-Friday post. Really unfortunate since that means I’ll need to reset many wifi devices to use the new routers.

1 Like

OUCH :persevere:

That stings.

@WyzeHerman --the router product manager is looking into this!

I just tagged him so he can see another example of someone finding the same bug.

5 Likes

Thanks. I saw that as well. I’m going to continue playing with them for now. Glad I got them on EBay for only $70.

:sunglasses:

1 Like

Is there an update on this? Do we know when this will be fixed? I’m waiting before I finish migrating over to the Wyze mesh routers. Either that, or I’ll need to reset everything, all 70+ Wyze devices. I’d rather not do that. So I’m hopeful it will be fixed soon.

Wyze included this issue in their Fix-it-Friday report for this month:

Then when asked why the apostrophe anti-compatibility was intentional, Jason said he’d try to find out:

2 Likes

Hopefully they explain why it was intentional for the apostrophe to be blocked. And hopefully it can be unblocked. And the sooner the better.

And THIS is a perfect example of why Wyze devices should be able to change the wifi config without factory resetting them. If I could do that, I would have no issue with changing the password. And I can reset all of my cameras, etc, and get the config back to what it was before, but Home Monitoring is my biggest issue. If I reset it, I’ll have to re-add every sensor I have, reconfigure them, and make sure all of my rules still work. This is a pain, and all because an apostrophe in a password is intentionally blocked…

1 Like

I agree with most of your post. However, you shouldn’t have to reset everything for Home Monitoring. You should be able to re-add the hub with a new wifi password and everything SHOULD work. I say should, but this is Wyze after all.

1 Like

I am wondering if the HMS Hub needs to be reinstalled on the new SSID\PW network at all… There may be a possible workaround loophole way to get it on the new WiFi network without any reinstall since the hub has both WiFi and Ethernet capability and a UI to change it’s WiFi connection.

For the sake of discussion, if you do have to change your SSID or Password for the Wyze Router Network to work, would this be possible? :point_down:

Unplug the hub while connected to the old router network by WiFi, run it on battery, move it near the new Wyze router, plug it back in, and connect the Hub thru the Ethernet port to the Wyze Router so that the SSID\PW are irrelevant. It should get a new IP and connect to the server, thereby accessible in your app.

Then, with your phone connected to the new SSID\PW Wyze Router Network and your GPS enabled, go into the Hub Settings, Device Info, Change Connection and select the new Wyze Router WiFi network SSID\PW. When you disconnect the Ethernet cable, it should then automatically connect to the new Wyze Router WiFi network without the need for any setup or reinstall since you just supplied it w\ new network credentials.

I haven’t done this, just thinking with my thumbs. So if there are any critical flaws in my theory, please feel free to point them out.

2 Likes

I completely forgot that it had an ethernet port. I’ll try that.

Thanks!

2 Likes

It didn’t work. The wifi settings are locked in and can’t be changed without doing a factory reset, which would then require all sensors to be readded.

For now, I’m going to plug it in via ethernet and not worry about wifi settings. But it would be nice for all of this to be fixed.

You should not have to do a factory reset and readd your devices. Doing a new setup install with the hub running nearby and GPS \ BT on should allow the resetting of the WiFi to the new SSID and PW. Because you aren’t doing a factory reset or deleting it from the app, there shouldn’t be any loss of function, settings, or sensors.

1 Like

But how does the hub know I’m trying to change its settings if I don’t reset it?

I tried repairing it (brief press of the reset button), but that didn’t allow me to change the wifi settings either. So, if that’s what you’re suggesting, that didn’t work either.

Don’t press any buttons [edit:] perform a factory reset on the hub. It doesn’t need any reset.

The hub shouldn’t need to know anything. All that gets pushed from the app. After you have the phone on the new SSID network, and you initiate a new Hub install setup, [edit:] (it does require one tap of the ‘Reset Button’ for “Ready to Connect”) the app initiates a BT connection to the hub. During that setup, after the app gets the new SSID and PW from the phone network settings and logs the GPS location, it then pushes those new settings to the hub via BT. Then the hub uses those settings to log into the WiFi and finalize the new setup.

Since the MAC of every device remains the same, all those devices remain installed, and all those devices remain in your settings on the server, they all stay in the app with their previous settings.

But the first step in doing a new setup install is to briefly press the button on the hub. Or are you saying to tell the app that I heard “ready to connect” even though I didn’t? I’m not seeing how the hub is going to allow anything to happen if it doesn’t even know I’m trying to change it.

And even if this does work, this is a big pain when all devices could be programmed to allow for wifi changes. Even if the router did allow for apostrophes, changing a wifi password is necessary at times. Wyze needs to fix this.

This seems to indicate that if I do reset it and add it without removing the hub from the app, everything would be retained, and it would incorporate the new wifi settings. But they don’t specifically say to factory reset it. Repairing doesn’t work. But I need someone to confirm if adding it, without deleting it, would actually retain sensors with a factory reset of the hub.

Did I mention that all of this is unnecessary when wifi changes could easily be implemented in the program/firmware?

Sorry for the confusion. I wasn’t being clear when I replied earlier.

There are 3 different uses for the hub “Reset Button”. (1) A short tap = Initiate Setup. (2) a long press just until the lights briefly dim and reset (3-5s) = Soft Reboot. (3) a longer press until the lights fully cycle (10s) = Factory Reset.

The third is the one you don’t want to do. Read below.

At the risk of my only working HMS Hub, I just confirmed the following:

You are correct, once the WiFi connection has been set within the Hub, it won’t let you use the Change Connection UI in Device Settings to modify the network.

I created and opened a Guest Network on my router with a unique SSID and Password. My Hub was attached to the router by Ethernet, so there was no WiFi yet set in the Hub. I used the Change Connection UI in the Hub Device Info Settings to assign the Hub to my Guest Network. I unplugged the Ethernet cable and the hub had no reaction. It immediately transitioned onto the Guest Network. I confirmed in the Router that it was connected by WiFi to the Guest Network.

I pressed the “Reset Button” for 5 seconds and the hub lights dimmed and then blinked and the hub rebooted quickly and logged back into the Guest Wifi. All sensors remained connected. No need whatsoever to reinstall any. All HMS Monitoring Settings related to the sensors also remained unchanged.

I then disabled the Guest Network in the Router. As soon as this happened, the Hub went offline (I got an alert push notification) and it started blinking.

I verified that my phone was connected to my primary network since the Guest Network had been disabled, verified BT and GPS was on, and I began a New Device Setup Install for a Wyze Sense Hub. I pressed the Setup Button briefly on the hub to get the “Ready to Connect” and I continued the install. Since the phone was on the primary network with the Guest Network disabled, the SSID and PW for the main network were pre-populated into the WiFi Credentials entry blocks. When the setup completed, the hub came online. I confirmed in the router that it was connected via WiFi and that it operated by arming and disarming the HMS. Again, all sensors remained installed and operational. No need to reinstall any. All HMS Monitoring Settings remained unchanged.

One anomaly that was revealed as a bug is in the Hub Settings Device Info page. Even though the Hub was confirmed to be connected to the Main Network by WiFi and the Guest Network disabled, the WiFi Network shown in the page still shows as the old Guest Network SSID even though it was verified as disabled and the hub verified as connected to the main network.

This confirms:

  • Like all other Wyze Products, the Hub can be reinstalled to a new SSID Network thru a new setup process without the loss and reinstallation of sensors as long as it is not deleted from the App.

  • Using the Reset Button for a short press “Ready to Connect” setup will not result in the loss and reinstallation of sensors.

  • Using the Reset Button for a longer 5s press Soft Reboot will not result in the loss and reinstallation of sensors.

You should be able to put the hub on the new Wyze Mesh Router Network without any issues so long as you don’t delete it from the app, your phone is on that same SSID network, and BT & GPS are enabled. With the old WiFi unplugged, disconnect the Ethernet from the hub, wait for it to go offline, start blinking, and send you the offline alert notification. Press the “Reset Button” once, go thru the setup, use the new WiFi SSID, and it should connect and give you three lights. Ignore what network it is telling you in the Device Info UI because that is wrong.

2 Likes