Nightmare setting up Wyze Vacuum on Wifi

I know I’m not alone with this post by searching this Forum and the internet. Prior to this, I have loved Wyze products and everything has been extremely easy to set up and use.

Does anyone have any tricks or suggestions that haven’t been mentioned so far to get the vacuum to connect? I have now spent 3 hours of my life troubleshooting a new product that should have been a very easy set up. It is extremely disappointing since I had very high expectations of another quality Wyze product.

Steps I have taken so far…

  • Ensure Wifi is only broadcasting 2.4 GHz
  • Restarted router
  • Restarted phone
  • Turned off phone Mobile Data
  • Disabled auto-reconnect Wifi on phone
  • Turned on Location Services for the Wyze app
  • Ensured I was connected to the correct Wifi access point before starting Wyze app
  • Ensured the WPA encryption key was correct
  • When selecting the WVCR_XXXX Wifi access point, phone warns no internet access, and instruct phone to stay connected anyway
  • Selected Forget WVCR_XXXX Wifi access point before starting the set up each time

Something that might help others further troubleshoot the problem… I noticed that after the Wyze app times out saying the vacuum could not connect, the two white lights on the buttons continue to flash white. The only way I’ve been able to get them out of this cycle is to press the power button to start vacuuming and then press the power button again to stop the vacuum from moving.

1 Like

You’ve done some great standard troubleshooting. I tried all of those for some devices (some with Wyze, and some with others) and still had problems, and was similarly frustrated to wits-end.

What kind of router are you using, and is it based on WRT firmware in any way (DD-WRT, Open-WRT, Gargoyle firmware, etc). Does your router have an option to disable the WMM (WiFi MultiMedia) option? If so, disable it. I was having an insane amount of trouble getting Wyze bulbs and Wyze Plugs to connect (though not 100% of the time) until I discovered this was causing the issue for me, and resolved it. I detailed some of my finding about this weird issue here:

That thread also has some suggestions others found to work (though they were dealing with bulb issues…but it seems to be very similar), though you have tried many of those suggestions. Since you have tried almost all the common things to resolve the issue (like I had tried), and it’s still not working, I am asking about your router because that’s what ended up being the culprit for me. I found it worked for some routers and not others.

Furthermore, I found sometimes I could do a loophole…activate it on a router that worked (using the same SSID/PW, etc then sometimes the devices would later connect to the main SSID I wanted them to after both were rebooted (though not always). If you don’t have other routers, you could try the following:

  1. Disable your WiFi Router.
  2. Have one phone broadcast a WiFi Hotspot using the same SSID/PW as the main WiFi Router.
  3. Using another phone, connect to the hotspot, activate the Vacuum through the set up, once it is set up, turn off the hotspot, turn on the Router, and see if it will now connect.

Let me know if either of those end up being helpful They are things that have worked for me in the past to trick devices into working when other steps you listed didn’t pan out. :slight_smile:


Mine would not set up with my iPad, I tried my iPhone and it worked. Once set up ipad also works

What’s your wifi ssid? Does it have any special characters? I don’t have a vacuum myself but I know special characters effect other Wyze products setups.

1 Like

POTENTIAL SOLUTION: Wyze has issues with their code for the vacuum. This is likely a software issue and hopefully not a hardware issue. Wyze is not accepting a passphrase of 63 characters. My current passphrase is 63 characters long and has the following special characters in it… * \ = ] { [ _ - : @ # ; } / % (
I changed the password to a shorter 25 character passphrase (including special characters) and the vacuum connected. This is definitely a passphrase character length issue.

Wyze / Gwen, I hope you read the forum postings. You have had this issue with previous new devices too and were able to resolve it with an app software update. Please try to fix the vacuum in a similar way. Thanks.

Thanks for the suggestions! I tried all three ideas and nothing worked.

To answer your questions…

  • I have a Ubiquiti router
  • WMM is not enabled
  • I have been able to set up 11 Wyze cameras, 5 light bulbs, and 8 oulets with no trouble so far. That is, until I received the vacuum yesterday
  • My SSID has 8 characters, all letters (two of them are capital)

Good to hear! Thanks for the update, it is always good to add to the knowledge base to be helpful to refer others to who have struggles. I totally forgot about the special character and password issues.

I’m glad you got it figured out. I agree, Wyze should be able to resolve it with an update.

I finally got the vacuum to connect. Although I am not 100% sure this was it, I went into my WiFi settings and disabled 5ghz. Then followed all the other suggestions again, and it worked! This is after spending 3+ hours trying everything. Make sure to disable cellular data too.

Took me a while just to figure out how to turn of Data on my cell phone (Half a day) then it hit me… something I have never used before… PLANE MODE . Than I tried pairing and TA-DA Paired There is a God !

Narrow focus from your knowledge base???

The password length solved my issue also. thanks.

Glad to have helped Krayg!

I’m really hopeful that Wyze will be fixing the length issue in their upcoming fix once its certified.

I tried the workaround you posted, and was excited when it immediately connected to the mobile hotspot; I was even able to have it download the firmware update. Disabled the hotspot and renabled the router (I also tried WMM both enabled and disabled) and it still wouldn’t connect.

I am using OpenWrt, and updated to the latest version (19.07.7) and reset all settings. Reconfigured the WiFi to use the same ssid and password (I kept all other WiFi settings as their defaults), and still no luck. I cannot figure out how to get this vacuum to connect to my router.

1 Like

Thanks for the response. I am definitely sorry the workaround didn’t work, but I am glad to hear some form of confirmation that there is something in the WRT-based firmware that so many IOT devices don’t like (others besides Wyze also have issues sometimes). Now, if we could only figure out what it is! Thank you for checking the WMM.

The good news, is that we’ve confirmed that the conflict is something to do with the router specifically since the IOT device will connect to your hotspot, and presumably other non-WRT routers. There are many possibilities…I know Wyze has mentioned some DNS issues and other stuff on some routers, but since you have WRT, I am guessing it has to do with that firmware. That’s not to say there aren’t workarounds…Lots of people have gotten them to work, though you might have to log into the router with something like putty and do some manual configuration on just the right options if they aren’t showing up in the GUI.

I did some research online for you and I am reading that some people have had luck disabling what’s called the LDPC, sometimes in addition to the WMM. Give that a try?

Others said to not disable WMM and “use CCMP only”

I’m reading that there is a big issue using some ESP based devices like the ESP8285 chips because of some static IP issue or something like that (fixed in later ESP8266 chips). I don’t know what chips Wyze uses, but this could mean it is something they cannot fix for certain routers if they are using this problematic chipset. I am reading of people finding ways to get their WRT routers to make it work still though.

Here’s a thread with a bunch of people confirming they got it to work by following some steps to manually set both the WMM and LDPC to 0:

That might help. Be aware, that I’ve read in other threads that some routers will automatically reset some of those manual settings back to 1 upon reboot, so if your router loses power, you might have manually redo that…though I don’t know 100% if that will be necessary.

Another workaround would be to use a separate cheap router for any devices with the flawed/picky IOT chipsets. Let them connect through the cheaper router (using a different channel number of course), and still have everything else go through the normally superior Open-WRT router.

Let me know if you figure out a good solution so we know how to help some other people in the future too. Sorry you’re having these issues. It’s frustrating to death, I know…As I said, I had a similar problem before and had to learn all this craziness. Wyze just needs to use different chipsets that fixed these compatibility issues…but I get that these were probably cheaper…

Unfortunately, turning off LDPC didn’t seem to help, either. As a last resort, I tried installing the stock Linksys firmware, and (unfortunately?) that immediately fixed it. I’ll try looking for/opening a support ticket with OpenWrt, because I’d really like to go back to that firmware.

1 Like

Sounds like a great move. Obviously it’s not the router itself, since the stock firmware works.

Somehow using OpenWRT based firmware has major issues with lots of IOT devices. So weird! I am really glad to hear you are opening a ticket so they can work on resolving this for all the OpenWRT branches too. I personally used Gargoyle firmware (based on OpenWRT) on a router and it was such a hassle with IOT devices I finally retired it. So frustrated because the firmware is so AWESOME! I hope an official ticket at the source will help get it figured out so future versions are fixed.

I’m not sure whether to say sorry or congratulations that you figured it out, but at least you have a working device now. Thanks for letting me know though. I was very interested in hearing what you discovered.

So, after getting the latest firmware update for my vacuum I decided to give OpenWrt 19.07.7 a try again, and it stayed connected this time!

At this point, I’m not sure whether flashing the original firmware first, and then switching back to OpenWrt is what actually fixed it (maybe the original firmware cleared a setting I had mis-configured), or if it was actually the vacuum’s firmware update. Either way, I’m happy it’s working together now!

Note: I had tried OpenWrt 21.02.0-rc1 first, but I had a lot of connection issues from all wifi clients on that version, which is when I decided to try 19.07.7 again.

1 Like

Cool update. That is interesting. I am a huge fan of OpenWrt-based firmware for routers, I wish they were more IOT-friendly though. It sounds like it shouldn’t be too hard for someone to figure out this particular issue since the old firmware allows things to work fine. Must be some bug in the newer firmware they haven’t fixed yet.

I figured I’d provide an update on this.

After working for a couple months, my vacuum decided to stop connecting again.

Once 21.02.0 stable was released (about a month ago), I tried updating to that version. After reading a bit on the OpenWrt wiki, I found out that you must disable 802.11w on the WRT3200ACM for the WiFi radios to work (this also means I couldn’t enable WPA3, either), which was likely the original issue I had when installing the release candidate.

My vacuum immediately connected again after the update, and it actually fixed a lot of other network issues I’ve had with other devices for a long time, specifically my printer and an LG TV. I normally had to regularly reboot the router to be able to connect to these devices; but I haven’t seen any connection issues at all since the update.