Wyze Bulb: unable to finish pairing, Connection timed out

Thank you, @muerte33, @DreadPirateRush.
Once I changed the length of SSID of the 2.4G to something much smaller like “4Wyze” the pairing went through. Once the firmware was upgraded, it was able to join any length SSID.

Everyone, appreciate your time and help here.

I am off to my actual Geofence project !

Happy Holidays.


Great news!!
I did not have the long SSID problem,
What solved my problem was to turn off wireless data on my phone.
It would be nice if Wyze could put up a sticky troubleshooting guide for bulb purchasers.
There are a LOT of problems that can trip you up on a bulb setup.
You know people that buy the 4 pack and have trouble with the first one get frustrated badly.

This is not a problem for all devices .
There is a troubleshooting guide with that info here

A search will also find info


If you have gotten this far and have not solved the issue, I may be able to offer a final suggestion. I literally spent hours determined to make these bulbs work using all the different ideas from this thread, in addition to getting Wyze support involved, who were ready to refund my money after nothing worked.I tried one last thing - I bought a repeater (Gallaway 1200Mbps wireless) and enabled it to run a 2.4ghz wifi channel with a unique SSID (the name or length didn’t matter) and then at last the Wyze bulbs synced immediately and I’m finally using them! … along with several Wyze cameras (that never had this issue). Hope this helps!

For anyone who still has issues, here’s what I did to get my 2 Wyze light bulbs connected on my Android phone.

Goal: 2 Light bulbs in one light fixture. You will need two fixtures available to power cycle for pairing process

Some background on my hardware:

  • Pixel 3 XL running version 10 with October update (still haven’t gotten latest updates form Google)
  • Wyze app version 2.7.19
  • Home router with 2 distinct 2.4 and 5 Ghz networks (XYZ and XYZ-5g for example). I have RCN modem + router combo. Some Ubee model, not sure the exact model number. I had standard wifi settings (no need to futz around with b/g/n settings


  1. You will need two light fixtures, one where the light bulb will live in and another to temporarily pair it to Wyze. Plug one light bulb in each fixture.
  2. Forget the 5Ghz network so you’re only connected to the 2.4 Ghz wifi network
  3. Turn off mobile data AND VoLTE. I found this in Setttings app → Network & Internet → Mobile Network (mine was T-Mobile). I also had data roaming off
  4. Launch Wyze app
  5. Start pairing first light bulb by toggling power 3 times
  6. Add light bulb product in Wyze app, and go through the process. It involves connecting to the light bulb Wifi access point. NOTE THIS AP NAME DOWN (so you don’t pair the wrong one by accident). It will eventually connect back to your 2.4 Ghz network since it needs internet data to finish pairing. This is normal
  7. Repeat the same procedure as above for the 2nd light bulb in a DIFFERENT FIXTURE. This is needed so the old light bulb does not forget it’s pairing when you initiate pairing again
  8. After both light bulbs are paired, you can turn off both light fixtures and move them both to your desired fixture. Power on and ensure remote control works

Hope this helped.


I had problems setting up the plug, with the same router/dd-wrt. Likely problem is AP isolation is always active, see this thread: DD-WRT :: View topic - "AP Isolation" always active
Been this way for quite some time

1 Like

Having the same issue here.
All other devices can connect but the bulbs and the plugs.
Mode Mixed
All the rest is default.
Was able to setup fine and they could reconnect fine even after several reboots. but after I had a downtime in my building I lost internet. When internet came back the bulbs and the plugs never worked again ( cam2 and lock were back up just fine like other IoTs)

1 Like

I had some issues with mine today I discovered they were the only devices not re-connecting after I did a reset on my router. Before the router reset and reboot I had set the mode from mixed to 802.11n only. This was the key to getting the bulbs tore-connect again.

I wanted to chime in on a solution I found with this issue for those who have tried several of the above suggestions and still have no luck (that’s what happened to me). I finally found a solution to my issue and figured I’d add to the knowledge-base here.

I spent well over 15 hours trying all of the above, and every variation of router setting I could find. I could get my bulbs to connect on another router, but not my main powerful router, though most other Wyze devices worked on it just fine (I had some problems with some Wyze plugs too though). It was driving me CRAZY! I knew it wasn’t the Wyze device specifically because I had some issues with some other bulbs in the past too…but it didn’t explain why some devices worked okay, just not others.

Finally, I stumbled on a post that indicated WRT-based routers were having some issues with IOT device connections for some weird reason.

This gave me an idea since I had replaced my router’s stock firmware with an Open-WRT based firmware (called Gargoyle-Router), so I wondered if that might be contributing to the issue. I then searched if anyone had posted about IOT device issues with Gargoyle and discovered that, indeed, someone else had been having similar problems (not with Wyze, but the issue was generalizable).

Someone said that the WiFi driver in [my] Linksys WRT32X device (at least while running Gargoyle) has some kind of issue. It was suggested to disable the WMM (WiFi Multimedia).

WMM? I wondered what that was and if this caused others issues in other routers too. I searched online and found that some other people were having IOT device issues caused by WMM on other routers too. Some IOT devices wouldn’t pair and some wouldn’t work at all if WMM was enabled. So the obvious solution was to just disable it.

The problem was that there was no option for me to disable WMM! I could disable normal QOS (Quality of Service / Bandwidth limitations), but not WMM, the option didn’t exist in the GUI anywhere! I finally knew what the likely issue was, but fixing it would be difficult.

One guy warned that if I disabled the WMM on my 2.4GHz SSID, I couldn’t get 802.11n speeds on that SSID network anymore (though I still would on the 5GHz…either way it wasn’t a huge deal since my internet wasn’t above 54mbps anyway). Still, it was suggested to create an extra “guest network” SSID on the router and disable WMM on that one, and just have all the IOT devices connect that. Then I would keep the N speeds on my primary 2.4GHz SSID, but the picky IOT’s like these Wyze Bulbs could still use the 2.4GHz on the Guest network. So I did this.

I then found and followed instructions to log into my router with PuTTY (a free SSH and Telnet client). After logging in to my router with PuTTY (I had to use an Ethernet Cord, not WiFi for some reason), in my case, for my router/firmware, the commands to disable the WMM on the guest network SSID were the following:

uci set wireless.ap_gn_g.wmm=0
uci commit wireless

I then tried to set up the bulbs again and this manually disabling the WMM worked! All Wyze bulbs/devices will now pair to my router and function correctly.

I mostly wanted to post this here for others in the future that are frustrated to wits-end (like I was) when all of the above suggestions still wouldn’t work for you. It may simply be that your router has a WMM issue preventing your Wyze bulbs from pairing/connecting. Consider searching for how to disable WMM for your particular router, maybe you’ll just have a simple GUI option to click to disable. If that doesn’t work for you, you could always try a different router too…that also worked for me, but my other routers were way less powerful with a weaker signal…so I wanted to figure out how to get it to work on the router I actually wanted it on.
Best wishes.


Thanks for such a detailed solution. I ran into a lot of problems installing bulbs over the last 12 months, but luckily this particular problem never plagued me. I do connect all my Wyze equipment to an ASUS RT-N16 running DD-WRT so it may not have the WIFI Multimedia enabled by default.
When you reboot your router do you have to go in and re-issue those commands, or is it just a problem when setting up the bulbs?

This post gets longer and longer, hopefully someone can condense it down into about 20 bullet items.
Thanks again!

I’m not sure of all of that yet. I read some people said it stays permanent, some said it changes back if you make any other changes (settings) to that SSID, someone thinks it resets if you reboot. But others said you have to actually manually set the wmm back to a 1 instead of a 0 or it stays off (which makes sense…,except that others claim it could switch on it’s own somehow, which I don’t understand…maybe changing settings somehow makes some subroutine refresh it back the way it thinks it is supposed to be?).

Maybe I’ll update more later once I have a better feel for the long term…all I know for sure is that doing that let me finally pair them and start using them (the main immediate concern), but I haven’t done a lot of testing on the long term concerns yet. I am considering upgrading my router anyway (I am nearing 50+ devices connecting to my router already…might need something more high end…

SOLUTION FOUND!!! I returned my crappy Wyze amazon purchase and got my money back! I shouldn’t have to waste hours of my day to get a light bulb to work. “How many hours does it take to screw in a lightbulb?” if your answer is more than ONE, the lightbulb is a waste of $$$. Maybe I’ll try Wyze’s product line again in 5-10 years when they’ve ironed out the bugs; my preference is to pay for and use a properly working product, and NOT to be a guinea pig beta tester bug hunter troubleshooter to get a room lit up.

1 Like

No problem pairing here :man_shrugging:t2:

No problem here either it takes less than 3 minutes.

I’m having the same issue it started once we upgraded to iOS 14 on iPhone

After much troubleshooting, I finally found a solution that worked on iOS 14:

  1. Launch Settings app, then go to Privacy | Location Services | Wyze. Allow Location Access to While Using the App and and Precise Location to On.
  2. Disable cellular data, either from Control Center or from Settings | Cellular | Cellular Data.
  3. Launch the Wyze app and start the usual pairing process.
  4. When asked to go back to Settings to select WiFi, be sure to click “i” next to Wyze bulb WiFi and unselect “Private Address”.
  5. Go back to the Wyze app. You should be able to continue finishing the setup process.
  6. Re-enable cellular data.

yes having same issue , tried manual flash spent ages with online suport , count less hrs tying to get it working , amazonvendor here in australia not overly helpfull

Having a heck of a time with these bulbs…tried ALL of the “solutions” posted above to no avail…what the heck?

I’m not a digital native, just an old lady who can follow directions like a champ. That being said, I don’t know how the heck to change my router (from G to N? I don’t even know what that means). I think this is just ridiculous. My BS meter says its not worth it for the 2 days of frustration I’ve been through to get this bugger to work. I’m done and I’m complaining to the management. (and I AM good at that)

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.